Access to attach button

VERIFIED FIXED in 2.1 S1 (1aug)

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: WDM, Assigned: azasypkin)

Tracking

({feature})

unspecified
2.1 S1 (1aug)
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.1, tracking-b2g:backlog)

Details

(Whiteboard: [tako][p=1][2.1-feature-qa+])

User Story

As  a user I want easy access to the attachment button by having the button closer to the keyboard so I can quickly hit the button.

AC1: I want attachment icon to be not on the keyboard but close to it

Attachments

(8 attachments)

Comment hidden (empty)
(Reporter)

Updated

4 years ago
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
User Story: (updated)
Keywords: feature
Whiteboard: [tako]
Note that this was how it was designed in v1.1 and was changed somewhen in v1.3 (bug 923023). We'll eventually need to settle.

Needs UX but really need VD before being actionable.
Flags: needinfo?(vpg)
Flags: needinfo?(jelee)
This is being worked on from VD. Will provide visuals soon but there's some work still remaining to solve the spacing left for the text input area when saving space for the button.

Not clearing NI as reminder. 

Remember all mockups and specs will be provided in a 2.1 messaging metabug where all changes related to this app should be gathered.

Comment 3

4 years ago
I'm ok with moving the attachment button to composer area. If that's what we are planning to do, I suggest we pull out the "call contact" function and place it on header (when there's only one recipient). Tks ;)
Flags: needinfo?(jelee)

Comment 4

4 years ago
Created attachment 8450049 [details]
[2.1 Message] Access to attach button v1.0.pdf

Hello, please see attached for the spec. Thanks!
Created attachment 8450122 [details]
Visual Mockup. SMMS_compose_0000_01.png
Flags: needinfo?(vpg)
Created attachment 8450123 [details]
Visual Mockup. SMMS_compose_0001_02.png
Created attachment 8450126 [details]
Visual Mockup. SMMS_compose_0004_invalid_field.png
Created attachment 8450127 [details]
Visual Mockup. SMMS_compose_0003_Longmessage.png
Created attachment 8450823 [details]
Visual Spec. Compose
Find attached visuals and specs for implementing the attachment icon new placing.

Cheers.
V
QA Contact: echang
QA Whiteboard: [Gaia::SMS]
QA Whiteboard: [Gaia::SMS] → [COM=Gaia::SMS]
QA Contact: echang → ashiue
Blocks: 1041725
Whiteboard: [tako] → [tako][p=1]
Target Milestone: --- → 2.1 S1 (1aug)
Assignee: nobody → b.mcb
Manuel, please note we took this in our sprint, this means we think the SMS team can handle this. So feel free to work on another work if you have some.
Assignee: b.mcb → nobody
(Assignee)

Updated

4 years ago
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Hey Fang,

Could you please provide us with the right image assets (1@x, @1.5x, @2x, @2.25x) for the new attachment button? 

Currently we have a white icon, but per spec color has changed + we didn't have @2x version for some reason.

Thanks!
Flags: needinfo?(fshih)

Comment 13

4 years ago
Created attachment 8462325 [details]
sms_icon_attachment .zip

Attached the new attachment icon at 1x 1.5x 2x 2.25x.
Flags: needinfo?(fshih)
(In reply to Fang Shih from comment #13)
> Created attachment 8462325 [details]
> sms_icon_attachment .zip
> 
> Attached the new attachment icon at 1x 1.5x 2x 2.25x.

Thanks Fang!
Setting dependency on bug 1043518 as patch for this bug based on the latest master is impossible to verify in full.
Depends on: 1043518
Created attachment 8462753 [details] [review]
GitHub pull request URL
Comment on attachment 8462753 [details] [review]
GitHub pull request URL

Hi Steve,

Here is the patch with attachment button VR. Could you please review it?

Thanks!
Attachment #8462753 - Flags: review?(schung)
Comment on attachment 8462753 [details] [review]
GitHub pull request URL

Patch looks fine, but the unit test seems broken in composer test after applied it. Could you please investigate the root cause?
Attachment #8462753 - Flags: review?(schung)
Comment on attachment 8462753 [details] [review]
GitHub pull request URL

(In reply to Steve Chung [:steveck] from comment #18)
> Comment on attachment 8462753 [details] [review]
> GitHub pull request URL
> 
> Patch looks fine, but the unit test seems broken in composer test after
> applied it. Could you please investigate the root cause?

Thanks for review! I've added "type=button" to the add attachment button element, so tests should be fine now.
Attachment #8462753 - Flags: review?(schung)
Comment on attachment 8462753 [details] [review]
GitHub pull request URL

Just one nit, so r=me :)
Attachment #8462753 - Flags: review?(schung) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/29b480349511a56f82eb53e2e82d28f7b98f518b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Depends on: 1046248

Updated

4 years ago
QA Whiteboard: [COM=Gaia::SMS] → [COM=Gaia::SMS][2.1-feature-qa+]

Comment 22

4 years ago
Hi Oleg,

I do not see the change of call button on header for single recipient when I tried on

Gaia      5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko     https://hg.mozilla.org/mozilla-central/rev/e6614d8d85f9
BuildID   20140803160202
Version   34.0a1

We should expect the change at this user story since the spec is defined on UX doc, right?
Flags: needinfo?(azasypkin)
(In reply to ashiue from comment #22)
> Hi Oleg,
> 
> I do not see the change of call button on header for single recipient when I
> tried on
> 
> Gaia      5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
> Gecko     https://hg.mozilla.org/mozilla-central/rev/e6614d8d85f9
> BuildID   20140803160202
> Version   34.0a1
> 
> We should expect the change at this user story since the spec is defined on
> UX doc, right?

Hi Alison,

Thanks for noticing! This bug was only about attachment button, but I've just filed a separate bug 1048717 for the "Call" button too.

Thanks!
Flags: needinfo?(azasypkin)

Updated

4 years ago
Flags: in-moztrap?(ashiue)

Updated

4 years ago
QA Whiteboard: [COM=Gaia::SMS][2.1-feature-qa+] → [COM=Gaia::SMS]
Whiteboard: [tako][p=1] → [tako][p=1][2.1-feature-qa+]
Tested and working
Flame
2.1
Gecko-329b2e4
Gaia-d688d4f
Status: RESOLVED → VERIFIED

Updated

4 years ago
Flags: in-moztrap?(ashiue) → in-moztrap?
QA Contact: ashiue

Updated

4 years ago
Flags: in-moztrap? → in-moztrap?(echang)
QA Contact: echang
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.