Closed Bug 1027287 Opened 5 years ago Closed 5 years ago

Intermittent browser_hotfix.js, browser_inlinesettings.js [@ nsSocketTransport::InitiateSocket()] "Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made"

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox30 --- wontfix
firefox31 --- fixed
firefox32 --- fixed
firefox33 --- fixed
firefox-esr24 --- fixed
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: RyanVM, Assigned: rstrong)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=41986662&tree=Mozilla-Inbound

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test mochitest-browser-chrome-3 on 2014-06-18 12:57:06 PDT for push 8cf3aebcaeeb
slave: talos-mtnlion-r5-028

13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821734	addons.update-checker	WARN	Request failed: http://127.0.0.1:8888/extensions-dummy/updateBackgroundURL - 404: Not Found
13:03:41     INFO -  1403121821735	addons.update-checker	WARN	Request failed: http://127.0.0.1:8888/extensions-dummy/updateBackgroundURL - 404: Not Found
13:03:41     INFO -  1403121821736	addons.manager	DEBUG	onUpdateFinished for {972ce4c6-7e08-4474-a285-3208198ce6fd}
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821734	addons.manager	DEBUG	onUpdateFinished for special-powers@mozilla.org
13:03:41     INFO -  1403121821736	addons.update-checker	DEBUG	Requesting http://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.rdf
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821734	addons.update-checker	WARN	Request failed: http://127.0.0.1:8888/extensions-dummy/updateBackgroundURL - 404: Not Found
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821734	addons.manager	DEBUG	onUpdateFinished for mochikit@mozilla.org
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821735	addons.update-checker	WARN	Request failed: http://127.0.0.1:8888/extensions-dummy/updateBackgroundURL - 404: Not Found
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821735	addons.manager	DEBUG	onUpdateFinished for indexedDB-test@mozilla.org
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821735	addons.update-checker	WARN	Request failed: http://127.0.0.1:8888/extensions-dummy/updateBackgroundURL - 404: Not Found
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821736	addons.manager	DEBUG	onUpdateFinished for {972ce4c6-7e08-4474-a285-3208198ce6fd}
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821736	addons.update-checker	DEBUG	Requesting http://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.rdf
13:03:41     INFO -  1403121821747	addons.update-checker	DEBUG	Found an update entry for hotfix@tests.mozilla.org version 1.0
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821747	addons.update-checker	DEBUG	Found an update entry for hotfix@tests.mozilla.org version 1.0
13:03:41     INFO -  1403121821748	addons.manager	DEBUG	Downloading hotfix version 1.0
13:03:41     INFO -  1403121821749	addons.manager	DEBUG	Background update check complete
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821748	addons.manager	DEBUG	Downloading hotfix version 1.0
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821749	addons.manager	DEBUG	Background update check complete
13:03:41     INFO -  1403121821750	addons.xpi	DEBUG	Download started for https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-ovo.xpi
13:03:41     INFO -  1403121821751	addons.xpi	DEBUG	Download of https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi completed.
13:03:41     INFO -  1403121821763	addons.xpi	DEBUG	Verifying XPI signature
13:03:41     INFO -  1403121821767	addons.repository	DEBUG	cacheAddons: enabled false IDs ["hotfix@tests.mozilla.org"]
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821750	addons.xpi	DEBUG	Download started for https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi to file /Users/cltbld/Library/Caches/TemporaryItems/tmp-ovo.xpi
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821751	addons.xpi	DEBUG	Download of https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi completed.
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821763	addons.xpi	DEBUG	Verifying XPI signature
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821767	addons.repository	DEBUG	cacheAddons: enabled false IDs ["hotfix@tests.mozilla.org"]
13:03:41     INFO -  1403121821773	addons.xpi	DEBUG	Starting install of hotfix@tests.mozilla.org from https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821773	addons.xpi	DEBUG	Starting install of hotfix@tests.mozilla.org from https://example.com/browser/toolkit/mozapps/extensions/test/browser/signed_hotfix.xpi
13:03:41     INFO -  1403121821776	addons.xpi	DEBUG	Addon hotfix@tests.mozilla.org will be installed as a packed xpi
13:03:41     INFO -  Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made.  You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
13:03:41     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | Console message: 1403121821776	addons.xpi	DEBUG	Addon hotfix@tests.mozilla.org will be installed as a packed xpi
13:03:42     INFO -  TEST-INFO | Main app process: killed by SIGHUP
13:03:42  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | application terminated with exit code 1
13:03:42     INFO -  INFO | runtests.py | Application ran for: 0:04:02.161007
13:03:42     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/kp/d3gspp5n44dgvr_5sd53dvhr00000w/T/tmp2PICmUpidlog
13:03:42     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1403116415/firefox-33.0a1.en-US.mac.crashreporter-symbols.zip
13:04:08  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_hotfix.js | application crashed [@ nsSocketTransport::InitiateSocket()]
Summary: Intermittent browser_hotfix.js "Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made" → Intermittent browser_hotfix.js, browser_inlinesettings.js "Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made"
Ben, how hard is turning off the updater during tests?
Flags: needinfo?(bhearsum)
Duplicate of this bug: 1030091
Summary: Intermittent browser_hotfix.js, browser_inlinesettings.js "Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made" → Intermittent browser_hotfix.js, browser_inlinesettings.js [@ nsSocketTransport::InitiateSocket()] "Non-local network connections are disabled and a connection attempt to aus4.mozilla.org (63.245.217.219) was made"
(In reply to Nathan Froyd (:froydnj) from comment #12)
> Ben, how hard is turning off the updater during tests?

Seems like it would just be a pref flip. That'd probably happen in the test harnesses (eg, automation.py or whatever) rather than in RelEng code though.

I think whether or not we want to do that is a bigger question though. There was a newsgroup thread about this recently: https://mail.mozilla.org/pipermail/firefox-dev/2014-May/001727.html
Flags: needinfo?(ted)
Flags: needinfo?(jmaher)
Flags: needinfo?(bhearsum)
(In reply to Ben Hearsum [:bhearsum] from comment #49)
> I think whether or not we want to do that is a bigger question though.

We can either:
a) Disable the updater
b) Leave the updater enabled, but use a dummy URL in automation

We already do (b) for telemetry, so that seems like an acceptable solution here. What isn't acceptable is hitting the network during automation, so we need to do at least one of the above.
Use a dummy update URL in automation, in case tests (eg browser_hotfix.js) toggle app.update.enabled and the timer happens to fire between that test's setup and cleanup. I've only set it in a proportion of the locations mentioned in bug 1023483, since most suites don't toggle app.update.enabled (and I'm hoping bug 1023483 will unify a bunch of these prefs anyway).
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Attachment #8451630 - Flags: review?(bhearsum)
Ed has handled this!
Flags: needinfo?(ted)
Flags: needinfo?(jmaher)
Comment on attachment 8451630 [details] [diff] [review]
Use a dummy app.update.url during automation

Review of attachment 8451630 [details] [diff] [review]:
-----------------------------------------------------------------

I'm going to have to defer to others on this. I don't understand the full implications, and there's question about whether or not it's wanted.
Attachment #8451630 - Flags: review?(robert.strong.bugs)
Attachment #8451630 - Flags: review?(gavin.sharp)
Attachment #8451630 - Flags: review?(bhearsum)
Though it is easy to use a dummy url there is also other code that can display ui after 'x' number of update failures that can't be disabled via a pref. The better solution would be to do what we've always done (at least for update tests) which is make it so any test that enables the app.update.enabled pref to disable the pref (e.g. cleanup) after it is done.
Looking at the test it appears that setting the dummy url in the test itself should be sufficient. That way if other tests start enabling app update it will be caught.
Attached patch bug1027287Splinter Review
Assignee: emorley → robert.strong.bugs
Attachment #8451630 - Attachment is obsolete: true
Attachment #8451630 - Flags: review?(robert.strong.bugs)
Attachment #8451630 - Flags: review?(gavin.sharp)
Attachment #8451839 - Flags: review?(dtownsend+bugmail)
Attachment #8451839 - Flags: review?(dtownsend+bugmail) → review+
Thank you :-)
https://hg.mozilla.org/mozilla-central/rev/f28f4ef4bdbe
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
See Also: → 1131725
You need to log in before you can comment on or make changes to this bug.