Closed Bug 1027633 Opened 8 years ago Closed 8 years ago

Overscrolling the music list compresses towards the left edge instead of towards the middle of the list

Categories

(Core :: Panning and Zooming, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
2.0 S5 (4july)
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected
b2g-v2.1 --- fixed

People

(Reporter: cwiiis, Assigned: vingtetun)

References

Details

Attachments

(1 file)

If you overscroll the list of songs in the music player, the effect causes it to compress towards the edge of the screen instead of compressing to the middle like it does elsewhere.

I imagine this is a side-effect of the layout of the music app, but filing this bug against apz for now for investigation.

Video: https://www.dropbox.com/s/22s1awk7pjq8uvb/VID_0001.3gp
I took a quick look at the music player layout in the app manager. I think this is a result of overscroll not playing well with CSS transforms. When you are in one of the tabs other than the "tiles" tab (which is the leftmost icon in the bottom row of tabs) then there is a transform:translateX(-100%) applied to one of the parent divs (div id="views"). That is probably what is throwing off the overscroll.
Unsure if this affects 2.0 (although it probably does). This should be a blocker, I think.
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → ?
blocking-b2g: 2.0? → 2.1?
We should fix this, and if the fix is simple enough, do the uplift to 2.0.  I don't see it blocking the release though, not even 2.1.
Assignee: nobody → botond
blocking-b2g: 2.1? → ---
Flags: needinfo?(botond)
blocking-b2g: --- → backlog
Attached patch bug1027633.patchSplinter Review
Simple css fix. Wilson let me know if it has side effects.
Attachment #8447135 - Flags: review?(wilsonpage)
Thanks Vivien; if this works, lets make sure we ask for the uplift and get this into 2.0/Aurora
Flags: needinfo?(botond)
Please make sure to also file a follow-up bug to fix this on the platform side, and have it block bug 1020045. I don't think there's any other bug tracking this issue at the moment.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Please make sure to also file a follow-up bug to fix this on the platform
> side, and have it block bug 1020045. I don't think there's any other bug
> tracking this issue at the moment.

Will do for sure.
Comment on attachment 8447135 [details] [diff] [review]
bug1027633.patch

Carrying squib r+.

I navigated around in the app and everything seems to works fine for me.
Attachment #8447135 - Flags: review?(wilsonpage) → review+
Target Milestone: --- → 2.0 S5 (4july)
I un-applied the Gaia fix on master and retested this, and could not reproduce the issue.

I suspect, based on the description of the problem, that the underlying platform issue was bug 1035598, which has since been fixed.

In any case, there is no need to file another bug (as requested in comment 8) now.
No longer depends on: apz-css-transforms
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.