Closed Bug 102831 Opened 23 years ago Closed 20 years ago

if focus is the url bar, ctrl-f4 does not close the topmost tab

Categories

(SeaMonkey :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0a1

People

(Reporter: joschi, Assigned: csthomas)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file, 2 obsolete files)

1. ctrl-t to create a new tab
2. click in the url bar
3. press ctrl-f4 and the tab will not close
Blocks: 55416
->andreww, without whom this would fall off our schedule.
Assignee: hyatt → andreww
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → mozilla0.9.8
*** Bug 110910 has been marked as a duplicate of this bug. ***
note to self - ctrl(cmd) w and t are defined globally in navigator.xul whilst 
ctrl f4 is in the binding. Move that out to exist at same location as T and W
adjusting milestone
Target Milestone: mozilla0.9.8 → mozilla0.9.9
patch ready for review
Keywords: review
I would rather that this just be handled automatically by tabbrowser. Perhaps
the Ctrl-F4 keyhandler in tabbrowser should be a capturing handler
Target Milestone: mozilla0.9.9 → mozilla1.0
Target Milestone: mozilla1.0 → Future
Keywords: review
Why does Ctrl+W work but not Ctrl+F4?
*** Bug 139846 has been marked as a duplicate of this bug. ***
Seeing this on 20020421 Linux. Btw: under unices ctrl-w is already taken for
deleting words when inside text fields so this shortcut will not close a tab
from the location bar.

OS+Platform -> All
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 145998 has been marked as a duplicate of this bug. ***
I filed this as 139846, but it appears to be the same problem, with a slightly
different trigger.  I was requested to add my description with the alternate way
of getting into this state:

If a tab is opened but the URL points to a file that just gets a 'save as'
dialog, the tab opens to 'about:blank'.  If you attempt to close that tab with
ctrl-f4, it won't close.  You can close it by clicking the <X> (close tab) button.

If you just open 'about:blank' in a new tab, you can close it normally.

Reproducible: Always
Steps to Reproduce:
1. Open a page with a downloadable .exe file (e.g., go to
http://download.com.com/3002-2098-911823.html?tag=dir )
2. Right-click on the link (www.microsoft.com for the above)
3. Choose 'open in new tab'
4. Observe new tab opens ("Untitled")
5. When "Save as" dialog appears, just click 'cancel'
6. Observe that the new tab remains open
7. Click on the tab (to bring it to the front if you have tabs opening in the
background)
8. Press Ctrl-F4 to close the tab (tab remains open)
9. Click the <X> button to close the tab (tab closes)

Expected Results:  Ideally, if a new tab (or new window) just results in a file
to save, instead of sticking around with about:blank displayed, the new
tab/window should close automatically...

Second best would be to make ctrl-f4 work correctly.

Additional note:

After getting a tab in this state, if I click to select the tab, then click in
the "content" frame, I can then close the tab with ctrl-f4.
See also bug 114170, ctrl+pgup/pgdn (to switch tabs) doesn't work with focus in
url bar.
Blocks: 114170
nominating...
Keywords: access, nsbeta1
No longer blocks: 114170
*** Bug 170362 has been marked as a duplicate of this bug. ***
Nav triage team: nsbeta1-
Keywords: nsbeta1nsbeta1-
Still a problem as of build 2003021008 (1.3b).

Dan
*** Bug 232708 has been marked as a duplicate of this bug. ***
*** Bug 251600 has been marked as a duplicate of this bug. ***
Attachment #67183 - Attachment is obsolete: true
Ctho, could you possibly merge the bindings so there are no differences?  May as
well start converting to toolkit, and here is as good a place as any.
I should note... tabbox.xml in firefox misses the ability to show a "New Tab" button
(In reply to comment #20)
> Ctho, could you possibly merge the bindings so there are no differences?  May as
> well start converting to toolkit, and here is as good a place as any.

That's actually why I'm working on this - I was diffing the various tab files
and found the fixed Firefox bug.

(In reply to comment #21)
> I should note... tabbox.xml in firefox misses the ability to show a "New Tab"
button

Yeah, that's the next thing I'll have to figure out.  After this bug is fixed,
that will be the only difference between the tabbox.xml files.
Status: NEW → ASSIGNED
Whiteboard: [cst: active]
Target Milestone: Future → mozilla1.9alpha
Attached patch patch (obsolete) — Splinter Review
Firefox works without a capturing event listener... I've attached a patch to
change firefox in bug 282178.
Attachment #175498 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #175498 - Flags: review?(timeless)
Comment on attachment 175498 [details] [diff] [review]
patch

Patch is malformed. Also the added code in the destructor does not belong in a
loop.
Attachment #175498 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview-
Attachment #175498 - Flags: review?(timeless) → review?
Attached patch fixed patchSplinter Review
Sorry, I don't know what I did to the other patch.
Attachment #175498 - Attachment is obsolete: true
Attachment #175604 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #175604 - Flags: review?(timeless)
Comment on attachment 175604 [details] [diff] [review]
fixed patch

Although I wonder if Ctrl+F4 would be better served as a <key> in
navigatorOverlay.xul
Attachment #175604 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
Comment on attachment 175604 [details] [diff] [review]
fixed patch

please file a bug to remove this from the mac target
Attachment #175604 - Flags: review?(timeless) → review+
QA Contact: firefox → stephend
Whiteboard: [cst: active] → checkin
checked in
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: checkin
Verified FIXED for me using build 2005-04-05-06 on Windows XP Seamonkey trunk.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
Target Milestone: mozilla1.9alpha1 → seamonkey2.0a1
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: