Closed Bug 1028374 Opened 6 years ago Closed 5 years ago

[B2G][Lockscreen] Device locks automatically after only a few seconds

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 wontfix)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- wontfix

People

(Reporter: astole, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file logcat
After locking the screen once, the device will automatically lock in about 7 seconds even though the screen timeout is set to 1 minute.

Repro Steps:
1) Update a Flame to BuildID: 20140620040204
2) Using the power button, lock the screen
3) Unlock the screen
4) Wait for screen to timeout

Actual:
Screen timeouts very quickly

Expected:
The screen timeouts after the amount of time listed in the screen timeout menu

2.1 Environmental Variables:
Device: Flame 2.1
BuildID: 20140620040204
Gaia: ccd70903544486bea04e85d8a4aacf63f1de2a72
Gecko: bdac18bd6c74
Version: 33.0a1
Firmware Version: v121-2

Repro frequency: 2/2, 100%
See attached: logcat
This issue does not repro on the latest 2.0 on Flame. The call log displays correct information.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140620000202
Gaia: c5dd47e3f9e18872961946735fdbc071a1656ac9
Gecko: 71b1b4b0850c
Version: 32.0a2
Firmware Version: v121-2



2.1 User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Josh - If a bug gets flagged as a regression, then you need to triage it to determine if it's a blocker or not.
Flags: needinfo?(jmitchell)
nomming as a blocker - lock-screen is a prominent feature seen by almost any user and when it is not working properly will add a high degree of frustration for the end-user.
blocking-b2g: --- → 2.1?
Flags: needinfo?(jmitchell)
QA Contact: jharvey
Duplicate of this bug: 1028186
Duplicate of this bug: 1028315
B2G Inbound Regression Window

Last Working

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140619025733
Gaia: 210754620ef706662c3379eb9fbb53c6e5b21baa
Gecko: 2ef5d1687f05
Version: 33.0a1 (2.1 - Master)
Firmware Version: v122

First Broken
Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140619031241
Gaia: fa1ecd7f9703b6061e6b0a63bc160069ebd91b1f
Gecko: 2c7d7b1d8eb6
Version: 33.0a1 (2.1 - Master)
Firmware Version: v122


Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 210754620ef706662c3379eb9fbb53c6e5b21baa
Gecko: 2c7d7b1d8eb6

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: fa1ecd7f9703b6061e6b0a63bc160069ebd91b1f
Gecko: 2ef5d1687f05

Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/210754620ef706662c3379eb9fbb53c6e5b21baa...fa1ecd7f9703b6061e6b0a63bc160069ebd91b1f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Broken by bug 970824.

Greg - Given this is a pretty bad regression making trunk hard to use right now, can you backout?
Blocks: 970824
Flags: needinfo?(gweng)
I strongly guess this is because some thing was missed in the progress of patching the ScreenManager in that bug. Unfortunately I'm taking a trip until 6/29, so there is no stable network to let me do the investigation, nor to back out the patch. So if this is emergent please back it out for me, thanks.
Flags: needinfo?(gweng)
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #8)
> I strongly guess this is because some thing was missed in the progress of
> patching the ScreenManager in that bug. Unfortunately I'm taking a trip
> until 6/29, so there is no stable network to let me do the investigation,
> nor to back out the patch. So if this is emergent please back it out for me,
> thanks.

Tim - Can you find someone else to backout the suspected patch here? This is rendering the trunk build nearly unusable right now, so I'd like to get the root cause out of the build.
Flags: needinfo?(timdream)
Fixed by backout bug 970824.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(timdream)
Resolution: --- → FIXED
FWIW, I suspect the fix is easy (maybe just a smallish typo) compare to the backout commit, however judging by the severity I decide to simply do a backout.
Duplicate of this bug: 1030454
blocking-b2g: 2.1? → 2.1+
This issue is occuring in today's build

Environmental Variables:
Device: Flame Master
Build ID: 20140725034810
Gaia: 3a06aa58245eaf848242d6d1497c1af536fffabd
Gecko: 6c0971104909
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
closing this to open a new bug instead
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Bug 1044270 was opened for this issue. https://bugzilla.mozilla.org/show_bug.cgi?id=1044270#c2 states that this issue is not considered a bug and closed as wontfix. Changing status of flags and bug to verified wontfix for this issue as well.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Resolution: FIXED → WONTFIX
Status: VERIFIED → RESOLVED
blocking-b2g: 2.1+ → ---
Closed: 6 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.