Apps with an origin unable to be installed from alternate marketplace

RESOLVED DUPLICATE of bug 960601

Status

Firefox OS
Runtime
RESOLVED DUPLICATE of bug 960601
4 years ago
4 years ago

People

(Reporter: ozten, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Steps to Reproduce

1) Using a test device*
2) Provision the device to trust BetaFox. Instructions http://d2gk.co/help
3) Install "Jongla IM" from BetaFox

    http://d2gk.co/app/v/47/install/shout%40ozten.com%2CJongla%20IM

Actual:

    E/GeckoConsole(    109): Content JS INFO at   app://system.gaiamobile.org/js/app_install_manager.js:354 in   ai_handleDownloadError: downloadError event, error code is   INVALID_PACKAGE

Expected:
Should launch and be usable.

Background:
I've edited the manifest and removed the origin and everthing works in that version:

    http://d2gk.co/app/v/56/install/shout%40ozten.com%2CJongla%20IM

This bug was found here https://github.com/mozilla/betafox/issues/38

What is BetaFox? https://wiki.mozilla.org/Mobile/Projects/BetaFox

* Use a device you can re-flash and not your dogfood phone. We'll provision it and to revert back to production marketplace, you will need to re-flash!
(Reporter)

Updated

4 years ago
Blocks: 1004611
I can install http://d2gk.co/app/v/60/install/clouserw%40gmail.com%2CMarketplace on my device.  Flame, 1.3.0.0-prerelease, build from June 11th.
(Reporter)

Comment 3

4 years ago
Krupa setup a Flame with the same version of FxOS as Wil, but her device didn't work.

So this bug appears only on some Flame's.

It appears on all devices I have access too.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1033155
When we throw INVALID_PACKAGE, we also log a more detailed error in the console. Maybe the error could give a hint about what's happening.
(Reporter)

Comment 6

4 years ago
I just tested my personal Flame that I just got from everbuying.com with the stock OS.

I'm able to install and this bug doesn't reproduce.

I'll try another device, to get marco better logs.
(Reporter)

Comment 7

4 years ago
Created attachment 8456313 [details]
marketplace_logcat_unagi.txt

Reproduced with an unagi

1) ./provision-betafox.sh full_unagi http://d2gk.co

2) Load http://tinyurl.com/olz9sc2 on the device

3) Install

Attachment is lolcat with INVALID_PACKAGE error message and surrounding log lines
Attachment #8456313 - Flags: feedback?(mar.castelluccio)
Comment on attachment 8456313 [details]
marketplace_logcat_unagi.txt

I can't reproduce on my ZTE Open, I'll try with a Flame. A copy of your Webapps.jsm file would be useful (the error is on line 2909, I'd like to see what's there :D).

You could grab a copy by doing:
1) adb pull /system/b2g/omni.ja
2) unzip omni.ja -d ./dir
3) You'll find the file in ./dir/modules/Webapps.jsm
Attachment #8456313 - Flags: feedback?(mar.castelluccio)
Flags: needinfo?(ozten.bugs)
(Reporter)

Comment 9

4 years ago
Created attachment 8456935 [details]
Webapps.jsm

Thanks for the detailed instructions!
Here is my Webapps.jsm
Flags: needinfo?(ozten.bugs)
Created attachment 8457625 [details]
modified Webapps.jsm

Unfortunately it wasn't so helpful. Could you reproduce again using this modified Webapps.jsm file? (you should be able to push it via 'adb push')

Basically I've enabled detailed logging and I've made the error be reported with a stack trace.
(Reporter)

Comment 11

4 years ago
Created attachment 8457646 [details]
marketplace_lolcat_debug.txt

    mv ../Webapps_updated.jsm modules/Webapps.jsm
    zip ../omni3.ja `find .`
    adb push ../omni3.ja /system/b2g/omni.ja
    adb remount
    adb push ../omni3.ja /system/b2g/omni.ja
    adb reboot
    adb lolcat -c
    adb lolcat > marketplace_lolcat_debug.txt
This is much better!

This is bug 960601, that was a regression from bug 910815.

According to bug 960601's flags, this should be fixed in 1.3.
(Reporter)

Comment 13

4 years ago
Marco, you are amazing. Thank you so much.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 960601
You need to log in before you can comment on or make changes to this bug.