animations stop after 1.5 hours

VERIFIED DUPLICATE of bug 6525

Status

()

Core
ImageLib
P3
normal
VERIFIED DUPLICATE of bug 6525
19 years ago
18 years ago

People

(Reporter: pnunn, Assigned: pnunn)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

19 years ago
see bug#2148, for originating bug.
(Assignee)

Updated

19 years ago
Target Milestone: M9

Comment 1

19 years ago
I'm going to leave today's builds on all 3 platforms running over the weekend on
http://slip/projects/marvin/complex/image_aligned_above_table.html.

(Will report results Saturday afternoon or Monday AM.)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
Being a geek, I came in to check today, and the animations which I started Friday
evening before leaving for home also stopped on Mac OS and Win32 (4.14.99 builds)

So, I confirm that this is a problem on all 3 platforms.

Comment 3

19 years ago
*** Bug 7942 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
[Note to self: check 9427 when verifying this bug.]
(Assignee)

Comment 5

19 years ago
eli:
Please check this again on Mac.
-pn
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
I just noticed the note that this was
verified as a problem on all 3 platforms.

I'm not seeing the problem on NT.

closing so it can be tested by Eli.
-pn

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 7

19 years ago
Re-opening. ;) Sorry. ;(

I left it running for an hour during the XPApps meeting, and Mac had frozen after
an hour. (Win NT had no effect, although it may just require more time. Didn't
try UNIX, but can.)

Updated

19 years ago
Target Milestone: M9 → M10

Comment 8

19 years ago
m10 for more study.

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 9

19 years ago
[The animation on Win NT finally halted after 2 hours; the throbber continues to
throb, however.]

Updated

19 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 10

19 years ago
Changing platform and OS to All (to reflect the fact that this is also
reproducible on NT).
(Assignee)

Comment 11

19 years ago
*** Bug 9427 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 12

18 years ago
*** Bug 1031 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

18 years ago
*** Bug 6525 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Depends on: 15817
(Assignee)

Comment 14

18 years ago
This is probably the result of memleak described in #15817.
Not marking as duplicate yet.
(Assignee)

Comment 15

18 years ago
*** Bug 14250 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
[Note to self: When verifying this bug, please be sure to confirm that all bugs
reports marked as duplicate are in fact also fixed.]
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 17

18 years ago
This can now be marked a duplicate of 15817. The gifdecoder instance
leaks.

*** This bug has been marked as a duplicate of 15817 ***

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 18

18 years ago
Rubber-stamping verified as duplicate; left note in 15817 to double-check this
bug as part of verification.

Comment 19

18 years ago
elig - if this is a verified dup, why is it Reopened/Duplicate.  Should it not be
Verified/Duplicate?

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
...because I was going through a lot of bugs and made a click-o.

Updated

18 years ago
Status: VERIFIED → REOPENED

Comment 21

18 years ago
Now that 15817 is fixed, I'd like to look at this one a bit more. Re-resolving
as duplicate so that it goes into my in-queue.

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago

Comment 22

18 years ago
re-resolving as duplicate...

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 23

18 years ago
Re-opening. Attached test case freezes on Linux after about 1.5 hours using
2000010608 build. (Can check Win32/Mac OS overnight if you'd like.)

Updated

18 years ago
Resolution: DUPLICATE → ---
(Assignee)

Updated

18 years ago
Target Milestone: M11 → M16
(Assignee)

Updated

18 years ago
Summary: probable memleak that accumulates after several hours, stops animation → animations stop after 1.5 hours
(Assignee)

Comment 24

18 years ago
Changing summary. gif memleaks have been plugged.
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 25

18 years ago
This is a duplicate of 6525.

*** This bug has been marked as a duplicate of 6525 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 26

18 years ago
Verifying as duplicate.

Of course, the bugs marked duplicate of 6409 will now just get verified when 6525
is fixed.
You need to log in before you can comment on or make changes to this bug.