[Dialer][Conference] Conference call status bar is invisible, can't exit conference call view

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: drs, Assigned: drs)

Tracking

({regression})

unspecified
2.0 S5 (4july)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
STR:
1) Get into a state where you have 2 active calls.
2) Merge those calls.
3) The conference call status bar is missing.

Cursory note from my bisecting/debugging:
I believe this is a regression from the last 2 weeks or so, but I'll bisect it further. Also, I don't see any errors in logcat yet.
(Assignee)

Comment 1

4 years ago
Only v2.1 is affected. Another bug I noticed is that you can end the conference call by hitting the hangup button, but it won't actually change the visual state, so you get stuck in the broken conference call view. I'm keeping these bugs together here because I'm guessing that they're directly related.
Assignee: nobody → drs+bugzilla
Blocks: 1024460
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Keywords: regression
Summary: [Dialer][Conference] Conference call status bar is invisible → [Dialer][Conference] Conference call status bar is invisible, can't exit conference call view
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Comment 3

4 years ago
Created attachment 8447740 [details] [diff] [review]
Fix bad check for hasOwnProperty on telephony.conferenceGroup.

PR: https://github.com/mozilla-b2g/gaia/pull/21141

This was happening because we were using hasOwnProperty on mozTelephony's conferenceGroup field. This is provided by an IDL file through XPCOM, which hasOwnProperty doesn't seem to support. You can confirm this really quickly by checking |console.hasOwnProperty('log') => false| in your console.
Attachment #8447740 - Flags: review?(21)
Attachment #8447740 - Flags: review?(21) → review+
(Assignee)

Comment 4

4 years ago
https://github.com/mozilla-b2g/gaia/commit/05a0303d554dfe44e8dad131ce62a4e382872aee
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED
Switching the 2.1?->2.1+, on these fixed bugs as these are regression.

Nothing to land here, its just flag-cleanup of 2.1? list. Please Ni me if there is confusion/disagreement.
blocking-b2g: 2.1? → 2.1+
This issue is verified fixed on Flame 2.2 Master KK (319mb) (Full Flash) and Flame 2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device:2.2 Master KK (319mb) (Full Flash)
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: The conference status bar is VISIBLE and the user CAN exit the conference call view
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.