[Flatfish] [Lockscreen] Hide emergency call button

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: joshua, Assigned: chens)

Tracking

(Blocks: 1 bug, {verifyme})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][TCP])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Since the flatfish device does not have cellular capabilities, it is pointless and confusing to have an Emergency Call button on the lockscreen.
(Reporter)

Comment 1

4 years ago
This is actually a UX improvement...
Blocks: 1018519
No longer blocks: 903304
Which is build is this on? Is this on a bug for regular phones?
(Reporter)

Comment 3

4 years ago
This is a problem in all the builds I have tested.  To clarify the location of the button: it is on the passcode entry keyboard.

This is not an issue on phones because they have a cellular connection.
Okay, I can reproduce.
OS: Other → Gonk (Firefox OS)
Hardware: Other → ARM
Whiteboard: [Flatfish] → [Flatfish][TCP]
I think testing for |if(navigator.mozTelephony)| should be enough. I haven't worked on the tablet though so I hope this API is not available. If it is available, we probably want to file a bug to remove it on systems that can't place a phone call.
(Reporter)

Updated

4 years ago
Depends on: 1034196
(Reporter)

Comment 6

4 years ago
Assigning to me!
Assignee: nobody → thewanuki
(Assignee)

Comment 7

4 years ago
I think this issue is fixed in latest master?
Status: NEW → UNCONFIRMED
Ever confirmed: false
Putting verifyme keyword in to check to see if this is resolved in latest.
Keywords: verifyme
See Also: → bug 928643
(Assignee)

Comment 9

3 years ago
Created attachment 8459450 [details]
Lockscreen screenshot

Screenshot on tablet w/ latest gaia

Gaia      cab9e0dd0dee93f31f12313d012e660f074663cf
Gecko     51ac93f62dfaba70de71610bbc14e0b62d7e0525
BuildID   20140714014330
Version   33.0a1
(Reporter)

Comment 10

3 years ago
Thank you Sherman!  This issue is actually shown on the pass-code entry field.  To enable this, please go to Settings > Privacy and Security > Screen lock and enable Passcode lock.
(Assignee)

Comment 11

3 years ago
Created attachment 8465257 [details] [review]
Pull request
Attachment #8465257 - Flags: review?(gweng)
Comment on attachment 8465257 [details] [review]
Pull request

OK, but please wait for the CI result.
Attachment #8465257 - Flags: review?(gweng) → review+
Comment on attachment 8465257 [details] [review]
Pull request

This is missing a new test.
Attachment #8465257 - Flags: review+ → review-
While I indeed miss that check (my fault), my concern is to change another one's review directly is proper or not. What I've experienced is to set f-, not overwrite the existing one.
Comment on attachment 8465257 [details] [review]
Pull request

To restore the flag as it could be. Maybe I'm wrong, but what I've experienced and heard is we should not change another one's review flag directly. It should come with a f- .
Attachment #8465257 - Flags: review-
(Assignee)

Comment 16

3 years ago
Comment on attachment 8465257 [details] [review]
Pull request

PR update and tests added
Attachment #8465257 - Flags: review?(gweng)
(Assignee)

Updated

3 years ago
Assignee: thewanuki → shchen
Comment on attachment 8465257 [details] [review]
Pull request

Review+ with nits. Please fix them and make sure CI result is green.
Attachment #8465257 - Flags: review?(gweng) → review+
(Assignee)

Comment 18

3 years ago
Thanks for the comment, PR updated.
(Assignee)

Updated

3 years ago
Attachment #8465257 - Flags: feedback?(gweng)
Comment on attachment 8465257 [details] [review]
Pull request

While I set r+ with nits means you can land the code after you fix the nits.
If you still want to set review to confirm that, you can set review again.
Attachment #8465257 - Flags: feedback?(gweng)
(Assignee)

Comment 20

3 years ago
Merged to master 
https://github.com/mozilla-b2g/gaia/commit/dde1b44f6e4db389083d1a45ccb495ab40d71bd6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

3 years ago
Reopen due to tbpl test fail, 
https://github.com/mozilla-b2g/gaia/commit/a14e8e82cbceea9bb3f177aa0441e8461d5232ba
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
(Assignee)

Comment 22

3 years ago
Reland on master
https://github.com/mozilla-b2g/gaia/commit/ea45b90fd0dd551d0decdc3e9cc38168ff30185d
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1057313
You need to log in before you can comment on or make changes to this bug.