Right clicking a failed job immediately spawns a new tab with an invalid URL

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Assigned: automatedtester)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
1) Open treeherder and find a repo with a failed job
2) Single right click that job & don't do anything else

Expected:
Not really sure, but I either of:
a) Context menu opens, where the user can "copy link to clipboard" or "open in new tab", where the URL is either the raw log or the log viewer.
b) New tab opens immediately, but to a URL that is valid (eg log viewer or raw log), and the context menu is suppressed.
[I think I prefer (a)]

Actual:
* New tab immediately opens without the user having selected anything on the context menu.
* The URL for that new tab is invalid (eg: https://treeherder.mozilla.org/ui/logviewer.html#?job_id=1513431&repo=mozilla-inbound)
* The context menu still appeared, but overlaid on top of the newly spawned tab (since it switched the current tab away from treeherder).
(Reporter)

Updated

3 years ago
Summary: Right clicking a failed job immediately spawns a tab with an invalid URL → Right clicking a failed job immediately spawns a new tab with an invalid URL
(Reporter)

Updated

3 years ago
Priority: -- → P3
(Reporter)

Updated

3 years ago
Blocks: 1030636
Priority: P3 → P2
I think could be addressed as part of bug 1033264, so I will technically assign myself to this.
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
I'm un-assigning myself from this for now, based on details I've provided in its related bug
https://bugzilla.mozilla.org/show_bug.cgi?id=1033264#c3
Assignee: tojonmz → nobody
Status: ASSIGNED → NEW
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1057259
(Reporter)

Updated

3 years ago
Blocks: 1059400
No longer blocks: 1030636
(Assignee)

Comment 4

3 years ago
Created attachment 8486776 [details] [review]
Allow rightclick to act normally and not spawn a new window
Assignee: nobody → dburns
Attachment #8486776 - Flags: review?(cdawson)
(Reporter)

Updated

3 years ago
Status: NEW → ASSIGNED

Updated

3 years ago
Attachment #8486776 - Flags: review?(cdawson) → review+
(Assignee)

Comment 5

3 years ago
https://github.com/mozilla/treeherder-ui/commit/70ffa2ae6cf5f1a94c987781656f6df2dba537d8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 6

3 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/3a999475d4abe4fbbdd6786c086e4c56ec7d3c3c
Bug 1032499: Make right click act normally and not spawn a new window

https://github.com/mozilla/treeherder/commit/e0ad50edddfdba3d67bfdc472e0fb5e73903079f
Merge pull request #160 from AutomatedTester/1032499

Bug 1032499: Make right click act normally and not spawn a new window
You need to log in before you can comment on or make changes to this bug.