Closed Bug 1032783 Opened 6 years ago Closed 6 years ago

Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, testLinkContextMenu, test_sync_worker.html, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]

Categories

(Core :: DOM: Content Processes, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox31 --- unaffected
firefox32 --- unaffected
firefox33 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: cbook, Assigned: bkelly)

References

()

Details

(Keywords: crash, intermittent-failure)

Android 2.3 Emulator mozilla-inbound opt test mochitest-8 on 2014-07-01 04:21:38 PDT for push 955a638544a0

slave: tst-linux64-spot-223

https://tbpl.mozilla.org/php/getParsedLog.php?id=42848685&tree=Mozilla-Inbound

04:54:21  WARNING -  PROCESS-CRASH | /tests/dom/tests/mochitest/bugs/test_bug346659.html | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]
04:54:21     INFO -  Crash dump filename: /tmp/tmpFBAGHD/1782325a-0db1-1656-0a63a042-2a05059c.dmp
04:54:21     INFO -  Operating system: Android
04:54:21     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
04:54:21     INFO -  CPU: arm
04:54:21     INFO -       0 CPUs
04:54:21     INFO -  
04:54:21     INFO -  Crash reason:  SIGSEGV
04:54:21     INFO -  Crash address: 0x8
04:54:21     INFO -  
04:54:21     INFO -  Thread 47 (crashed)
04:54:21     INFO -   0  libxul.so!mozilla::ipc::ThreadLink::~ThreadLink() [MessageLink.cpp:955a638544a0 : 208 + 0x2]
04:54:21     INFO -       r4 = 0x5159d550    r5 = 0x5bcffc28    r6 = 0x515336e0    r7 = 0x5159d550
04:54:21     INFO -       r8 = 0x4d9c95d9    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc00    lr = 0x4d9c63a5    pc = 0x4d9c6254
04:54:21     INFO -      Found by: given as instruction pointer in context
04:54:21     INFO -   1  libxul.so!mozilla::ipc::ThreadLink::~ThreadLink() [MessageLink.cpp:955a638544a0 : 211 + 0x3]
04:54:21     INFO -       r4 = 0x5159d550    r5 = 0x5bcffc28    r6 = 0x515336e0    r7 = 0x5159d550
04:54:21     INFO -       r8 = 0x4d9c95d9    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc00    pc = 0x4d9c63a5
04:54:21     INFO -      Found by: call frame info
04:54:21     INFO -   2  libxul.so!mozilla::ipc::MessageChannel::Clear() [MessageChannel.cpp:955a638544a0 : 280 + 0x5]
04:54:21     INFO -       r4 = 0x5628ebb0    r5 = 0x5bcffc28    r6 = 0x515336e0    r7 = 0x5159d550
04:54:21     INFO -       r8 = 0x4d9c95d9    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc08    pc = 0x4d9c9c91
04:54:21     INFO -      Found by: call frame info
04:54:21     INFO -   3  libxul.so!mozilla::ipc::MessageChannel::Close() [MessageChannel.cpp:955a638544a0 : 1683 + 0x5]
04:54:21     INFO -       r4 = 0x5628ebb0    r5 = 0x5bcffc28    r6 = 0x515336e0    r7 = 0x5159d550
04:54:21     INFO -       r8 = 0x4d9c95d9    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc20    pc = 0x4d9c9e7b
04:54:21     INFO -      Found by: call frame info
04:54:21     INFO -   4  libxul.so!ChildImpl::ThreadLocalDestructor [BackgroundImpl.cpp:955a638544a0 : 424 + 0x3]
04:54:21     INFO -       r4 = 0x58fc77e0    r5 = 0x5796b400    r6 = 0x56f9660c    r7 = 0x00000000
04:54:21     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc48    pc = 0x4d9ca155
04:54:21     INFO -      Found by: call frame info
04:54:21     INFO -   5  libnss3.so!PR_SetThreadPrivate [prtpd.c:955a638544a0 : 180 + 0x5]
04:54:21     INFO -       r4 = 0x00000003    r5 = 0x5796b400    r6 = 0x56f9660c    r7 = 0x00000000
04:54:21     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000001
04:54:21     INFO -       sp = 0x5bcffc68    pc = 0x49f60a81
Component: IPC → DOM: Content Processes
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Blocks: 1013571
This has the same signature as bug 1032276...
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> This has the same signature as bug 1032276...

Hmm, if thats the case, then it may be unrelated to bug 1013571.  I don't see anything in the stack for bug 1032276 that directly relates to the PBackground change.
Combine other intermittent failure bugs with the same stack (and that similarly also only occur on Android 2.3) into this.
Blocks: 967704
Summary: Intermittent test_bug346659.html | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()] → Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]
Duplicate of this bug: 990378
Duplicate of this bug: 1032705
Duplicate of this bug: 1033078
Duplicate of this bug: 1031592
Duplicate of this bug: 1032276
Duplicate of this bug: 1032201
https://tbpl.mozilla.org/php/getParsedLog.php?id=42941393&tree=Mozilla-Inbound
Summary: Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()] → Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, testLinkContextMenu, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]
Duplicate of this bug: 1033613
Summary: Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, testLinkContextMenu, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()] → Intermittent Android 2.3 test_bug346659.html, test_bug434998.xul, test_MediaSource.html, testAddonManager, testLinkContextMenu, test_sync_worker.html, Shutdown | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]
Lets see if this continues to occur after bug 1013571 was backed out.  I'm not 100% sure if its related or not.
There have not been any more reports of this from TBPL since the backout of bug 1013571, so I'm marking this fixed.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.