quick launch does not recover from exit, crash, etc

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
18 years ago
6 years ago

People

(Reporter: jruderman, Assigned: bugzilla)

Tracking

({regression})

Trunk
Future
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Quick Launch no longer restarts itself when I restart Mozilla after selecting 
exit or crashing Mozilla.  I have to open and close prefs to get Quick Launch 
running again.

This used to work correctly.  Blake made it work in bug 85437.

This has been present for several weeks, and it has been hurting my ability to 
use Mozilla as dogfood.
(Reporter)

Updated

18 years ago
Keywords: regression

Comment 1

18 years ago
Re-assigning to Blake.  Blake, can you look into this?  The only explanation I
can think of is some sort of problem with multiple installed copies (so the
registry key check fails).
Assignee: law → blakeross
(Assignee)

Comment 2

18 years ago
This works for me. Any other detail you can provide, Jesse?
(Reporter)

Comment 3

18 years ago
I tried blowing away my profile, but that didn't fix the problem.  I still have 
to go to prefs, select the advanced category, and close prefs to get quick 
launch to activate.

I install each nightly in a new directory, and Mozilla doesn't try to run 
itself when I start Windows 98.
(Assignee)

Comment 4

18 years ago
Don't know what to say. Futuring unless others can reproduce. Grace?
Target Milestone: --- → Future
(Reporter)

Comment 5

18 years ago
I unchecked "Quick Launch", restarted Mozilla, and checked it again.  Now 
everything works.  Marking WFM.  I'll file a new bug or reopen this one if I 
run into this problem again.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
*** Bug 106194 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
I guess this is just a nasty manifestation of bug 89781, "[rfe] make quick 
launch compare versions before using existing process".

Comment 9

17 years ago
also reported in bug 121100
Bug 121100 is still marked NEW. It is an identical bug to this, and has more
people CCed and much more input. Jesse, I know this is an older bug, but do you
mind if its marked duplicate of bug 121100?
(Reporter)

Comment 11

17 years ago
I was hitting bug 89781, not bug 121100.  This works for me now that I know the
workaround in comment 5.
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.