Closed Bug 1038167 Opened 5 years ago Closed 5 years ago

Need an icon for Smart Collection in App permissions screen in Settings

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jlorenzo, Assigned: aus)

References

Details

(Whiteboard: [systemsfe][ETA=7/17])

Attachments

(5 files, 2 obsolete files)

STR
1. Go to settings
2. Go to app permissions

Actual result
The default icon is still used.

Expected result
As we have different permissions between Homescreen and Smart Collection, we should display a more explicit icon.
We cannot ship with that kind of missing icon
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
(In reply to Johan Lorenzo [:jlorenzo] from comment #1)
We cannot ship with that kind of missing icon, can we?
Do we have UX/visual for this?
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Peter since we cannot ship with a missing icon.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pla)
Might want to track it in another bug, but we will also need an icon for the "Search Results" app. Currently the default icon is even worse than the default smart collections icon, I think it's because we copied the template app for that one.
(In reply to Kevin Grandon :kgrandon from comment #5)
> Might want to track it in another bug, but we will also need an icon for the
> "Search Results" app.
Already filed ;)
See Also: → 1022506
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe] → [systemsfe][ETA=7/15]
Assigning this to Peter to create the icon, then I'll take it and implement once we have assets.
Assignee: nobody → pla
Peter, feel free to assign this to me once you've made the icon.
Target Milestone: --- → 2.0 S6 (18july)
Whiteboard: [systemsfe][ETA=7/15] → [systemsfe][ETA=7/16]
Attached file AppPermissionsIcons-20140529.zip (obsolete) —
Hi Kevin,

As we spoke about this morning, I'm uploading new icons for not only the Smart Collections in App Permissions, but also for Homescreen, System, and Find My Device.  The attached zip contains all the sizes, including a 256x256 generic size (not sure if you still want this size).

Also, I will file a couple of new bugs:

1) Tighten up the drop shadow to match the homescreen app icons
2) Make App Permissions use the new 2.0 default app icon

Peter.
Flags: needinfo?(pla)
Hi Aus, I just read your comment.  Assigning to you.

Thanks!!!
Peter
Assignee: pla → aus
This mockup shows the new 4 new icons on the App Permissions page, along with the tigher dropshadow.
Aus,

Just to explain my Comment 9 - I found that App Permissions in settings was pulling in old icons from 1.4 for Homescreen, System, and was missing an icon for Find My Device, so I've included those 3 other icons.  Hopefully they can all be fixed with this bug.

Thanks again,
Peter
Whiteboard: [systemsfe][ETA=7/16] → [systemsfe][ETA=7/17]
Duplicate of this bug: 1037566
Duplicate of this bug: 1027344
Hi Peter,

I'm not seeing the new Homescreen, System and Find My Device icons, is it possible that the wrong zip file was attached? The one I have also doesn't have 256x256 icons.
Flags: needinfo?(pla)
Attached file FFOS2AppPermissionsIcons-20140716.zip (obsolete) —
Hi Aus,

I'm so sorry, you're right, I attached an old zip file from May by accident!  Here's the correct one.  Sorry for the inconvenience/delay.

Peter
Attachment #8457710 - Attachment is obsolete: true
Flags: needinfo?(pla)
No worries, thanks Peter! :)
peter I found the same issue as bug 1022506 that the normal icon size might be 84x84 instead of 80x80.

And for those app that only shows in app permission list, maybe 30x30 is sufficient (as system app does)?

https://github.com/mozilla-b2g/gaia/tree/master/apps/system/style/icons

(those are 30/45/60/68)
Flags: needinfo?(pla)
I'm going to go ahead and land the icons as they are for 2.0, we can figure out for 2.1 if we really need to optimize and strip out the other sizes if we run into partition space issues. You guys can feel free to open a new bug for this to track your discussion.
Also, I know for fact that the homescreen will be showing in the task manager for 2.1. Therefor, we *will* need larger icons for it.
Vivien, could you approve these icon updates? Otherwise I will have to flag 4 different people in 3 different timezones for reviews. :(
Attachment #8458561 - Flags: review?(21)
Status: NEW → ASSIGNED
Attachment #8458561 - Flags: review?(21) → review?(timdream)
Attachment #8458561 - Flags: review?(timdream) → review+
The sizes of these icons are wrong. We should be using the following sizes: 84, 126, 142, 189, 284
I'll remove the 80px ones and make 84px ones from 126, should resize all nice. Almost done, in fact.
Hi Aus,

Please wait until I upload a new set.  The problem is I also found a mistake in the System icon - which has a bite taken out of the gear.  I will upload in a few minutes if you can hold on.

Thanks and sorry!
Flags: needinfo?(pla)
This set of icons fixes the mistake with the @1 size (now 84 instead of 80), and the System icon gear.
Attachment #8457992 - Attachment is obsolete: true
Both master and v2.0 now have the 84x84 icons and have had the 256x256 removed as they are not used anymore.
Attached image Verify_image.png
This issue has been verified successfully on Flame 2.0,2.1

See attachment: Verify_image.png
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0
Flame 2.1 versions:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.