Detect Flash ads to be played in Shumway

RESOLVED DUPLICATE of bug 1134284

Status

P1
normal
RESOLVED DUPLICATE of bug 1134284
4 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
We can detect Flash ads by looking for common ad dimensions, `clickTag` SWF URLs, or known ad servers.
(Reporter)

Comment 1

4 years ago
Yury: Till said you might work on ad detection for whitelisting compatible ads.
Assignee: nobody → ydelendik
(Reporter)

Comment 2

4 years ago
Till suggests building a whitelisting infrastructure that can take three things into account:

* stage dimensions as specified by the embedding page (compared to industry-standard Flash ad dimensions)
* whether a clicktag is supplied as a parameter
* the swf's url, matched by a regexp
Assignee: ydelendik → dchan
Depends on: 870553
(Reporter)

Updated

4 years ago
Priority: -- → P1
(Reporter)

Updated

4 years ago
Blocks: 1037580
No longer blocks: 1037568
(Reporter)

Updated

4 years ago
Assignee: dchanm+bugzilla → nobody
(Reporter)

Comment 3

4 years ago
Tobias ran an offline ad detection test of our archive of 90K SWF files from a crawl of Alexa top sites' home pages. Based on ad-like content dimensions or clickTag URL, 22% of the SWFs were categorized as ads. The other SWFs are probably video players, trackers, site navigation menus, or non-standard ad dimensions.

We may still need to implement client-side ad detection even with a Shumway list to avoid playing non-ad SWFs on whitelisted domains. A shavar blocklist to quickly block websites broken by Shumway is probably the most important reason for maintaining a server list.

The TP team's script to import Disconnect's blocklist:

https://github.com/mozilla-services/shavar-list-creation
(Reporter)

Comment 4

4 years ago
Monica strongly recommends that creating a Shumway shavar list block M3, even if the list is just a clone of the TP list to start. The server workflow to import and publish lists is tricky.
Blocks: 1037568
No longer blocks: 1037580
(Reporter)

Updated

4 years ago
Blocks: 1145847
(Reporter)

Comment 5

4 years ago
I am repurposing this bug for the Shumway dev work to detect ads, whether by SWF dimensions, clickTag, or whitelist. I will split the work to create, approve, and serve the whitelist to separate blocking bugs.
Summary: Create Shumway whitelist or detection of compatible Flash ads → Detect compatible Flash ads
(Reporter)

Updated

4 years ago
Summary: Detect compatible Flash ads → Detect Flash ads to be played in Shumway
(Reporter)

Updated

4 years ago
Depends on: 1145857
(Reporter)

Updated

4 years ago
No longer blocks: 1145847
Depends on: 1145847
(Reporter)

Comment 6

4 years ago
We will need client-side heuristics in addition to the server whitelist. I added "https://pagead2.googlesyndication.com", a common ad server, to my "shumway.swf.whitelist" pref. It broke some non-ad video content:

http://www.wired.com/2015/04/binge-guide-orphan-black/
http://www.bbcamerica.com/orphan-black/videos/join-the-clone-club/
(Reporter)

Comment 7

4 years ago
Correction: adding googlesyndication.com to the shumway.swf.whitelist pref does NOT break the videos in comment 6. I was testing a number of different whitelist wildcard expressions at the time and I lost track of which expression I was testing.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134284
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.