Cannot connect to cell data

RESOLVED DUPLICATE of bug 1040700

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1040700
4 years ago
4 years ago

People

(Reporter: RobertC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8456908 [details]
cell-data.png

The issue seems to be dependent on the base build on the device.

We can reproduce this issue with both manual and automated tests on base build B1TC00011220.
This issue is not reproduce when running tests on base build B1TC200110G0.

Build info v2.1 flame:
Gaia      d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko     https://hg.mozilla.org/mozilla-central/rev/691ffea49efb
BuildID   20140716040207
Version   33.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014

Cell data works on: B1TC200110G0
Does not work on: B1TC00011220

STR:
1. flash phone with latest gaia
2. got to setting > cellular & data
3. choose sim card
4. enable data connection

Expected result:
Cell data should be enabled

Actual result:
The toggle button is enabled but cell data is not working (screenshot attached)

Comment 1

4 years ago
I have tried with two UK Sim cards and I can't replicate this.

Are you sure it's not the APN settings? 

Is there anything in the logcat?
Component: RIL → Vendcom
Team: please always include a logcat (with as much appropriate debug information enabled as possible); thanks.
This is not a vendor bug. If that was true, then this would repro on all branches.
Component: Vendcom → RIL
(In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #3)
> This is not a vendor bug. If that was true, then this would repro on all
> branches.

Note - this repros on 2.1, not 2.0.
    This affects smoketest and reproduces on 2.1 we did not reproduce on 2.0.

    Environmental Variables:
    Device: Flame Master
    Build ID: 20140716040207
    Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
    Gecko: 691ffea49efb
    Version: 33.0a1 (Master)
    Firmware Version: v122
    User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0"

    Environmental Variables:
    Device: Flame 2.0
    BuildID: 20140716000201
    Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
    Gecko: 913827496f65
    Version: 32.0a2 (2.0)
    Firmware Version: v122
    User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
blocking-b2g: --- → 2.1?
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Keywords: qaurgent, regressionwindow-wanted, smoketest
QA Contact: jmercado
Is this 100% reproducible? Please test this with a device other than Flame and provide logs with ril log enabled [1]. Thanks.

[1] https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#RIL_Debugging
(In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #3)
> This is not a vendor bug. If that was true, then this would repro on all
> branches.

If that was true, you can always switch its component back to RIL. Before we have a logs on devices other than Flame, this is not a RIL component bug. We won't look into a Flame RIL problem. Please understand this.

Andreas, do you think we should take a look now?
Component: RIL → Vendcom
Flags: needinfo?(gal)

Comment 8

4 years ago
I saw this happening on v2.0 build also, on base build B1TC00011220.
Based on comment 1, I think this is an APN settings issue, because when I use the Vodafone SIM with the Vodafone apn settings the connection is successful (tests pass), and after changing the SIM to Orange I can reproduce the issue seen in automation.

Could this be and issue in the testvars.json ril.data vs SIM APN settings?

Gaia      aa4f795b81c6147d67c4f06009e166debcf8856e                         
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/0ec0b9ac39f0  
BuildID   20140717000201                                                   
Version   32.0a2                                                           
ro.build.version.incremental=109                                           
ro.build.date=Mon Jun 16 16:51:29 CST 2014                                 
B1TC00011220
(In reply to [:AndreiH] from comment #8)
> I saw this happening on v2.0 build also, on base build B1TC00011220.
> Based on comment 1, I think this is an APN settings issue, because when I
> use the Vodafone SIM with the Vodafone apn settings the connection is
> successful (tests pass), and after changing the SIM to Orange I can
> reproduce the issue seen in automation.
> 
> Could this be and issue in the testvars.json ril.data vs SIM APN settings?

I think there might be two different bugs here - 1) involving a UI automation issue, 2) involving a bug only seen by manual testing. 

Peter - Can you open a separate bug for [2]?
blocking-b2g: 2.1? → ---
status-b2g-v2.0: unaffected → affected
Component: Vendcom → Gaia::UI Tests
Flags: needinfo?(pbylenga)
Keywords: qaurgent, regressionwindow-wanted, smoketest
Flags: needinfo?(gal)
Filed bug 1040211.  Note we are also seeing on it on today's 2.0.
Flags: needinfo?(pbylenga)
Root cause turned out to be legitimate Gaia bug, so duping to that bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1040700
You need to log in before you can comment on or make changes to this bug.