If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Modify APN for ATT because last update doesn't work as expected (followup from bug 965826)

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: albert, Assigned: albert)

Tracking

({regression, smoketest})

unspecified
2.1 S1 (1aug)
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Bug 965826 modified an APN for O2 Germany, what caused the need of updating the apn list from the AOSP list. Last changes in AOSP master changed the APN for ATT and it is not working in Firefox OS.

AOSP changed the apn from 'phone' to 'nxtgenphone', what seems to be used for 'Voice over LTE'.

So, we need to change back the ATT apn to 'phone'
(Assignee)

Updated

3 years ago
Assignee: nobody → alberto.crespellperez
(Assignee)

Updated

3 years ago
Blocks: 965826
(Assignee)

Updated

3 years ago
Blocks: 1040382
(Assignee)

Updated

3 years ago
Blocks: 1040211
(Assignee)

Comment 1

3 years ago
Created attachment 8458727 [details]
Patch

Created 'overwrite' tag in query.js to allow overwrite an APN from a local one.

Added an ATT APN in order to overwrite the one that is failing in firefox OS.
Attachment #8458727 - Flags: review?(josea.olivera)
Nominating to 2.0 as this bug will fix the regression introduced by bug 965826 that's already in 2.0
blocking-b2g: --- → 2.0?
Comment on attachment 8458727 [details]
Patch

LGTM. r=me

I don't have an ATT ICC card. I tested this by forcing the MCC MNC to 310 410 values and the APN got back to the previous one.

Thanks Albert for taking care of it.
Attachment #8458727 - Flags: review?(josea.olivera) → review+
Created attachment 8459327 [details]
1040700.png

How the APN looks after taking the patch.
Jose Antonio, as Albert is on PTO can you land this patch in master? Thanks a lot!
Flags: needinfo?(josea.olivera)
(In reply to Maria Angeles Oteo (:oteo) from comment #5)
> Jose Antonio, as Albert is on PTO can you land this patch in master? Thanks
> a lot!

Sure, landed at:

https://github.com/mozilla-b2g/gaia/commit/bed4278709afbb5a08c8441712af2cbd1f0ab1e6
Flags: needinfo?(josea.olivera)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1040211
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.1 S1 (1aug)

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+

Updated

3 years ago
Keywords: regression

Updated

3 years ago
No longer blocks: 1040211

Updated

3 years ago
Duplicate of this bug: 1039545
Keywords: smoketest
v2.0: https://github.com/mozilla-b2g/gaia/commit/579a8c858979672a5f435577c4a53cdff9151fe2
status-b2g-v2.0: affected → fixed
You need to log in before you can comment on or make changes to this bug.