Intermittent test_nfc_peer.js | TimeoutException: TimeoutException: Connection timed out

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=43944813&tree=Mozilla-Central

b2g_emulator_vm mozilla-central opt test marionette-webapi on 2014-07-16 08:22:38 PDT for push f6e46d1fc903
slave: tst-linux64-spot-742

09:14:25     INFO -  07-16 12:08:22.630 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/nfc/tests/marionette/test_nfc_peer.js
09:14:25     INFO -  07-16 12:08:22.640 I/Gecko   (   44): 1405526902643	Marionette	INFO	sendToClient: {"from":"0","value":null}, {05ceee1c-dae7-47ea-9ec4-5d8fc0ef1495}, {05ceee1c-dae7-47ea-9ec4-5d8fc0ef1495}
09:14:25     INFO -  07-16 12:08:22.810 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
09:14:25     INFO -  07-16 12:08:23.120 I/Gecko   (   44): 1405526903124	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {6a8241f2-c861-4e8d-884b-8bcce22b9870}, {6a8241f2-c861-4e8d-884b-8bcce22b9870}
09:14:25     INFO -  07-16 12:08:23.160 I/Gecko   (   44): 1405526903168	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {d59f26bc-f606-4cd7-a0a8-3a31c9b0dfa3}, {d59f26bc-f606-4cd7-a0a8-3a31c9b0dfa3}
09:14:25     INFO -  B2G is still running but Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
09:14:25    ERROR -  TEST-UNEXPECTED-ERROR | test_nfc_peer.js | TimeoutException: TimeoutException: Connection timed out
09:14:25     INFO -  Traceback (most recent call last):
09:14:25     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 171, in run
09:14:25     INFO -      testMethod()
09:14:25     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 505, in runTest
09:14:25     INFO -      filename=os.path.basename(self.jsFile))
09:14:25     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 1040, in execute_js_script
09:14:25     INFO -      line=None)
09:14:25     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
09:14:25     INFO -      return func(*args, **kwargs)
09:14:25     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 597, in _send_message
09:14:25     INFO -      "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
09:14:25     INFO -  TEST-INFO expected PASS | took 362700ms
Blocks: 860906
Assignee: nobody → allstars.chh
Duplicate of this bug: 1012946
Assignee: allstars.chh → nobody
Component: NFC → Marionette
Product: Firefox OS → Testing
Change components to Marionette as this should be a bug of it.

Every test in nfc will call finish() immediately if navigator.mozNfc is not defined.

And check the timestamp in the log,
The first nfc test (test_ndef.js) starts at 07-16 12:08:07.551, and the exception is thrown at 07-16 12:08:23.160, took only 16 seconds before the exception is thrown.

I don't think the timeout is caused by NFC tests.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
No longer blocks: 860906
Comment hidden (Treeherder Robot)
Closed as this intermittent has not been hit in 2 months.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.