Closed Bug 1040236 Opened 6 years ago Closed 2 years ago

[Flatfish] Mac users are unable to access the tablet via fastboot (therefore unable to flash the device)

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: caspy77, Unassigned)

References

Details

(Whiteboard: [TCP] [Flatfish] [flatfish-hardware][POVB])

Attachments

(1 file)

245.64 KB, application/octet-stream
Details
With the new bootloader (2.0) flatfish devices now use the same vendor ID in both normal and fastboot mode.
Unfortunately it seems that our Mac users are still unable to access fastboot on the device (and therefore flash a new OS).
Whiteboard: [Flatfish] → [TCP] [Flatfish] [flatfish-hardware]
See Also: → 1033619
Blocks: 1031983
See Also: → 1043548
It was suggested in our recent coordinator meeting that this could be an issue with the fastboot implementation.  It reminds me of a potentially relevant bug I just filed (bug 1043548 ).

Since updating the bootloader, the USB Drivers (Windows of course) that install with PhoenixSuit no longer work to access the device in fastboot mode.  Users must install a second set of Google Android drivers in order to access it.
Got some hints from our partner but still not able to access tablet in fastboot mode on Mac.

We tried several approaches include: download a copy of fastboot-mac script, run with sudo, and apply vendor ID using -i flag, but still no help.

[1] http://forum.xda-developers.com/google-nexus-5/help/mac-fastboot-finding-device-t2661020
[2] http://android.stackexchange.com/questions/58187/adb-can-discover-devices-but-not-fastboot
[3] http://forum.xda-developers.com/showthread.php?t=1350784
ni Jeff for my comment 2
Flags: needinfo?(jeff.cy.chuang)
Sherman, most Mac user does not need any driver installed to make Android devices work in fastboot mode but some users are facing the problem of not-found fastboot device(, adb device is visible). The only solution we found is adding -i <vendor_id> option for fastboot mode. It is sad to hear the solution does not work.
What information else do you need from me?
Flags: needinfo?(jeff.cy.chuang)
If this helps with the latest fastboot from sdk I get this error ERROR: Unable to create a plug-in (e00002be), of course only appears the first time you put flatfish in fastboot mode because after execute 'fastboot devices' OS X doesn't recognize the tablet as a usb device any longer so you have to restart the tablet again in fastboot mode
Forget to say that error appears no matter if I execute the command with or without sudo
Whiteboard: [TCP] [Flatfish] [flatfish-hardware] → [TCP] [Flatfish] [flatfish-hardware][POVB]
I was wondering if there is a fix for this in the pipeline?
https://android-review.googlesource.com/#/c/106689/ gets fastboot working for me on OS X 10.9.5, but for some reason leaves my built-in USB devices dead (trackpad, keyboard). It's at least on the road to a proper fix.
The latest version of that patch seems to help the USB devices dying. Worth trying.
I use this repo https://github.com/thp/fastboot-osx-standalone and applied the last version of the patch but it doesnt't work.

@mreimer can you put the fastboot binary that you compiled in some place where we can download and test?
Attached file fastboot for OS X
Try this.
It doesn't work for me, ./fastboot devices doesn't return anything.
If your device doesn't use one of the USB vendor ids on fastboot's built-in list, it won't show up in "fastboot devices" output. You can specify the USB vendor id with e.g. "-i 0x1234".
So whats the usb vendor id you used to connect to the tablet?
The device I'm testing on uses TI's USB vendor id, which is built in, so I didn't need to specify one with -i.
Still not working, the id that tablet uses is built in fastboot because is a Google id.

Need to add that before disable my keyboard and touch pad prints in console Bus error: 10
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.