Mail filtered to trash not deleted from POP server (when deleted locally!)

RESOLVED DUPLICATE of bug 89034

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 89034
17 years ago
4 years ago

People

(Reporter: emmet, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20011008
BuildID:    2001100803

When using POP and 'delete message from server when deleted locally'
preference, if a mail is *filtered into trash* (i.e. deleted locally)
then that mail is *not* deleted from the server.


Reproducible: Always
Steps to Reproduce:

Updated

17 years ago
URL: n/an/a
(Reporter)

Comment 1

17 years ago
and when you delete the trash it is not deleted from the server.

This means the server gets filled up with emails that you never wanted
to see in the first place.

Comment 2

17 years ago
filtering to trash does not delete from POP server but there is an option to
"Delete the message" in filters, that deletes from the POP server while
filtering to trash. Now I wish there was a filter option that deletes messages
from POP server, but I guess that should be filed as another bug report/feature
request.

Comment 3

17 years ago
filed bug 117037 for that.

*** This bug has been marked as a duplicate of 89034 ***
URL: n/a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
this is not an exact duplicate of bug 89034

there is another issue here. Seems that "Delete the message" doesn't delete
messages on POP server.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
build 2001122106 win32 trunk, neither move to trash folder nor delete the
message deletes the message on the pop server.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
This is not in reference to the mail filtered to trash not deleting from the server.
FYI...But generally when you have this option set up to delete the messages from
the server when delete locally, should be follwed by a Get Message.  After
clicking the get message button the messages should be deleted on the server.

Comment 8

17 years ago
this is preventing me from using filters, and I've been getting more mail
lately. What needs to be done to get this fixed?
Keywords: mozilla0.9.9

Comment 9

16 years ago
This problem exists also on mozilla 1.1 in Linux.

Comment 10

16 years ago
OS -> All based on comment 19.
OS: Windows 2000 → All

Comment 11

16 years ago
Marking as a dupe of bug 89034 again.
The correct behaviour (based on bug 66270 and the 'new' (per 200208) label for
this feature in preferences: "Delete messages on server when they are deleted or
moved from Inbox") is that as soon as a message leaves the inbox and the pref is
set, it should be deleted from server. The keyword here is "leaves" - no matter
if this is done by "moving" to a different folder or by "deleting" the message.
Bug 89034 covers fixing this behaviour for when the moving or deleting is done
by filters, and this is thus a dupe.

If you disagree and want to reopen, please explain clearly where this bug differs.

*** This bug has been marked as a duplicate of 89034 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
I understand that bug 89034 originally was about filtering mail to another
folder and keeping it on the server at this point, and only when the mail is
later (manually) deleted from that folder, it should also be removed from the
server. This would require a mechanism to track every message back to its
originating server, even from local folders.

_This_ bug is about the fact that moving a message to a local folder manually
deletes ist from the server (assuming that "Delete message..." is checked),
while moving it to a local folder automatically using a filter rule does not,
which is inconsistent behavior.

IMHO these two bugs are completely different, so I vote for reopening this one.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.