[RFE] Do not delete messages on POP server when moved locally

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
18 years ago
5 years ago

People

(Reporter: falcon10, Assigned: naving)

Tracking

({dataloss})

Trunk
Future
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test11 i686; en-US; 0.7) Gecko/20010111
BuildID:    200101118

Messages that go into "Inbox" ( don't fit any filter criteria ) and then moved
to another folder are deleted from the pop server. The flush flag is disabled.
I can read it, but

Reproducible: Always
Steps to Reproduce:
So far, it seems that whenever there's a "Check for new messages" request, the
message that has been moved from "Inbox" to another folder is deleted from the
pop server.

Actual Results:  The message is deleted from the pop server

Expected Results:  The message should remain in the pop server.

Updated

18 years ago
Summary: messages are deleted from pop server → messages are deleted from pop server

Updated

18 years ago
QA Contact: esther → sheelar

Comment 1

18 years ago
works4me-using commercial build 2001-01-22-18 on linux. 
Reporter,
can you try this on recent builds and see if this is still problem. thanks.

Comment 2

18 years ago
Are you sure you checked "Leave messages on server" in Account settings? If you 
don't, then all messages which you read will be deleted from the POP server and 
only remain locally.

Can you try to reproduce this with a new nightly and that checkbox checked?

Thanks..
(Reporter)

Comment 3

18 years ago
The new nightly (2001012519) has still the same problem....
My settings are leave message on the server and delete when they're deleted
locally. Unless the move operation implies deleting the message from the server
( which I'm almost positive is not the case ) there's something wrong...
Thanx,
Luis

Comment 4

18 years ago
I just tried this and you are right; message are actually deleted from the
server if they are moved to another folder. 

This is when "Delete messages on server when they are deleted locally" and
"Leave messages on server" both are checked!

This is a major flaw, this should really be fixed before Mozilla 0.9 (if not 0.8!).

Marking NEW.
OS -> All

And I guess this should get the dataloss keyword too?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 5

18 years ago
Agreed that this is worth the dataloss keyword.
Keywords: dataloss
Hardware: PC → All

Comment 6

18 years ago
adding keyword and nominating for nsbeta1.  A move should just be a move and
should not delete a message from the server.
Keywords: nsbeta1

Comment 7

18 years ago
Per bug meeting, I tried this with 4.7, it does this too. 

Comment 8

18 years ago
marking nsbeta1-.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → Future

Comment 9

18 years ago
A move is really a delete from one folder and adding to another folder.  Since 
the Inbox is the only folder on the server, and user has the preference set to 
"delete from server when I delete locally", then this is expected behavior.  
However, it could be confusing.  How about throwing up a dialog when a message 
is moved from a POP Inbox to another folder stating that "A move is a delete 
from one folder and an add to another folder.  If your preference is set to 
delete from server when deleting locally, this will delete this message from the 
server."   
(Assignee)

Comment 10

18 years ago
we can prevent a delete on server if the user does a move. however this is not
a dataloss because the destination folder has the messsage. nominating for 
0.9.2
Keywords: nsbeta1- → nsbeta1

Comment 11

18 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 12

18 years ago
*** Bug 89970 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Severity: critical → enhancement
Keywords: dataloss
Summary: messages are deleted from pop server → [RFE} Do not delete messages on POP server when moved locally

Comment 13

18 years ago
The behavior described in this is identical as in Netscape 4.*. I
believe this is correct. How else can I selectively delete messages on the
server why keeping them on the client (most people I know keep the old messages
locally not on the server). I would consider the WONTFIX solution. If not, there
must be a setting to preserve the 4xp behavior we now have. 

As this goes against 4xp behavior, I dare change the summary severity to enancement.

Comment 14

18 years ago
Umm Jacek, that is a different issue. You should be allowed to do both. Maybe a
delete only from server option (Is there a bug filed for that?). This should be
fixed if possible, it is still a dataloss problem.
Keywords: dataloss
Summary: [RFE} Do not delete messages on POP server when moved locally → [RFE] Do not delete messages on POP server when moved locally

Comment 15

18 years ago
I think this is a WONTFIX because the "move" operation is basically a
"copy-then-delete" operation. And deleting from the inbox then triggers the
deletion from the server, which is the correct behaviour. When you move
something, you are "removing" it from its original location. And "removing" is
"deleting". Am I wrong?

Comment 16

18 years ago
You're right that a move operation is a copy-and-delete operation and certainly
the message has to be deleted from Inbox but I don't think this means that the
message has to be deleted from the server. Messages on server should only be
deleted when I explicitly press the Delete button. That makes more sense I think.

However, looking at other comments I feel that there is a need for selectively
deleting messages from the server. I have felt a need for that function in the
past. Another approach that came to my mind was to create a special folder
called 'Saved Mails'. All messages moved to that folder or its sub-folders (and
of course Trash) would get deleted from the server. Otherwise they stay on the
server.

Personally I feel a Menu item that says 'Delete Message from Server (but leave
it in Inbox)' would be very powerful and useful.

Comment 17

18 years ago
Also, I don't think this is an enhancement request. It shouldn't matter what
NS4.x did, what should matter is 'What's the right behaviour?'.

Comment 18

18 years ago
1. I still think that this bug is valid. If the current behavior is suppost to
be correct, then the feature should be called "Delete messages on server when
they are deleted *from inbox*". As it is right now the setting says "Delete
messages on server when they are deleted locally".

2. Another thing, do filters cause messages to be deleted on the POP server? If
they do, it would be inconsistant as the messages never got into the inbox. If
they don't, do the messages get deleted on the server when they are
moved/deleted manually? If not that would mean that the user cannot delete those
messages on the server manually.

Comment 19

18 years ago
Pratik: this is where the Local Folder comes in.

I think Mozilla should keep the message on the server *if and only if* it is in
the same account. For example if I have a POP account A and "Local Folders".
With the "keep messages on server" and "delete on server when delete locally"
are on, I expect the message to be *still* on the server after I
downloaded/moved the message as long as it is still in POP account A. However,
if it is delete or moved into "Local folders", I would expect it to be deleted
on the server. Of course the warning that Esther suggested still applies.

Comment 20

18 years ago
Agreed. Moving to another mail account folder should delete the message fom the
server. I think this is a good approach and I agree with Esther that the user
should get a warning dialog box (Probably with a check button saying 'Don't show
this again' for people like me ;-))
(Reporter)

Comment 21

18 years ago
I believe messages should not be deleted when moving manually from folder to
folder. 
The filter operation does this in a non-interactive manner, and the messages
won't be deleted. I like to think of the move operation as a relocation within
the client. The server should play no part on this.
There's a special folder for deleting (trash). The filter operations include it,
so the manual.

Even in the extreme case,when moving mails from two different accounts, I
believe they should not be removed from the pop server. 

Regards,
Luis
(Assignee)

Comment 22

18 years ago
We don't have a consensus here. Scott, how do you want this issue to 
be resolved. 

Comment 23

18 years ago
The mirror of the user's POP account is the Inbox folder. This should be in sync 
 with the server if possible. Moving messages to other folders is archiving 
them. The POP server is not meant for archiving (unlike IMAP), therefore 
archived ("filed") messages should be removed from it.

At present if you read your POP account mail from several clients (like home and 
office), filing old messages to subfolders is the only way to delete them, and 
not the new ones that were not yet downloaded on the other client. There is no 
other way to keep the server folder small and have all the messages on both 
clients. Unnell one has a shell account and deletes the files manually (wuth 
elm, pine etc.)

If this "bug" is "fixed", I will have to delete old messages on one of my 
client, re-read the POP account (to synchronize it with my Inbox) and only then 
fish in Trash to move the messages to the right folders. Or copy (instead of 
moving) and then deleting (to force de,leting the messages on the server). These 
are absurd workarounds I would like to avoid.

Therefore, if this "bug" is to be ever fixed (I hope not), there must be a 
setting for users like me to restore the 4xp behavior.

Comment 24

18 years ago
I believe that this bug shouldn't be fixed.  A move is a delete and a copy.
Therefore it should be removed from the server.

Comment 25

18 years ago
Jacek: depends on how this bug is fixed, if this bug is fixed in such a way that
it only affects moving within the same account, you can still file your old
messages in a different account i.e. "local folders"

Comment 26

18 years ago
Basic: Why should "Local Folders" be treated differently from other local
folders? Do not morph this bg into "Do not delete messages on POP server when
moved locally unless it is into Local Folders"

Comment 27

18 years ago
No that is not what I meant, what I meant was that the folders within the
account should be considered special, as in that they do not remove the message
from the server when a message is moved between them. On the other hand, a
folder outside of the account will not be part of the account, therefore moving
the message from any folder in the account to a folder outside of the account,
would remove the message from the account and therefore remove the message from
the server.

Comment 28

18 years ago
Basic: What if you want to keep the messages from different accounts separate,
and at the same time delete selectively old messages on the server? In such a
case any such "fix" of this "bug" would create a nightmare of workarounds (see
my previous comments).

Comment 29

18 years ago
Jacek: which is why there should be a remove from server option... after all
isn't that more clear than moving to a different folder will remove from the server?

Comment 30

18 years ago
Basic: I lost you. For me the present behavior is clear as every move is
copy+delete. What you propose (delete the messages on the server if they are
moved to folders in other accounts or the Trash folder in the same account) is
much more complicated and for me counter-intuitive. 

BTW, let's stop spamming the bug. It seems our positions are now well defined.

Comment 31

18 years ago
Recommend wontfix.  See bug 84905, "Moving message across accounts actually 
does copy the message", fixed several weeks ago.  This "bug" does not cause 
real dataloss, because you still have the message in your local folders.  The 
workaround for people used to the 4.x behavior (manually copying if you want to 
leave the message on the server) is much easier than the workaround for bug 
84905 (copy and then delete), and the 4.x behavior is confusing because it is 
inconsistent with other applications.
You *must* be able to know what server, if any, a message is stored on.
Otherwise cleaning up an account somewhere becomes very difficult. Currently the
only way to possibly know is if the location of the message in the Folders pane
corresponds with its existence on a server. So it must be either
    - Inbox alone mirrors the user's POP account, or
    - Inbox and its subfolders -"-
    - the whole account, including all folders in it (excluding special folders
such as Sent etc..) -"-
Messages moved outside the designated area must be removed from the server.

Secondly, the filter action "move" and manual "move" appear to behave
differently, as even messages "moved" via filter to, say, somewhere in Local
Folders seem to persist on the pop server, whereas a manual move dose delete
from server..? I think this is evil and messy. The existence of a message on a
server should correspond with the placement of the message in the mailnews
hierarchy, not depend on actions, or whether the action was manual or automatic.
  (Note that I may be mistaken about the current behavior, but this is what my
testing of it showed)

Comment 33

18 years ago
Jesse Ruderman: the 4.x behavior *is not* what this bug is about. Please read
carefully.

Comment 34

18 years ago
Basic: please explain.  In what was is this bug not the opposite of bug 84905? 
What's different about the behavior requested in this bug and the 4.x behavior?
 (Keep in mind that I've never used 4.x mail and I've only started using Moz
Mail as dogfood recently.)

Comment 35

18 years ago
Jesse: In 4.x it does pretty much the current behavior, when a message is moved
away from the inbox, it is deleted from the pop server. What this rfe originally
proposed was that it should not delete (on the server) when a message is moved
away from the inbox.

My personal opinion is that it should not delete (on the server), if and only
if, it is between folders within the same account. If it is moved to something
like "Local Folders", it should prompt the user before deleting on the server.

In 4.x the current behavior made sense as pop mail messages was kept in "Local
Mail"->Inbox

Bug 84905 is about moving messages locally, unless I'm mistaken, it has nothing
to do with removing messages from the server.

Comment 36

18 years ago
Yes, any messages moved to another folder were deleted from the POP server by NC
4.*. No disagreement here.

I believe we need a good reason to change the behavior users are used to. I do
not see it here. And again: if we really decide to change the behavior, we need
create a UI setting enabling restoring the traditional one. 

Comment 37

18 years ago
The compelling reason to change the behaviour is that manually moving and
automatically moving (through filters. The option is 'Move to Folder X') have
different outcomes. One deletes the mail from the server, the other does not.
Does this seem like a sufficient reason?

Comment 38

18 years ago
Pratik: Maybe this is by luck, not device, but I like the outcome. When I move a
message, I know what I'm doing and I expect it deleted on server. But again if I
read my emails from two hosts (and I do), I would like to be able to store them
(processed by filter or not) on both compuers. The difference is that I can
manually move the messages *after* seeing them on both computers (the next day).
In case of filters I would receive them only on the one that first gets the
message. Presently, I have no problems both with manual and filter processed
messages.

Comment 39

18 years ago
Actually, this bug is so morphed that it became pointless. These bug is supposed to:

1) not to delete moved messages (the original report by falcon10, Hakan on 1/27,
  Sheela on 2/26)

2) do not change behavior but throw up a dialog when a message 
is moved from a POP Inbox to another folder stating that "A move is a delete 
from one folder and an add to another folder.  If your preference is set to 
delete from server when deleting locally, this will delete this message from the 
server."  (esther on 5/31) 

3) create a special folder (othen than Trash) which would trigger deleting if
messae is moved into ir (Pratik on 7/10)

4) create Menu item that says 'Delete Message from Server (but leave
it in Inbox)' (Pratik, same comment)

5) delete messages only if moved to another account (basic on 7/10)

6) make the result of moving messages manually and with filters consistent 
(Pratik on 7/10 and 7/11, Tuukka on 7/11) [I am not sure they agree which way - JP]

7) Leave as it is [WONTFIX] (Peter Lairo on 7/10, putterman on 7/10, jesse on
7/10, Jacek [me] on 7/10)


So what do we do?

Comment 40

18 years ago
I say we change the behavior of the "move" filter to match the other "move"
actions (drag, message->move->[folder], etc).

Jacek: see bug 61635 for adding "copy" to the list of possible filter actions.

Comment 41

18 years ago
OK. So we have now:

6a) change the filter behavior to remove mail from server if filter stores a
message elsewhere than Inbox

which replaces 6) as the inverse solution is identical to 7)

Generally, I believe that only resolution 1) or 7) should be allowed in this
bug. Any other solution is bug morphing and should - according to the Bugzilla
rules - be replaced by marking this one WONTFIX or INVALID and opening a new
bug. Ideas 2) to 6) should be filed as separate bugs if their authors wish to do
so. The only viable choice in *this* bug is implementing it (#1) or killing (#7).

BTW, idea 6a) would fall in another component (Filtering) than this bug
(Networking - POP)

Similarly, bug 61635 is a separate bug, that already exists. It's only relevance
to this one would be making this one a dup of 61635. 

Comment 42

18 years ago
If this bug is not going to be fixed, I suggest 3 new bugs be filed for:

1) do not change behavior but throw up a dialog when a message 
is moved from a POP Inbox to another folder stating that "A move is a delete 
from one folder and an add to another folder.  If your preference is set to 
delete from server when deleting locally, this will delete this message from the 
server."

2) change the filter behavior to remove mail from server if filter stores a
message elsewhere than Inbox

3) relabel "delete messages on server when they are deleted locally" to "delete
messages on server when they are deleted or moved from local inbox", or to
something better.

4) create Menu item that says 'Delete Message from Server (but leave
it in Inbox)'




(Reporter)

Comment 43

18 years ago
Basic :
Having the same functionality on the filters that the manual moving operations
will make things even worse. Then people who reads messages on different clients
won't have the great advantage of filters ( since the first one to read would
delete all the matching mails ).

What it's true is that both manual and non-interactive actions should have the
same outcome ( and hopefully it will be leaving the messages on the server ).

Wow, it was not my intention to create such a mess ! ;)

Regards,
Luis

Comment 44

18 years ago
Falcon: I can mark the "'move' filter should move, not copy, pop messages"
dependent on bug 61635 (make 'copy' filter available) if you want.

Comment 45

18 years ago
popping up alerts is going to annoy users.

Comment 46

18 years ago
falcon: you have a point, this is why I originally suggested:

5) delete messages only if moved to another account (basic on 7/10)

so that you can create filters that go to another folder within the same account
to prevent delete and create filters that go to a folder outside of the account
for deleting. But after thinking about it some more, I realize how this can be
unintuitive to some.

popups can have a "don't show this to me again" checkbox.

Comment 47

17 years ago
A long time ago (before this discussion even started) I filed the related bug
47297,  which covers one of the issues mentioned in this bug. Maybe it's time to
implement it!

Comment 48

17 years ago
Confusion can be avoided without a dialog box by changing "Delete messages on
server when they are deleted locally" to "Leave messages on server as long as
they are in the inbox" or "Leave messages on server as long as they are filed
inside this account."
(Assignee)

Comment 49

17 years ago
marking won'tfix. this is behavior we want.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 50

17 years ago
Navin: can we at least change the wording of the label per comment #c48 ?

Comment 51

17 years ago
I've filed Bug 117032 for comment 48 
bug 104029 might interest some people here.

Comment 52

17 years ago
filed bug 117037 to make it possible to get filters to work similar to the way
it works manually when moving messages from inbox.

Comment 53

17 years ago
verified won't fix based on Putterman and Navin's comments in the bug.  So the 
messages when moved will get removed from the server.
See other bugs opened that are related to this issue. 
Status: RESOLVED → VERIFIED

Comment 54

17 years ago
*** Bug 130840 has been marked as a duplicate of this bug. ***

Comment 55

17 years ago
*** Bug 149686 has been marked as a duplicate of this bug. ***

Comment 56

17 years ago
*** Bug 158316 has been marked as a duplicate of this bug. ***

Comment 57

14 years ago
Personally, I think this is still a bug because I have "Leave messages on 
server" checked and "Until I delete or move them from Inbox" unchecked.

Now when I have two mail clients on two systems that download messages from 
the same POP3 mailbox, I always lose part of my messages just because one of 
the clients deletes the messages that some filters are applied to.

This is a severe shortcoming because I want to check my mails with a powerful 
mail client utilizing mail filters instead of using ad-supported flashified 
web mail interfaces both at home and at work.

Or, alternatively, what about some intelligent mail-merging plugin for 
Thunderbird and Mozilla Mail ? I think solving this major bug would be easier.

Comment 58

14 years ago
Oh yeah, I forgot to add: There's are options in the message filters to have 
messages deleted locally and/or from the server, so why shouldn't we allow a 
local move operation without touching the server when "Until I delete or move 
them from Inbox" is *unchecked* ?? There will be absolutely no disadvantages 
in fixing this any more.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.