[RFE] option to delete messages from POP3 mail server in message filters

RESOLVED DUPLICATE of bug 74430

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 74430
17 years ago
10 years ago

People

(Reporter: basic, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When using filters to move mail away from the inbox, it does not delete the mail
from the POP server like when mail is moved manually from the inbox. I'd suggest
an option to delete the mail from the POP server for a "move" filter rule.

maybe related to bug 47297, bug 61635, bug 66270 and bug 104029
(Reporter)

Comment 1

17 years ago
Or maybe a seperate filter action to delete from POP server (but not locally).
This would make things more flexible and maybe make more sense in view of bug
13145 ?

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.9

Comment 2

16 years ago
i agree to comment 1. this would be a nice option to keep my mailbox clean from
messages automatically generated (w3-style or mozilla bugmail, e.g.). those
messages don't need to reside on the server. if we could delete them from the
server but store them locally, i could keep them all in a folder while removing
them from the server -- so it would be MUCH easier to check mails via a
webinterface, if you're not at home. i'll give it a vote. but shall we mark this
bug depentant of bug 13145, since it really would only make sense if this
feature was implemented (which i already voted for).

Comment 3

16 years ago
Finding this bug, ends the frustrations I've been having with "filters" and
deleting mail from my mail server.

Using a "Mozilla Mail" filter.. I filter all bugzilla email to a local folder. 
I suppose my *expectation* was that if I delete the (filtered) mail, it would
also be deleted on the server it originated from.

I was quite surprised the first time I checked my mail server (after using
filters), to find over 300 bugzilla emails that I *thought* I had deleted.

I am unsure what the majority of people would expect in this case, but I (for
one) would like to see an option to 'delete mail from server' after applying the
filter (moving the mail).

(note: 'mozilla0.9.9' keyword is outdated, please update)

Updated

16 years ago
Depends on: 13145

Updated

16 years ago
Blocks: 47297

Comment 4

16 years ago
This bug would probably be useful for deleting messages over a certain size for
people with slow connections, but otherwise, message aging in days (bug 11055)
would probably be more useful.
Depends on: 11055

Comment 5

16 years ago
Err, bug 107883 would be a better bug to depend on that bug 11055.
Depends on: 107883
No longer depends on: 11055

Comment 6

16 years ago
> When using filters to move mail away from the inbox, it does not delete the 
> mail from the POP server like when mail is moved manually from the inbox.

That this happens is bug 89034


> I'd suggest an option to delete the mail from the POP server for a [] filter
> rule.

This is a dupe of bug 74430

Finally I don't see how _implementation_ of this feature blocks or depends on
_implementation_ of the blocking and depending bugs, so am removing those.

I think this'll serve to un-entangle this entire mess (see also bug 104029) of
closely related bugs; if you disagree, please explain clearly where my reasoning
fails.

*** This bug has been marked as a duplicate of 74430 ***
No longer blocks: 47297
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 13145, 107883
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.