Closed Bug 10406 Opened 21 years ago Closed 21 years ago

[BLOCKER] Edit | Wallet | Safe Form Fill dialog is not drawn correctly

Categories

(Toolkit :: Form Manager, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jay, Unassigned)

References

Details

(Whiteboard: is this fixed now?)

The OK and Cancel buttons at the bottom can barely be seen in the Safe Form Fill
window (not visible at all on linux).

Steps:
1. Goto Edit|Wallet|Samples, fill out form and save...
2. Goto the amazon page and click Edit|Wallet|Safe Form Fill

Machine and builds:
Win98 build 1999072308
Linux RH 6 build 1999072308

Note: Still needs to be tested on Mac build when its available.
They are not visible on windows either, in a build that I just pulled.  This is
a regression.  paulmac, can you tell when this started happening?
This started on today's build, but there are other things, such as the sidebar
customization screen, with similar problems, I would hold off wasting too much
of your time on it...
Assignee: morse → don
Assigning to Don per decision reached in todays meeting.
Assignee: don → davidm
Priority: P3 → P1
Target Milestone: M9
David, is this our bug?
Blocks: 11349
Jay, can you not get to the OK button at all? If you can't, please mark this as
a blocker. Thanks.
I can get to the ok and cancel buttons on windows, but it is still not visible
at all on linux.  I wrote the bug because the positioning of the window content
is not correct...but lately pressing the "OK" button does not work.  Upon
selecting the name and clicking OK the dialog disappears but the field is not
filled in like it normally should.  Maybe this is a new bug? Paul, can you try
it out and file a bug if you agree.
Blocks: 11465
Severity: normal → blocker
Summary: Edit | Wallet | Safe Form Fill dialog is not drawn correctly → [BLOCKER] Edit | Wallet | Safe Form Fill dialog is not drawn correctly
marking this as a blocker because it prevents the testing of wallet. It looks
like Jay just filed a bug on the other issue
Depends on: 11611
I think the problem is that the dialog is too small. Once the new dialog code
goes hopefully the auto resize will fix this
OS: Windows 98 → All
Hardware: PC → All
Changing OS and Platform to ALL, since this is also happening on Mac.
Whiteboard: is this fixed now?
Assignee: davidm → morse
I just realized that this is not one of my dialogs so I don't understand why it
was assigned to me. Long term this should be rewritten in XUL and the code
should be using window.openDialog with the modal flag. Short term I would think
that just making the window bigger might solve the problem. reassign back to
steve who I assume made this dialog
Depends on: 11016
Status: NEW → ASSIGNED
Dialogs will be rewritten in xul once blocking bug 11016 is fixed.  Added that
to the dependency list.

Short term I could just make the middle frame smaller (it is currently specified
by a * in the frameset line).  I don't know how to make the window bigger.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Short-term fix checked in.  This will be all changed once it is rewritten in
xul, but there already is a bug report saying I should re-write in xul.  So I'm
closing out this report as fixed.

I should have made this simple fix a long time ago.
Status: RESOLVED → VERIFIED
aaaaaah, this is beautiful, marking verified on all platforms!
Assignee: morse → nobody
Product: Core → Toolkit
QA Contact: paulmac → form.manager
Target Milestone: M9 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.