Nightly is crashing in mozilla::net::CacheIndex::GetEntryForEviction or mozilla::net::CacheIndex::IsForcedValidEntry

VERIFIED FIXED in mozilla33

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mstange, Assigned: jaypoulz)

Tracking

({crash, regression})

Trunk
mozilla33
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Today's nightly kept crashing a few seconds after startup in my main profile, even in safe mode. Using a fresh profile I was able to look at the crash reports and see that the crash happened under CacheFileIOManager::OverLimitEvictionInternal(), so I cleared my main profile's cache directories and the crash stopped happening (for now).

Changes since yesterday's nightly: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0894d2cdb16d&tochange=e743fd8c57ed

Bug 1020416 is the only one among those that seems to be related to the cache, and its patch touches CacheIndex::GetEntryForEviction, so I think we have a winner.

Crash reports:
https://crash-stats.mozilla.com/report/index/20e41c5f-25eb-4d8c-82a1-4e3f22140721
https://crash-stats.mozilla.com/report/index/999468d9-ef46-4087-9940-b57082140721
https://crash-stats.mozilla.com/report/index/6a934f4b-6877-4223-a2ba-88c222140721
Crash Signature: [@ mozilla::net::CacheIndex::GetEntryForEviction(unsigned char (*) [20], unsigned int*)]
Duplicate of this bug: 1041491
Duplicate of this bug: 1041360
bug 1020416  is backed out now and new nightlys are generating
New nightlies are complete
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → jaypoulz
Target Milestone: --- → mozilla33
Duplicate of this bug: 1042065
Crash Signature: [@ mozilla::net::CacheIndex::GetEntryForEviction(unsigned char (*) [20], unsigned int*)] → [@ mozilla::net::CacheIndex::GetEntryForEviction(unsigned char (*) [20], unsigned int*)] [@ nsACString_internal::Assign(nsACString_internal const&, mozilla::fallible_t const&) | nsACString_internal::Assign(nsACString_internal const&) | mozilla::net::Cach…
Summary: Nightly is crashing [@ nsACString_internal::Assign(nsACString_internal const&, mozilla::fallible_t const&) | nsACString_internal::Assign(nsACString_internal const&) | mozilla::net::CacheIndex::GetEntryForEviction(unsigned char (*) [20], unsigned int*) ] → Nightly is crashing in mozilla::net::CacheIndex::GetEntryForEviction or mozilla::net::CacheIndex::IsForcedValidEntry
Duplicate of this bug: 1041958
don't see any reports on any other builds other than 20140721030205.

However, this crash accounts for 88% of all crashes reported yesterday (7/22).  It's likely going to be a while before all Nightly users figure out how to get off the broken build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.