Control the enhancement of history tiles with a pref

VERIFIED FIXED in Firefox 33

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

Trunk
Firefox 34
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified)

Details

Attachments

(1 attachment)

We'll want to allow the user to turn on/off enhancement of history tiles from bug 1036299, and we'll default it to false for now. It'll be the same pref we toggle for bug 1037091.
Flags: firefox-backlog+
Posted patch v1Splinter Review
These are the tests you're looking for! ;)
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attachment #8460673 - Flags: review?(adw)
Comment on attachment 8460673 [details] [diff] [review]
v1

Review of attachment 8460673 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8460673 - Flags: review?(adw) → review+
Blocks: 1030832
https://hg.mozilla.org/mozilla-central/rev/db89140be503
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Iteration: --- → 34.1
QA Whiteboard: [qa?]
QA Whiteboard: [qa?] → [qa+]
QA Contact: cornel.ionce
Tested on latest Nightly, build ID: 20140727030204.

The "browser.newtabpage.enhanced" pref is set to false and the default selection in about:newtab page is Classic.
However, I don't see any change when the pref is set to true (about:newtab set to enhance). The enhance content (bug 1036299) is shown in both cases (classic / enhanced) while using a new profile.

Is there something I'm missing?
Flags: needinfo?(edilee)
You need to have a history visit to a mozilla.org page to see the history tile get enhanced for enhanced view.
Flags: needinfo?(edilee)
Nightly 34.0a1 (2014-08-03), Build ID: 20140803030203.

Confirmed that:
1) the default history tile mode is 'Classic', with the 'browser.newtabpage.enhanced' pref set to false
2) enabling 'Enhanced' mode from the gear button sets the 'browser.newtabpage.enhanced' pref to true
3) enabling 'Blank' mode from the gear button sets the 'browser.newtabpage.enable' pref to false
3.1.) if 'Enhanced' mode was enabled prior to this change, the 'browser.newtabpage.enhanced' remains true
4) various mozilla.org tiles are displaying the enhanced view - white mozilla text on grey background - (as stated in Comment 5)
4.1) I was unable to see the same behavior with any other website except *.mozilla.org

Ed, please let me know what are your thoughts on 3.1) and 4.1).
Flags: needinfo?(edilee)
QA Contact: cornel.ionce → andrei.vaida
Iteration: 34.1 → 34.2
(In reply to Andrei Vaida, QA [:avaida] from comment #6)
> 3.1.) if 'Enhanced' mode was enabled prior to this change, the
> 'browser.newtabpage.enhanced' remains true
Sounds good. This lets the user toggle the about:config pref to get back to what they saw before selecting blank.

> 4) various mozilla.org tiles are displaying the enhanced view - white
> mozilla text on grey background - (as stated in Comment 5)
> 4.1) I was unable to see the same behavior with any other website except
> *.mozilla.org
Yup. Only mozilla.org tiles have enhanced tiles data.
Flags: needinfo?(edilee)
Thank you for the clarifications, Ed.

This is now verified fixed on Nightly 34.0a1 (2014-08-06) using Windows 7 64-bit, Mac OS X 10.9.4 and Ubuntu 13.04 32-bit.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
Depends on: 1050705
Blocks: 1057602
Uplift has been managed in bug 1057602
Verified fixed on Aurora 33.0a2 (2014-08-27) as well, using Windows 7 64-bit, Ubuntu 14.04 LTS 32-bit and Mac OS X 10.9.4.

One note though, in comparison with my note from Comment 6, the default history tile mode for a clean profile is now 'Enhanced', instead of 'Classic'. Was this intended?
Flags: needinfo?(edilee)
Bug 1042214 changed the default from enhanced = false to enhanced = true unless upgrading with DNT = on/send.
Flags: needinfo?(edilee)
You're also using the enhanced preference to control whether or not tracking information is sent from the new tab page.

This seems like a bad double use of a preference.
I concur with Mike. "enhanced" is void of meaning and a bad name. Prefs should be for specific features, not collections of features, e.g. "doTracking" and "useOverrideImages" or similar.
FWIW, this is a problem now, because we want to turn off tracking, and don't know how
You need to log in before you can comment on or make changes to this bug.