Add gear button with doorhanger configuration of newtab page

VERIFIED FIXED in Firefox 33

Status

()

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 34
Points:
8
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified)

Details

Attachments

(4 attachments, 3 obsolete attachments)

From the prototype: http://bg61zt.axshare.com/new_tab.html

There'll need to be a gear icon to customize the new tab page with presets:
- enhanced
- classic
- blank

Where these presets toggle various show/hide customizations for the page:
- enhanced images
- search box
- tiles
- messaging/explanation area

enhanced = all
classic = search + tiles
blank = none
Flags: firefox-backlog+
(Assignee)

Updated

4 years ago
Depends on: 1042204
(Assignee)

Comment 1

4 years ago
Created attachment 8461258 [details] [diff] [review]
v1
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attachment #8461258 - Flags: review?(adw)

Comment 2

4 years ago
Comment on attachment 8461258 [details] [diff] [review]
v1

Review of attachment 8461258 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, the only thing is that I think "customize" would be a better name for everything than "gear," but it's a nit, so feel free to ignore.
Attachment #8461258 - Flags: review?(adw) → review+
(Assignee)

Comment 3

4 years ago
This patch uses the svg added in bug 1037341.
Depends on: 1037341
(Assignee)

Comment 4

4 years ago
Created attachment 8462106 [details] [diff] [review]
for checkin
Attachment #8461258 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Blocks: 1040369
https://hg.mozilla.org/mozilla-central/rev/999c74d2ab23
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34

Updated

4 years ago
Iteration: --- → 34.1
QA Whiteboard: [qa?]

Comment 6

4 years ago
Can anyone confirm that the gear button changes sizes on new tab openings?
https://bugzilla.mozilla.org/show_bug.cgi?id=1044570
QA Whiteboard: [qa?] → [qa+]
QA Contact: cornel.ionce
I've verified this using the latest Firefox 34 Nightly build (20140804030205) on: Win 7 x64, Win 8 x64, Win 8.1 x64, Ubuntu 12.04 x64, Mac OS X 10.9.4.

I was able to verify that the following work as expected:
- gear icon displays in the top right corner of the New Tab page, and has an alternative image when hovered/selected
- gear icon opens a list with options: Enhanced, Classic (default), Blank
- selecting Enhanced will set the following:
     * browser.newtabpage.enabled=true
     * browser.newtabpage.enhanced=true
     * enhanced history tiles will display in all New Tabs for *.mozilla.org (bug 1042204 comment 6)
- selecting Classic will set the following:
     * browser.newtabpage.enabled=true
     * browser.newtabpage.enhanced=false
     * non-enhanced regular history tiles will display in all New Tabs for *.mozilla.org (bug 1042204 comment 6)
- selecting Blank will set the following:
     * browser.newtabpage.enabled=false
     * browser.newtabpage.enhanced=false/true (depends if switched from Enhanced or Classic)
     * all New Tab pages will display empty (with just the gear icon visible and accessible)
- transitions between the 3 options work fine

Potential issues:
1. For now I see that there's not much difference between Enhanced and Classic modes - the only difference is that in Enhanced mode we display enhanced history tiles with a rollover picture on hover (see bug 1042204 comment 6). This means that the "messaging/explanation area" is not seen... let me know if this is an issue (I'm guessing it's not or will not be implemented?).
2. Gear icon is invisible in High Contrast modes (white, black, color) in Windows - see attached image
3. Gear icon looks rather blurry while in hovered/selected state - see attached image
4. Can open/dismiss list of options via keyboard, but cannot select one of the options in the list via keyboard

(In reply to Mikel from comment #6)
> Can anyone confirm that the gear button changes sizes on new tab openings?
> https://bugzilla.mozilla.org/show_bug.cgi?id=1044570
I've tried to reproduce this in all 5 operating systems that I've used, but was unsuccessful. I could not get the gear icon to change size even after quickly opening 60-70 New Tabs.

Ed, can you review what was tested above, and especially the list of potential issues, and let me know whether I should file them separately (and close this) or reopen this issue.
Flags: needinfo?(edilee)
Created attachment 8467077 [details]
blurry_gear_icon.png
Created attachment 8467078 [details]
newtab_gear_icon_high_contrast.png

Updated

4 years ago
Iteration: 34.1 → 34.2
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #7)
> 3. Gear icon looks rather blurry while in hovered/selected state - see
> attached image

Looks like tjis is bug 1046693.
(Assignee)

Comment 11

4 years ago
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #7)
> 1. For now I see that there's not much difference between Enhanced and
> Classic modes
Yup. For now it's just the enhancement of history and there's not many history tiles that are getting enhanced right now.

> 2. Gear icon is invisible in High Contrast modes (white, black, color) in
> Windows - see attached image
Please file a followup.

> 3. Gear icon looks rather blurry while in hovered/selected state - see
> attached image
Bug 1046693.

> 4. Can open/dismiss list of options via keyboard, but cannot select one of
> the options in the list via keyboard
A followup for this too. Bug 1044537 is related to the menu items but not about keyboard access. Also, I would think gear menu item related issues should be the same with the search engine selection menu.
Flags: needinfo?(edilee)

Comment 12

4 years ago
(In reply to Ed Lee :Mardak from comment #11)
> > 4. Can open/dismiss list of options via keyboard, but cannot select one of
> > the options in the list via keyboard
> A followup for this too. Bug 1044537 is related to the menu items but not
> about keyboard access. Also, I would think gear menu item related issues
> should be the same with the search engine selection menu.

Yes, please file individual follow-ups for each menu.
Depends on: 1051861
Depends on: 1051865
(In reply to Ed Lee :Mardak from comment #11)
> (In reply to Florin Mezei, QA (:FlorinMezei) from comment #7)
> > 2. Gear icon is invisible in High Contrast modes (white, black, color) in
> > Windows - see attached image
> Please file a followup.
Added bug 1051861.

> > 4. Can open/dismiss list of options via keyboard, but cannot select one of
> > the options in the list via keyboard
> A followup for this too. Bug 1044537 is related to the menu items but not
> about keyboard access. Also, I would think gear menu item related issues
> should be the same with the search engine selection menu.
Added bug 1051865 for the gear icon, and bug 1051873 for the Search Provider button.

Marking this as verified since follow up bugs are tracked separately, and have been added to the backlog.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
(Assignee)

Comment 14

4 years ago
To land this for aurora, we need to not change strings. This means the functionality for aurora non-en-US users will see a gear icon that toggles the newtab page.
(Assignee)

Updated

4 years ago
Blocks: 1056279
(Assignee)

Comment 15

4 years ago
Created attachment 8476446 [details] [diff] [review]
for aurora

For uplift to aurora, we want to avoid string changes in the properties/dtd.
Attachment #8476446 - Flags: review?(adw)
(Assignee)

Updated

4 years ago
Attachment #8476446 - Attachment is patch: true
(Assignee)

Updated

4 years ago
Attachment #8476446 - Flags: review?(adw)
(Assignee)

Comment 16

4 years ago
Created attachment 8477109 [details] [diff] [review]
aurora delta

This patch is on top of the one landed in m-c, but when landing this patch for aurora, it'll be squashed into the same commit so there's no churn of locales files.
(Assignee)

Updated

4 years ago
Blocks: 1057602
(Assignee)

Comment 17

4 years ago
Created attachment 8477762 [details] [diff] [review]
aurora delta

Here's a patch on top of what landed in m-c but to make it string-freeze-friendly for aurora uplift.
Attachment #8476446 - Attachment is obsolete: true
Attachment #8477109 - Attachment is obsolete: true
Attachment #8477762 - Flags: review?(adw)
(Assignee)

Updated

4 years ago
status-firefox33: --- → affected
status-firefox34: --- → verified

Updated

4 years ago
Attachment #8477762 - Flags: review?(adw) → review+
(Assignee)

Updated

4 years ago
status-firefox33: affected → fixed
Verified fixed on Windows 7 64bit, Mac OS X 10.8.5 and Ubuntu 14.04 32bit using latest Aurora, build ID: 20140828004002.
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.