[shumway] Google Finance charts fails with TypeError: v368 is null shumway.js line 769 > Function:210

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

4 years ago
Shumway renders Google Finance charts with X scale squashed 50% and then fails with TypeError: v368 is null shumway.js line 769 > Function:210 in the web console.

https://www.google.com/finance?q=VBMFX

I see the following Shumway errors in the web console:

 "Session #2: loaded 8331/8331" avm-sandbox.js:237
 "Session #2: closed" avm-sandbox.js:231
 "Session #3: loaded 8684/8684" avm-sandbox.js:237
 320 shumway.js:1428
 TypeError: v368 is null shumway.js line 768 > Function:210
 ...
 Initialize Renderer: 1374.1ms shumway.js:234
 "AVM1 error: Error: Object "XML" is not found" shumway.js:1064
 "AVM1 error: Error: Method load is not defined." shumway.js:1064

This bug is a clone of Shumway GitHub issue #1222: https://github.com/mozilla/shumway/issues/1222
No longer blocks: 1037568
(Reporter)

Updated

4 years ago
Blocks: 1038057
Priority: -- → P4
Duplicate of this bug: 1085117

Comment 2

4 years ago
I get this error

TypeError: v403 is null
shumway.player.js line 9307 > Function:191
ShumwayStreamConverter.js: Timeout during shumway instance initialization

And a ridiculous amount of these warnings
"Font metrics for "Helvetica" unknown. Fallback to default." shumway.player.js:142
(Reporter)

Updated

4 years ago
Blocks: 1037580
No longer blocks: 1038057
The chart is now rendered pretty much correctly, and works to some extent. Not everything works, but the issue reported here is gone, so marking fixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.