Disabling MAPI Send gives me an error about not being able to set N6 as default mail

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
17 years ago
7 years ago

People

(Reporter: lchiang, Assigned: srilatha)

Tracking

Trunk
mozilla1.2alpha
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Disabling MAPI Send gives me an error about not being able to set N6 as default mail

Win32 build 2001-10-10-094 branch

I can't reproduce this, but I thought I would log this problem since it's very
confusing.

1.  After using MAPI Send for a while (sending from Word, Excel, Powerpoint), I
thought I'd try to disable the pref.  I had exited all of those applications.
2.  In Netscape 6, open preferences dialog
3.  Uncheck the option to use MAPI Send
4.  Get an error msg:

"Netscape 6 could not be set as the default mail application because a registry
key could not be updated.  Verify with your system administrator that you have
write access to your system registry, and then try again."

This is a strange error to get:
a.  I'm not trying to set Netscape 6 as the default mail app.  I'm unchecking to
use MAPI Send.
b.  I have write permission to my system.  Otherwise, I would not have been able
to enable this preference in the first place.

I will to reproduce some more.

Under what conditions would a user normally see this dialog?  Is it even
supposed to come up when unchecking the MAPI Send pref?

Comment 1

17 years ago
Srilatha will take a look in Lisa's machine.
Assignee: tiantian → srilatha
Priority: -- → P3
Let's get some more investigation on this one.

Pls look at Bug 103065, because the dialogue for that bug is coming up here.
Keywords: nsbranch

Comment 3

17 years ago
This is a known problem and is rel. noted.  This can be taken up for this 
release, if L10N guys are ready to translate new strings and if there is 
permission from UI people for new error dialogs.

Comment 4

17 years ago
But Krishna, the reason we brought it up again is because we don't have to add a
new string. According to Lisa's findings in 103065, she actually saw this very
dialog come up when she was trying to unselect mozilla as her default mail app.
(Reporter)

Comment 5

17 years ago
Actually, according to this bug 104256, I see an error dialog which may be able
to be reused (called) when the condition in bug 103065 is encountered.
(Assignee)

Comment 6

17 years ago
Lisa, I think you got the error message, because
While disabling the pref, if the mapi32.dll is ours we replace it with the 
mapi32_moz_bak.dll.
At the time, when you tried to disable simple MAPI, the mapi32.dll is in use so 
replacing the mapi32.dll failed. 

As Krishna pointed out above, we are displaying one error dialog for serveral 
cases, since we could not add new strings because of the UI/l10n freeze. 
Ideally, The error message should be some thing like "The MAPI32.dll is in use. 
Cannot disable the pref. Please close all other applications and try again".



PDT-, pls relnote this one.
Keywords: relnote
Whiteboard: [PDT-]

Comment 8

17 years ago
Release note has been updated for this bug.

Updated

17 years ago
Keywords: nsbeta1

Updated

17 years ago
Blocks: 107065

Updated

17 years ago
Keywords: nsbranch

Updated

17 years ago
Blocks: 103807

Updated

17 years ago
Target Milestone: --- → mozilla0.9.8

Comment 9

17 years ago
Suggested wording for error message: "The preference "Use Netscape Mail as the 
default mail application" could not be changed. Try closing all other mail 
programs, all MS Office programs, and any other programs (for example, Wordpad), 
that can be used to send mail, and then try again."

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: P3 → P2
(Assignee)

Comment 10

17 years ago
Right now we only one error message for handling all the error cases.
The error message we have is 
"Netscape Mail could not be set as the default mail application because a 
registry key could not be updated. Verify with your system administrator that 
you have write access to your system registry, and then try again."

It is better if we can have different messages. Here are the error cases. These 
cases can happen while setting/unsetting the preference.

1) Swapping the dll failed because it is in use or the user does not have 
permission
2) Setting the registry keys failed.

For the first case, we should have something like
"Not able to swap mapi32.dll. Either it is in use or you do not have permission 
to the system directory. Try closing all other mail programs, all MS Office 
programs, and any other programs (for example, Wordpad), that can be used to 
send mail, and then try again or contact your system administrator"

For the second case
"Registry key could not be updated. Verify with your system administrator that 
you have write access to your system registry, and then try again."
Robin, what's your take on this?

Comment 11

17 years ago
I agree it's best to have separate error messages for different error conditions.

First error case: "Netscape Mail could not be set as the default mail
application. Try closing all other mail programs, all MS Office programs, and
any other programs (for example, Wordpad), that can be used to send mail, and
then try again."

Second error case: Use the existing error message "Netscape Mail could not be
set as the default mail application because a registry key could not be updated.
Verify with your system administrator that you have write access to your system
registry, and then try again."



 
(Assignee)

Comment 12

17 years ago
As mentioned above we will run into the first and second error cases while 
trying to set and unset the preference. Either we have to have four error 
messages, 2 for setting the pref and 2 for unsetting the pref or 
We can have only two error messages if we can replace the words
"Netscape Mail could not be set as the default mail application." to something 
like "The preference "Use Netscape Mail as the default mail application" could 
not be changed"

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.8 → mozilla0.9.9
removing PDT grafitti.
Whiteboard: [PDT-]

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 14

17 years ago
After discussing with Srilatha, I think having one message for each of the four
scenarios is the best approach:

First error condition (.dll error):

Error setting pref: "Netscape Mail could not be set as the default mail
application. Try closing all other mail programs, all MS Office programs, and
any other programs (for example, Wordpad), that can be used to send mail, and
then try again."

Error unsetting this pref: "Your default mail application could not be changed.
Try closing all other mail programs, all MS Office programs, and
any other programs (for example, Wordpad), that can be used to send mail, and
then try again."

Second error condition (registry error):

Error when setting pref: "Netscape Mail could not be
set as the default mail application because a registry key could not be updated.
Verify with your system administrator that you have write access to your system
registry, and then try again."

Error when unsetting pref: "Your default mail application could not be changed.
Verify with your system administrator that you have write access to your system
registry, and then try again."

Comment 15

17 years ago
Correction to error message #4:

Error when unsetting pref: "Your default mail application could not be changed
>>because a registry key could not be updated.<< Verify with your system
administrator that you have write access to your system
registry, and then try again."


Comment 16

17 years ago
I'm adding this comment because it seems closest to my problem.

I'm on win95 with Netscape 4.77 installed.

I have installed the latest general build of mozilla 0.9.8 (02/04/02)

I'm using a Boy Scout recordkeeping software package called TroopMaster and
every time I try and send (email) the data files I get the message ".... could
not be set as the default mail application because a registry key could not be
updated.  Verify with your system administrator that you have
write access to your system registry, and then try again."

Can I get this to work ?

Comment 17

17 years ago
nsbeta1- as per ADT
Keywords: nsbeta1+ → nsbeta1-

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend
The "MAPI Send" preference no longer exists, at least under that name  ->  
WontFix

The error message discussed in this bug is reported 
in bug 224824 and bug 248003, quite possibly others.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: MailNews → Core
Product: Core → MailNews Core
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.