Closed Bug 224824 Opened 19 years ago Closed 18 years ago

Cannot set Mozilla as default mail application

Categories

(MailNews Core :: Simple MAPI, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: painterengr, Assigned: cavin)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031030

This is the same as bug 144456 but now applied to mozilla version 1.6a

Reproducible: Always

Steps to Reproduce:
1. in mail and newsgroup preferences check "use mozilla as the default mail
application".  select OK
2. error dialog box pops up stating in part that mozilla could not be made the
default because a registry key could not be updated.
3.

Actual Results:  
error dialog box pops up stating in part that mozilla could not be made the
default because a registry key could not be updated.

Expected Results:  
silently changes the default mail application to mozilla.

how about reporting in this dialog box the key names that it is trying to update
so we could have a chance at isolating the problem?
use regmon from sysinternals.com to find the key :-)
I´m using Mozilla as my default mail client on Win98 and Win98SE, and often
changing builds, so I often get asked for making Mozilla my default mail client.
I´ve never got problems.
Where is your profile located, and is it writable, especially registry.dat in
the folder holding the folder Profiles, i.e. c:\windows\Application Data\Mozilla ?

But reading Bug 141965 comment 2 the windows registry can´t be updated, not the
netscape registry. Please read this comment, and there is other useful info in
this bug, which got duped to Bug 207947, also containing some more info about
the keys, which got duped to bug 202497.


*** This bug has been marked as a duplicate of 202497 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
this can't be ralted to bug 207947 and this can't be a dupe of bug 202497.
Bug 202497 is about an incomplete registry setting that cause a few applications
don't launch Mozilla as default mail application.

This bug is that Mozilla can't set itself as default mail application because it
gets an error while doing that.

Reporter:
Please respond in this bug and not via mail - Thanks !

You got this error:
1. 39.98954560    Mozilla:FA4FA095    QueryValueEx
0xC1CA1050\C:\WINDOWS\SYSTEM\MAPI32    NOTFOUND       

Do you have a mapi32.dll in the windows\system32 directory ?

 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Matti, should 
Bug 141965 Does not register as Windows Default Mail Client
be reopened, as it is duped to bug 207947 -> bug 202947 ?
on win98 (as updated by microsoft) the mapi dll are located in c:\windows\system
(not system32).

my system has c:\windows\system\mapi32.dll and is version 4.00.834.840, Oct 2000.

IE 5.5 showed a blank e.mail application in the options.  the drop down list
does have mozilla mail listed and can be selected.

also, i have received the same mail application registration failure notice with
ALL of the mozilla versions i have installed previously.
i do not use outlook and outlook express.  as such, i uninstalled both of them
long ago.  however, i regularly perform the microsoft windows update and office
2000 update.  looking in my control panel installed software list i do not see
either of these (except the office 2000 entry) BUT there is an entry for
"outlook express update Q330994".

i have office 2000 premium service pack 3 installed.  i just ran the office
setup and see that outlook in still installed.  outlook express is not.

also, i have the old microsoft fax (atwork fax and windows messaging) installed 
from the win98 cd (cd path drive:\tools\oldwin95\message\us\{awfax.exe,wms.exe}.
this problem is the same on version 1.6b as it was on 1.6a.
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

this problem is the same on version 1.6 as it was on 1.6b and 1.6a.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316

this problem is the same on version 1.7b as it was on 1.6, 1.6b and 1.6a.
Mozilla/5.0 (Windows; U; Win98; 1.7 release candidate 1

this problem is the same on Win98 for version 1.7 rc1 as it was on 1.7b, 1.6,
1.6b and 1.6a.
I have the same problem with Windows 2000 Service Pack 4.  I am logged in as an
administrator.  I have double checked that I have all read and write access to
all files and folders on the computer.  My profile is in the default location.  

When I try to set mozilla mail as my default mail client, I get a message that
says that Mozilla Mail cannot edit a registry value to make it the default mail
client and to please see my system administrator.  

There is no reference to any registry keys.  

I've had this error with bot Mozilla 1.6 and 1.7 RC.

-Vaughn L. Reid III
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040514 (RC 2)

this problem is the same on Win98 for version 1.7 rc2 as it was on 1.7 rc1,
1.7b, 1.6, 1.6b and 1.6a.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520

This problem is the same on Win98 for version 1.8a1 as it was on 1.7 rc2, 1.7
rc1, 1.7b, 1.6, 1.6b and 1.6a.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040714

This problem is the same on Win98 for version 1.8a2 as it was on 1.8a1, 1.7 rc2,
1.7 rc1, 1.7b, 1.6, 1.6b and 1.6a.
Richard Painter: comment 1 is a clue.  You should run regmon and get a log of 
what happens when you try to make Mozilla the default.  Attach the log to this 
bug, and maybe we can figure it out.

Regmon is here:
  http://www.sysinternals.com/ntw2k/source/regmon.shtml

It's very odd that you would get that error, as Win98 (to my knowledge) does not 
have access control to registry keys; that feature is specific to NT/2K/XP.
Bug 248003 is about the same problem with TB0.7 on WinXP.  
There is a regmon log attached to that bug.
From bug 104256 comment 10:
> Right now we only one error message for handling all the error cases.
> The error message we have is 
> "Netscape Mail could not be set as the default mail application because a 
> registry key could not be updated. Verify with your system administrator that 
> you have write access to your system registry, and then try again."
> 
> It is better if we can have different messages. Here are the error cases.
> These cases can happen while setting/unsetting the preference.
>
> 1) Swapping the dll failed because it is in use or the user does not have
>    permission
> 2) Setting the registry keys failed.

Regarding DLL swap -- see bug 109362.
Depends on: 109362
(In reply to comment #17)
> Regarding DLL swap -- see bug 109362.

Richard Painter, did the information at bug 109362 comment 26 resolve your 
problem?
Product: MailNews → Core
No response from reporter  => WFM

Recent versions of Mozilla are using the same technique for setting as default 
mail client as Thunderbird has been using.  Some problems have arisen due to 
that -- see bug 279627.  I don't believe that is the problem with this bug, 
however.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.