bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

[User Story] Remove notification icons from status bar

RESOLVED FIXED in Firefox OS v2.1


Firefox OS
4 years ago
3 years ago


(Reporter: pdol, Assigned: albertopq)



2.1 S3 (29aug)
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 fixed)


(Whiteboard: [ucid:System246], [ft:systemsfe])

User Story

As a user, I want my notification icons removed from the status bar so as to make more room for other status bar icons.

Acceptance Criteria:
1. The old notification indicator is no longer displayed in the status bar.
2. When I have new notifications that I have not looked at, a new indicator is used to inform me of them, per UX spec.


(5 attachments, 1 obsolete attachment)

Comment hidden (empty)
Created attachment 8479388 [details]
[Spec 2.1] Ambient Notification
Created attachment 8479389 [details]
[Spec 2.1] Notification Flow
Created attachment 8479390 [details]
[Video Spec 2.1] Ambient notification indicator
Alberto, can you help out with this?

Note: for the ambient notification toaster animation, I have a demo from a while ago that has some keyframes that might give you a jump start here:

Assignee: nobody → apastor
Created attachment 8479988 [details]
[Spec 2.1] Ambient Notification

Update Spec
Attachment #8479388 - Attachment is obsolete: true

Comment 6

4 years ago
Created attachment 8480709 [details] [review]
Ambient notifications first approach

Sorry for the delay.
Attaching the first approach for the ambient notification implementation. Probably still some tweaks in terms of timings of the animation to be done, but I'll like to start getting some feedback.

Attachment #8480709 - Flags: feedback?(mhenretty)


4 years ago
Attachment #8480709 - Flags: ui-review?(epang)
Duplicate of this bug: 1052222


4 years ago
Attachment #8480709 - Flags: ui-review?(rmacdonald)
Comment on attachment 8480709 [details] [review]
Ambient notifications first approach

Plus'ing based on the IxD / behaviour but this is subject to Eric's visual review. I'll also email Eric about some potential visual polish and ways to improve contrast in some scenarios.
Attachment #8480709 - Flags: ui-review?(rmacdonald) → ui-review+
Just realized one issue. The portion of the ambient indicator that varies based on the number of notifications should be based on the number of <em>unseen</em> notifications as opposed to the number of total notifications. I'll double check the spec and make any changes.
Comment on attachment 8480709 [details] [review]
Ambient notifications first approach

Hey Alberto,

Thanks for working on this!  It's look really good, but there are some visual changes that are needed.

Notification Toast:

1. The Notification Icon should be vertically centered in the toast

2. Calls, SMS (and others that are two lines) should include both lines.  For example, for SMS, The Name should be on the first line (18px, regular) and the message on the second (14px, regular).

3.  For single line notifications - They should be vertically centered with the notification icon.

4.  The background colour of the toast should be #00BCE2 (this will make sense with #3 below)

Indicator Bar:

1. Can we reduce the indicator by 1px?  It's currently to spec, but seeing it implemented Rob is right, it looks to dominant as is. 

2. The handle should transition from white to #B3F3FF (while the opacity increases) 

3. When the handle expands to the sides of the screen (for the first notification) it should transition from #B3F3FF to #00BCE2

Thanks again!  Please let me know if you have any questions!
Attachment #8480709 - Flags: ui-review?(epang) → ui-review-
Flags: needinfo?(alberto.pastor)

Comment 11

4 years ago
Hi Eric,

Thanks for the feedback!
Regarding the notification toast, I didn't touch it at all. I thought this bug was only about removing the notifications indicator in the status bar (and replace it with the ambient indicator).

Should I fix the toast as part of this bug as well?

Regarding the indicator, I'll fix it today.

Flags: needinfo?(alberto.pastor)
Comment on attachment 8480709 [details] [review]
Ambient notifications first approach

Thanks for making all the changes!  It looks great now :) R+
Attachment #8480709 - Flags: ui-review- → ui-review+
Comment on attachment 8480709 [details] [review]
Ambient notifications first approach

LGTM! Probably ready for the real r? after tests are fixed :)
Attachment #8480709 - Flags: feedback?(mhenretty) → feedback+


4 years ago
Attachment #8480709 - Flags: review?(mhenretty)
Comment on attachment 8480709 [details] [review]
Ambient notifications first approach

A couple of nits, but overall this is very cool to see!
Attachment #8480709 - Flags: review?(mhenretty) → review+


4 years ago
Last Resolved: 4 years ago
Resolution: --- → FIXED
feature-b2g: --- → 2.1
Reverted in master for causing bug 1060627.
master:  https://github.com/mozilla-b2g/gaia/commit/efd04e972d961bd6e1a06ce2298e82025673b28b

We are going to squash the fix from bug 1060627 into this when we reland.
status-b2g-v2.1: fixed → affected
Resolution: FIXED → ---
No longer depends on: 1060627
Duplicate of this bug: 1060627
Created attachment 8481633 [details] [review]
[Gaia PR] reland with fix from bug 1060627

This is Alberto's patch with the fix from bug 1060627 squashed into his commit. Waiting for green before relanding.
Attachment #8481633 - Flags: review+
feature-b2g: 2.1 → ---
master: https://github.com/mozilla-b2g/gaia/commit/91d0294120eaa35a60f84fe82c7d89d2e01902cb
Last Resolved: 4 years ago4 years ago
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED
Depends on: 1060935
Duplicate of this bug: 1044115
Duplicate of this bug: 1054312
Duplicate of this bug: 1047251
Target Milestone: --- → 2.1 S3 (29aug)


4 years ago
No longer blocks: 1063601


4 years ago
Blocks: 1063601
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.