If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FF29 above crashes on my Android

RESOLVED DUPLICATE of bug 1067429

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1067429
3 years ago
a year ago

People

(Reporter: Spencer, Assigned: bnicholson)

Tracking

31 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Opening a new tab

Deleting a bookmark from the Awesome Screen

Loading a heavy site


Actual results:

All results will crash the application


Expected results:

I'm currently using Firefox 28, Did not upgrade to later versions due to the crashes.

I expected it to uh, do what it said? lol


Android 3.2 (Honeycomb)
Samsung Galaxy Tab 7.0 Plus

I'm used to using Firefox for my browser in the device, So i did not remove it but downgraded it
(Reporter)

Updated

3 years ago
OS: Windows XP → Android
Hardware: x86 → Other
(Reporter)

Updated

3 years ago
Hardware: Other → All
Please try out Firefox 31 which is the latest version we shipped.

If still crashing, please report back here on the crash report ID associated with your crash in about:crashes

https://support.mozilla.org/en-US/kb/Mozilla%20Crash%20Reporter#w_viewing-crash-reports
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

3 years ago
Same thing happened, as said on title. FF29 above

Crash IDs (Tested on FF31)

Opening a New Tab:
bp-4e5c2d88-dbb4-4ac3-913a-683492140725

Deleting a Bookmark from the awesome screen:
bp-fb7eeb3e-7bfc-4e38-b331-e7a402140725

Loading a heavy site:
Seems to be fixed.
(Reporter)

Updated

3 years ago
Version: Firefox 29 → Firefox 31
Thanks. This is an issue on the GT-P6200 device in particular. We have a fix on Nightly (http://nightly.mozilla.org) for Android.
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 976375
(Reporter)

Comment 4

3 years ago
Okay, Thanks for the help. I'll be waiting for the fixed version, for now i'm gonna use FF 28.0.1. Just can't stand browsing the internet without FF

Goodluck on the bug fix
(Assignee)

Comment 5

3 years ago
(In reply to Spencer from comment #4)
> Okay, Thanks for the help. I'll be waiting for the fixed version, for now
> i'm gonna use FF 28.0.1. Just can't stand browsing the internet without FF

Any chance you'd be willing to try out the latest Nightly to make sure this is actually fixed? We don't have one of these devices to reproduce the problem, so we were just making a blind attempt at a fix. If so, you can download Nightly at http://nightly.mozilla.org/.

Note that the fix in bug 987864 just landed today, so the APK linked there may still be broken, but it should be updated tomorrow.
(Reporter)

Comment 6

3 years ago
Hey! So i've tested Nightly on the device and the New Tab problem is gone!. Sadly, the Awesome Screen Bookmark deletion is still broken.

Crash ID:bp-c8509292-116f-4225-8289-af7a02140725
Another loadDrawable crash? Re-open and morph this bug? Brian?
(Assignee)

Comment 8

3 years ago
(In reply to Spencer from comment #6)
> Hey! So i've tested Nightly on the device and the New Tab problem is gone!.
> Sadly, the Awesome Screen Bookmark deletion is still broken.
> 
> Crash ID:bp-c8509292-116f-4225-8289-af7a02140725

Hey Spencer, the Nightly APK linked there wasn't updated until this morning around 10:30AM, so you probably got yesterday's Nightly which didn't include the fix. Can you try downloading the latest Android Nightly again from http://nightly.mozilla.org/ ? Thanks!
Just opening Firefox and browsing to a page should initiate the update download. Then just tap the update notification in the Android status area. No need to manually update Firefox.
(Reporter)

Comment 10

3 years ago
Redownloaded Nightly just incase (Please note the one i downloaded is 'Android', not the ARMv6 or x86 version. Just 'Android'

Restarted the device, installed Nightly, then restarted the device again. Just to make sure

Results:

Opening a New Tab: Fixed
Removing a bookmark from the Awesomescreen: Crashed

Crash ID: bp-b62fcc2d-8f62-4ee5-a355-b344d2140726
(Assignee)

Comment 11

3 years ago
The resource in these crash reports is frequently changing (currently it's 0x7f0d0090), but it always points to the same resource: GeckoActionBar.

From "aapt l -a <fennec-nightly>.apk":
      spec resource 0x7f0d0090 org.mozilla.fennec_aurora:style/GeckoActionBar: flags=0x00000400

But looking at the definitions/references for GeckoActionBar, nothing pops out; it's also unclear to me how this would be related to Toast.makeText (which is always in the crash stacks). I'll try to get my hands one of these tablets to see what's going on. In the meantime, we could go with a band-aid try/catch around the problem areas.

Spencer, thanks for all of your help so far! Can you tell me if any/all of the following also result in a crash in Nightly?:
* Bookmarking a page
* Adding/removing a page to/from reading list
* Downloading an add-on

These are all various places in our code where we use Toast.makeText(), and therefore places we would need to wrap if they crash.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(spencerivans13)
Resolution: DUPLICATE → ---
(Assignee)

Updated

3 years ago
Assignee: nobody → bnicholson
Status: REOPENED → ASSIGNED
(Reporter)

Comment 12

3 years ago
Hello Brian! Thank you again for all the help, I'm sorry if i haven't replied much for the past weeks. Too many school work that i did not have time to pay attention to my bug report, silly me.


Anywho, I've decided to do what you have told me. Although, I'm really tired (Typing right now at 1 AM). But, you have my assurance that i will respond sometime this weekend about the results.

Thank you for your patience
-Spencer
Flags: needinfo?(spencerivans13)
(Reporter)

Comment 13

3 years ago
Hey! Again, i'am SO Sorry. My school just keeps dropping activities on my back that i can't focus on this.

Nightly version used: 34.0a1 (Android, not x86 version)

BUG TESTS:
Bookmarking a page:
Webpage used - https://www.mozila.org/en-US/
Results - No crash

Adding/removing a page to/from reading list:
Webpage used - https://www.mozila.org/en-US/privacy/
Results - Crashed: bp-c88b048d-c339-4da1-bdde-65f892140823
Extras - It was successfully added to the reading list, but crashes when i start to scroll or wait for a bit. I also can't test if it crashes on removing a page from the reading list, as the page i added to the reading list was removed/disappeared

Downloading an add-on:
Add-on downloaded - 'Save Link Menus' by takachan from the official Mozilla add-ons page
Results - Crashed: bp-bcf4f937-aa7c-41b8-8513-7a2682140823
Extras - Nightly  crashed exactly as i pressed the 'Add to Firefox' button
(Assignee)

Comment 14

3 years ago
Spencer, thanks for all of your testing! I finally got my hands on a 3.2 GT-P6200, and I can reproduce the same crashes -- basically, this happens every time we try to show a system toast. This will be fixed by bug 1067429.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1067429
(Reporter)

Comment 15

3 years ago
Hey! Thank you guys for the help, Firefox 33.0's running fine on the device now. Very nice job, again THANK YOU
(Assignee)

Comment 16

3 years ago
And we appreciate your help! :)
You need to log in before you can comment on or make changes to this bug.