Closed Bug 987864 Opened 6 years ago Closed 5 years ago

crash in android.content.res.Resources$NotFoundException: Resource is not a ColorStateList (color or path): TypedValue{t=0x1/d=0x7f0d0077 a=3 r=0x7f0d0077} at android.content.res.Resources.loadColorStateList(Resources.java)

Categories

(Firefox for Android :: General, defect, critical)

29 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 34
Tracking Status
firefox29 --- wontfix
firefox30 --- wontfix
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
firefox34 --- fixed
fennec + ---

People

(Reporter: aaronmt, Assigned: bnicholson)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-ad5e7572-15bf-47d2-b53a-0a3822140324.
=============================================================

android.content.res.Resources$NotFoundException: Resource is not a ColorStateList (color or path): TypedValue{t=0x1/d=0x7f0d0077 a=3 r=0x7f0d0077}
	at android.content.res.Resources.loadColorStateList(Resources.java:2023)
	at android.content.res.TypedArray.getColorStateList(TypedArray.java:342)
	at android.widget.TextView.<init>(TextView.java:788)
	at android.widget.TextView.<init>(TextView.java:480)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:416)
	at android.view.LayoutInflater.createView(LayoutInflater.java:576)
	at com.android.internal.policy.impl.PhoneLayoutInflater.onCreateView(PhoneLayoutInflater.java:56)
	at android.view.LayoutInflater.onCreateView(LayoutInflater.java:644)
	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:669)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:724)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:479)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:391)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:347)
	at android.widget.Toast.makeText(Toast.java:247)
	at org.mozilla.gecko.GeckoApp$9.run(GeckoApp.java:814)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at android.app.ActivityThread.main(ActivityThread.java:4123)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:844)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:602)
	at dalvik.system.NativeStart.main(Native Method)

Seems to affect the GT-P6210 yet again
I have been tracking these crashers in bug 976375
See Also: → 1006631
426 crashes in the last week.
tracking-fennec: --- → ?
Assignee: nobody → bnicholson
tracking-fennec: ? → +
Let's try fixing this like we did in bug 970081
Output from "aapt l -a fennec-30.0.multi.android-arm.apk | grep 0x7f0d0077":

      spec resource 0x7f0d0077 org.mozilla.firefox:style/GeckoActionBar.Title: flags=0x00000400

According to http://developer.android.com/reference/android/R.style.html#TextAppearance_Holo_Widget_ActionBar_Title, this style was added in API level 13, but we reference it in the values-v11 folder [1], which will crash on API 11/12 devices.

The only thing throwing me off here is that the crash reports are showing Android version 13, so it seems like those devices wouldn't be affected. Either way, this style should be fixed.

[1] http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/resources/values-v11/styles.xml?rev=9387556cc4bf#83
Moves this style outside of values-v11. Also moves values-v14 -> values-v13 since the styles referenced here are all API 13 according to http://developer.android.com/reference/android/R.style.html.
Attachment #8454592 - Flags: review?(wjohnston)
Duplicate of this bug: 976375
Attachment #8454592 - Flags: review?(wjohnston) → review+
Note to self: request for uplift after this bakes a couple days.
Flags: needinfo?(bnicholson)
https://hg.mozilla.org/mozilla-central/rev/4b0180871f9a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Uplift ping! This is #3 crash on Fx32 (beta) and #7 crash on Fx31 (release)
Comment on attachment 8454592 [details] [diff] [review]
Move API 13 styles to values-v13 folder

(In reply to Mark Finkle (:mfinkle) from comment #10)
> Uplift ping! This is #3 crash on Fx32 (beta) and #7 crash on Fx31 (release)

Requesting uplift since this may help in some cases, but it's unclear how effective this fix actually is: https://bugzilla.mozilla.org/show_bug.cgi?id=1043116#c10. I'll see if Spencer is willing to try out more builds to pin these down.

Approval Request Comment
[Feature/regressing bug #]: unknown
[User impact if declined]: Frequent crashes on certain devices. It's unclear if/how much this patch actually helps, but it's a low risk change.
[Describe test coverage new/current, TBPL]: None
[Risks and why]: Low risk -- some resources are in the wrong directory for their required API level, and this fixes them.
[String/UUID change made/needed]: None
Attachment #8454592 - Flags: approval-mozilla-beta?
Attachment #8454592 - Flags: approval-mozilla-aurora?
Flags: needinfo?(bnicholson)
Attachment #8454592 - Flags: approval-mozilla-beta?
Attachment #8454592 - Flags: approval-mozilla-beta+
Attachment #8454592 - Flags: approval-mozilla-aurora?
Attachment #8454592 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.