Closed Bug 1043146 Opened 6 years ago Closed 5 years ago

Port to GTK3 for Thunderbird

Categories

(Thunderbird :: Build Config, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: m_kato, Unassigned)

References

Details

(Whiteboard: [fixed by another bug])

Attachments

(1 file, 1 obsolete file)

No description provided.
Attached patch GTK3 v1 (obsolete) — Splinter Review
Attached patch v1.1Splinter Review
Attachment #8461312 - Attachment is obsolete: true
Attachment #8461313 - Flags: review?(standard8)
See Also: → 882036
Comment on attachment 8461313 [details] [diff] [review]
v1.1

Review of attachment 8461313 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=Standard8
Attachment #8461313 - Flags: review?(standard8) → review+
Can you guys please explain what this does? Is this dependent on some Firefox/toolkit work too? Or will we have TB on GTK3 even before Firefox? Will this make TB only build with gtk3 and not on gtk2?
Depends on: gtk3
I feels migration to GTK3 is happening in Firefox already and also TB currently switched to using some GTK3 libraries (at least in my build).

Is this bug/patch still needed for anything or was the conversion done in another bug?
Flags: needinfo?(Pidgeot18)
(In reply to :aceman from comment #5)
> I feels migration to GTK3 is happening in Firefox already and also TB
> currently switched to using some GTK3 libraries (at least in my build).
> 
> Is this bug/patch still needed for anything or was the conversion done in
> another bug?

Conversion was done in another bug.
Flags: needinfo?(Pidgeot18)
I couldn't find any relevant checkin in comm-central so maybe TB already works from mozilla-central changes. Seamonkey has its of bug 1187222.

So let's close this as fixed, but remark that the attached patch was NOT checked in.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by another bug]
Duplicate of this bug: 1276466
I am slightly confused, I understand that Thunderbird is not yet using GTK3, yet this bug for it has been closed as "RESOLVED FIXED", so will Thunderbird start using GTK3 or not? What is the status of this?
Yes gtk3 is used, but not for thunderbired45. See bug 1245926.
GTK3 support did not ship in Thunderbird 45 - it was held back. It will be available in TB47 BETA shortly and future betas. Betas are available from http://www.mozilla.org/en-US/thunderbird/channel/
You need to log in before you can comment on or make changes to this bug.