Closed Bug 1043954 Opened 5 years ago Closed 5 years ago

Intermittent: fatal error C1083: Cannot open include file: 'prenv.h': No such file or directory

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla34

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

This is due to building in config/nspr during the compile tier retriggering an export (it's nspr's build system that does that, apparently), which re-exports headers, and creates a race with other compilations using the header in dist/include.
yeah, there's a libs:: export in nsprpub/config/rules.mk :(
Ah, I had forgotten about that feature of the nspr build system:

# libs - obsolete.  Now a synonym of "export".
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Comment on attachment 8463673 [details] [diff] [review]
Export nspr headers in a different directory during the target rule

Review of attachment 8463673 [details] [diff] [review]:
-----------------------------------------------------------------

So hacky. This new directory won't be packaged, will it?
Attachment #8463673 - Flags: review?(gps) → review+
(In reply to Gregory Szorc [:gps] from comment #4)
> So hacky. This new directory won't be packaged, will it?

No.
Duplicate of this bug: 1045386
https://hg.mozilla.org/mozilla-central/rev/87663bfc8524
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
QA Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.