Offline support for the packaged app

RESOLVED FIXED in 2014-09-16

Status

P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: andy+bugzilla, Assigned: scolville)

Tracking

2014-Q3
2014-09-16
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

4 years ago
When we are a packaged app, we'll need to detect if we are offline and display a nice error message.

This currently happens in yulelog:

https://github.com/mozilla/fireplace/blob/master/yulelog/main.js#L164-L178

We need to port that over. We'll also need to ensure that the string there is correctly translated so everyone can use it.
(Reporter)

Updated

4 years ago
Summary: Offline app support for the packaged app → Offline support for the packaged app
(Reporter)

Updated

4 years ago
Priority: -- → P2
(Reporter)

Updated

4 years ago
Assignee: nobody → scolville
Status: NEW → ASSIGNED
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1054244
Duplicate of this bug: 1054244
https://github.com/mozilla/fireplace/commit/2fd305aa3c9478e3b06d2981fd23cb1953ec1fbb
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-09-16
Testing notes:

 * Testing will require running the packaged app and turning off a connection to see the message.
 * Also to see the new-look date message, set an old date on the device (no functional changes purely cosmetic).

Comment 6

4 years ago
Dear Stuart,

I download the package from https://marketplace.firefox.com/packaged.webapp, but the version still is 20140422153147, can you tell me where I can download the new app?

Thanks.
The Marketplace package <https://marketplace.firefox.com/app/marketplace/> hasn't been updated since I last published a version on April 22:

    https://marketplace.firefox.com/developers/app/marketplace/status

Gaia <https://github.com/mozilla-b2g/gaia/blob/master/apps/marketplace.firefox.com/metadata.json> shows that we are in fact pointing to the correct app <https://marketplace.firefox.com/app/marketplace/>.

I haven't been keeping up with the Marketplace packaged-app process since then. Is it true that the package has not been updated in five months? Wil, can you confirm?
Flags: needinfo?(clouserw)

Comment 8

4 years ago
Dears,

How can I get the new app?
(In reply to Lingling Zhao from comment #8)
> Dears,
> 
> How can I get the new app?

It's not uploaded yet. We will update this bug when it's ready.
Kevin, can you answer comment 7?
Flags: needinfo?(kngo)
The new package tracking bug is https://bugzilla.mozilla.org/show_bug.cgi?id=897156 . When that is done we'll release a new package.
Flags: needinfo?(clouserw)

Updated

4 years ago
Flags: needinfo?(kngo)
You need to log in before you can comment on or make changes to this bug.