The Search app should have an overlay when launched from an app or browser window

RESOLVED FIXED in 2.1 S3 (29aug)

Status

Firefox OS
Gaia::Search
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: djabber, Assigned: daleharvey)

Tracking

unspecified
2.1 S3 (29aug)
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Bug raised on Vivien's WIP patch as per video in https://bugzilla.mozilla.org/show_bug.cgi?id=1039519 (comment 22)

Steps to reproduce from an app without navigation chrome: 
1) tap on rocket bar search field in status bar

Steps to reproduce from an app with navigation chrome/web site: 
1) tap on rocket bar search field in the expanded state

Expected results:
Search app shown as overlay above app/web page background. See visual design flow at: https://mozilla.box.com/s/g2of03hha34htbc4keep



Actual results:
Search app shown above wallpaper background
(Reporter)

Updated

3 years ago
Blocks: 946452
(Assignee)

Updated

3 years ago
Assignee: nobody → dale
(Assignee)

Comment 1

3 years ago
Created attachment 8477965 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23247

Uploading screenshots of the results, this is to fulfill https://mozilla.app.box.com/s/g2of03hha34htbc4keep

Francis I couldnt find exact colours so I guessed them, they seem darker on my screen than they do in device, but currently the overlay is .9 black, and the text input is rgba(31, 31, 31, 1); with no transparency

This means the homescreen shows the icons instead of the previous just background, its also somewhat possible to see the collapsed rocketbar behind but its very obscured, but you can still see enough of the app to give you some context
Attachment #8477965 - Flags: ui-review?(fdjabri)
Attachment #8477965 - Flags: review?(kgrandon)
(Assignee)

Comment 2

3 years ago
Created attachment 8477966 [details]
browser
(Assignee)

Comment 3

3 years ago
Created attachment 8477967 [details]
dialer
(Assignee)

Comment 4

3 years ago
Created attachment 8477968 [details]
home
Comment on attachment 8477965 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23247

+ Eric for possible ui-review, whoever gets to it first. Thanks!
Attachment #8477965 - Flags: ui-review?(epang)
Comment on attachment 8477965 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23247

Code looks good to me, thanks!
Attachment #8477965 - Flags: review?(kgrandon) → review+
Comment on attachment 8477965 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23247

Hi Dale...

Francis and Eric will really need to comment on this one but here's some preliminary feedback:

- In Eric's spec, the search results should move with the sheet (see screen 4 of the visual spec)
- If I had already visited a site, the link in the search results did not work at all. Could this be because it's already loaded in an existing browser window?
- The indeterminate loading indicator is the 2.0 indicator and does not match the 2.1 visual spec.

NI me if you have questions.

Rob
(Assignee)

Comment 8

3 years ago
Yeh thanks, those issues are unrelated to this patch, this purely changes the background of the saerch app once it is focused
For notes, here are the current bugs filed that I know about.

(In reply to Rob MacDonald [:robmac] from comment #7)
> Comment on attachment 8477965 [details] [review]
> - In Eric's spec, the search results should move with the sheet (see screen
> 4 of the visual spec)

Possibly tracked in an open but, not sure which.

> - If I had already visited a site, the link in the search results did not
> work at all. Could this be because it's already loaded in an existing
> browser window?

Bug 1045894

> - The indeterminate loading indicator is the 2.0 indicator and does not
> match the 2.1 visual spec.

Bug 941169
(Reporter)

Comment 10

3 years ago
I'll need Eric to comment on the colors and opacities, but from an interaction perspective, the overlay over the background is only meant to be used in the case of applications and browser windows. If the rocket bar is accessed from the home screen, it should show the wallpaper as a background, as is currently done. Is it possible to retain the current behavior when accessing the rocket bar from the homescreen, or do we need to one behavior for all cases?
Flags: needinfo?(dale)
(Assignee)

Comment 11

3 years ago
Its possible although I would recommend against it, this behaviour is nicely consistent and gives the user some affordance of where they currently are / how the rocketbar exists on top of applications.

We need to stop giving special cases to the behaviour of the homescreen, with replaceable homescreens we are going to have no control over how it is displayed or behaves and each special case will be at best odd but more typically completely broken, it is an application window and should be treated as such.

Ill edit this patch to the above behaviour but hopefully when seeing it we can follow up and remove the homescreen specific code
Flags: needinfo?(dale)
Comment on attachment 8477965 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23247

This looks good to me, I'm okay with keeping the transition the same for apps and homescreen.

By the way the visual spec is here on box:
https://mozilla.box.com/s/tas8lrljyf4khcegl3kg

Dale, you did a good job at guessing cause it's what I had in my spec :).

The transition of the RB still needs to be worked on (bug 1050868), but since this is covering where the overlay appears this looks good!

Thanks Dale!
Attachment #8477965 - Flags: ui-review?(epang) → ui-review+
(Reporter)

Updated

3 years ago
Attachment #8477965 - Flags: ui-review?(fdjabri) → ui-review+
(Assignee)

Comment 13

3 years ago
Awesome, thanks

https://github.com/mozilla-b2g/gaia/commit/c5e67119b517ad544816bea58bce455374b9b499
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Target Milestone: 2.1 S1 (1aug) → 2.1 S3 (29aug)
You need to log in before you can comment on or make changes to this bug.