Message sent to mailing list instead of contact

RESOLVED DUPLICATE of bug 1008718

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1008718
3 years ago
3 years ago

People

(Reporter: Alexander Bergmann, Unassigned)

Tracking

({regression})

31 Branch
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
If there is a mailing list and a contact with the very same name in your address book, a message composed to the contact is actually sent to the mailing list.

1) Create a new contact with the name "Test"
2) Create a new mailing list with the name "Test"
3) Write a new message and add the contact "Test" in the To field
4) Send the message using either "Send Later" or "Send Now"

Result: The message is sent to the mailing list instead of the contact!

If you use "Save as Draft" or "Save as Template", the saved message correctly contains the contact in the To field. The problem occurs only for "Send Later" or "Send Now".

There are a few reports about this problem in the German Thunderbird forum:
http://www.thunderbird-mail.de/forum/viewtopic.php?f=39&t=67194
http://www.thunderbird-mail.de/forum/viewtopic.php?f=31&t=67223

The problem might be related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=1044559
(Reporter)

Comment 1

3 years ago
Both the contact and the mailing list must be in the very same address book. If they are in different address books, everything works fine.
(Reporter)

Comment 2

3 years ago
I tried the suggested nightly builds as mentioned here: https://bugzilla.mozilla.org/show_bug.cgi?id=1008718#c6

2014-03-03: works!
ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/03/2014-03-03-03-02-04-comm-central/

2014-03-05: doesn't work!
ftp://ftp.mozilla.org/pub/thunderbird/nightly/2014/03/2014-03-05-03-02-02-comm-central/

It looks like the problem was introduced in 2014-03-05.

Comment 3

3 years ago
Thank you for testing and steps to reproduce. Let's mark it a dupe for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1008718
You need to log in before you can comment on or make changes to this bug.