Closed Bug 1047353 Opened 5 years ago Closed 5 years ago

Create a call information page for call log

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

RESOLVED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: rik, Assigned: rik)

References

Details

(Whiteboard: [planned-sprint c=6][in-sprint=v2.1-S2])

Attachments

(1 file)

This is based on the spec in bug 877971.
Blocks: 1047356
Target Milestone: --- → 2.1 S2 (15aug)
Assignee: nobody → anthony
Whiteboard: [planned-sprint c=6]
Assignee: anthony → drs+bugzilla
Whiteboard: [planned-sprint c=6] → [planned-sprint c=3]
Status: NEW → ASSIGNED
Assignee: drs+bugzilla → anthony
Status: ASSIGNED → NEW
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
Whiteboard: [planned-sprint c=3] → [planned-sprint c=3][in-sprint=v2.1-S2]
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
This will have to grow in scope or be broken up further.
Whiteboard: [planned-sprint c=3][in-sprint=v2.1-S2] → [planned-sprint c=][in-sprint=v2.1-S2]
Blocks: 1054995
Status: NEW → ASSIGNED
https://github.com/Rik/gaia/tree/call-info-1047353 is my current progress on this.
I've updated my branch.

This is still missing some tests and some styling but I'd like some feedback. Could you take a look Doug?
Flags: needinfo?(drs+bugzilla)
No longer blocks: 1054995
This looks pretty good to me, overall (feedback+). I don't see any serious problems, though there's lots of stylistic mistakes that I'll leave for actual review. I left some comments here:
https://github.com/mozilla-b2g/gaia/pull/23389

I was mostly focused on the design and test coverage. Thanks for posting the WIP.
Flags: needinfo?(drs+bugzilla)
Here's the first pull request. I didn't have time to re-read carefully so I might have left some stupid things.

I have no styling for the buttons. Maybe bug 1059336 will bring it for free. I'll add it otherwise.

I've also updated https://github.com/Rik/gaia/tree/call-info-1047353 without rebasing so that you can work on top of that for bug 1059336.
Attachment #8480757 - Flags: review?(drs+bugzilla)
Comment on attachment 8480757 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23435

This is really sloppy but the overall direction is fine. The test coverage is very good, though, as usual. We're missing 12/24hr format handling.

I've confirmed that I can handle all of the rest of the styling in bug 1059336, so don't worry about that.
Attachment #8480757 - Flags: review?(drs+bugzilla) → review-
Whiteboard: [planned-sprint c=][in-sprint=v2.1-S2] → [planned-sprint c=6][in-sprint=v2.1-S2]
Attachment #8480757 - Flags: review- → review?(drs+bugzilla)
Comment on attachment 8480757 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23435

Nits on the PR.
Attachment #8480757 - Flags: review?(drs+bugzilla) → review+
PR updated with nits, ready to land once bug 1035763 lands.
https://github.com/mozilla-b2g/gaia/commit/13a939343d52fe0ab990521ffdfc3a7b994c2776
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I think "cancelled" is the British spelling, this should be "Canceled". Also, the specs have "Canceled", one L.

Anyway, what does "canceled" mean in this context? I've started to call the subject and interrupted the call?
Flags: needinfo?(anthony)
Francesco: I've interrupted the call before the other party answered.
Flags: needinfo?(anthony)
Depends on: 1061623
Duplicate of this bug: 946220
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.