local folder name containg star (*) is empty after update to 31.0

RESOLVED DUPLICATE of bug 992879

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED DUPLICATE of bug 992879
3 years ago
3 years ago

People

(Reporter: Sir George, Unassigned)

Tracking

(Blocks: 1 bug, {dataloss, regression})

31 Branch
x86
Linux
dataloss, regression

Thunderbird Tracking Flags

(thunderbird31 affected)

Details

(Reporter)

Description

3 years ago
On July 23rd 2014 I upgraded Mozilla Thunderbird (originally installed from the tar.bz2-Installer, german localization) from 24.6.0 (20140610001341) to 31.0 (20140717165725).

On July 25th I noticed two of my folders under "Local Folders" appearing empty (named "a*Gesichtsbuch" and "a*StudiVZ"). [Not that I couldn't bare with the loss of their content... *SCNR*]
Note the special character "*" in these folders' names.
In the previous version both folders were normally accessible. They were created about 5 years ago(?).

I closed TB and backupped my mail profile. There the mail is still existent (data file as well as msf file). 
After the next application start both folders appear duplicated in the folder pane, but still empty.
Data is still available in data files in the profile, however you can't see any duplicate files there.

What puzzles me however are two empty folders with 9 characters long hexedecimal names as well as two corresponding msf files in my "Local Folders" folder in the profile, having a creation date identical to the time of the application update.

In the meantime I renamed datafiles and msf-files (replacing the asterisk by underscore) and both folders are accessible again.
The process wasn't straightforward, however. One of the "folders" still appeared empty (AFAIR) and finally had to be renamed to a name with two underscores... Also the filter rule for this folder wasn't deactivated automatically (the first folder's filter rule was deactivated).

Additional Version strings:
"Funnelcake January 2011"
"mozillamessaging04 - 1.0"
"Update channel: release"

Addons (state after Update):
British English Dictionary 1.19.1
Enigmail 1.6
Extra Folder Columns 1.1.5
Lightning 3.3
Provider for Google Calendar 0.32
Remove Duplicate Messages 0.1.13
Silvermel and Charamel XT 1.5.7

OS:
Debian Linux 6.0.10 (oldstable), Kernel 3.2.0-0.bpo.4-686-pae #1 SMP Debian 3.2.57-3+deb7u2~bpo60+1 i686 GNU/Linux
Desktop: Gnome 2.30.2

Remark: I had already commented about this behaviour in https://bugzilla.mozilla.org/show_bug.cgi?id=124287 but filed it separately now to assign some dominance to it.
(Reporter)

Updated

3 years ago
Blocks: 124287

Comment 1

3 years ago
apparently data is not completely lost, only you can't see it with w/ newer versions

regression 2014-03-21 -> 2014-03-22
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2014-03-21&enddate=2014-03-22+03%3A00%3A00

Only thing that touches this in c-c would be http://hg.mozilla.org/comm-central/rev/de8c29237377 (bug 984466 port)

So for a folder named "star*star":
 - after: star96775f81 and star96775f81.msf
 - before: star*star and star*star.msf
Status: UNCONFIRMED → NEW
status-thunderbird31: --- → affected
tracking-thunderbird31: --- → ?
Ever confirmed: true
Keywords: dataloss, regression
Summary: Folder with special character is empty after update to 31.0 → local folder name containg star (*) is empty after update to 31.0

Comment 2

3 years ago
See Bug 992879.  It appears you installed a not yet fixed version, and it's unclear when the fix was applied to beta/release.

Comment 3

3 years ago
Ah yes, I had a feeling i'd seen something similar fixed. Dping Confirming the star case is also indeed working on trunk.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
tracking-thunderbird31: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 992879
You need to log in before you can comment on or make changes to this bug.