Closed Bug 1048300 Opened 6 years ago Closed 5 years ago

Not obvious that browser menu is scrollable on small screen devices

Categories

(Firefox for Android :: General, defect)

34 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 35
Tracking Status
fennec + ---

People

(Reporter: krudnitski, Assigned: wesj)

References

Details

Attachments

(2 files)

Discovered when I was thought that the Twitter shared intent wasn't working (bug 1046204)

Since there are a lot of shared intents, new ones seem to get added to the bottom of the list. It isn't obvious that the list is scrollable in the current UI (at least on my Nexus 5).

Some options / questions to explore and consider for the likes of me (I can't be the only one like me!):
- when a new app has been added that harnesses Shared Intents, can they be added to the top of the list for visibility / promotion?
- can we do something unobtrusive but informative to let users know the list is scrollable? (although the scroll bar shows up, it does so briefly then disappears and isn't noticeable when you're focused on trying to find an intent to use)
- thoughts about surfacing a new intent in the 2nd QuickShare place when you've just added an app that supports Android intents?

Thanks!
(In reply to Karen Rudnitski [:kar] from comment #0)
> - can we do something unobtrusive but informative to let users know the list
> is scrollable? (although the scroll bar shows up, it does so briefly then
> disappears and isn't noticeable when you're focused on trying to find an
> intent to use)

This is Android displaying the scrollbar to let the user know that the view is scrollable.
I totally missed it on the multiple occasions that I was specifically trying to find an intent. Can we do anything to customise that a bit to help the user out? Especially for users who may nor be really familiar with intents, let alone new ones
(In reply to Karen Rudnitski [:kar] from comment #2)
> I totally missed it on the multiple occasions that I was specifically trying
> to find an intent. Can we do anything to customise that a bit to help the
> user out? Especially for users who may nor be really familiar with intents,
> let alone new ones

Not really. It's the Android convention, as is. I think we should WONTFIX this bug.
I don't agree. I think we need some other views here, ones that aren't living and breathing Android and their conventions. Even wen I knew what I was looking for, I missed it. How about other typical users who don't know what they are looking for (ie an intent to easily share cross apps)? It is easy to say that it is there when you are intimate with the OS, but I really feel this can be improved - and a small trick to increase browser engagement when you realize how easy it is to send discovered info from one spot to the next. 

I would like UX's thoughts to weigh in here as well.
Flags: needinfo?(ywang)
Flags: needinfo?(ibarlow)
Flags: needinfo?(alam)
One idea that came up during the Share to Firefox work:

Name the Share intent: "Add to Firefox". Share panel lists targets alphabetically. So "Add to Firefox" will be probably one of the top items on the screen.

A few other apps have been doing the same trick. "Add a Pin", "Add to Dropbox", "Add to Evernote". But the chances that a user have all of those installed is not super high. It should make Firefox appear on the first screen.
Flags: needinfo?(ywang)
Just want to make sure we're on the same page here, Karen -- is this the menu you're referring to? http://cl.ly/image/2N3z2Z1t2C2V
Flags: needinfo?(ibarlow)
yep
Yeah so this feedback has definitely come up before, even with the main Android menu. Some of this is "Android being Android", but I also think there are things we can do here to improve. 

--

1. Make the menu fill the height of the screen. 
Ours doesn't do this right now, and it's unclear why. I notice that other apps with menu contents that are taller than the height of the screen actually have the menu extend almost to the very bottom of the screen. The fact that ours stops higher up seems to create a sort of subtle but false sense that there is nothing beyond the bottom there, and that you can't scroll. Yes we show scrollbars, but it's subtle, and I think the shortness of the menu height may be creating a stronger misunderstanding than the flashing scrollbars can solve. 

--

2. Add some more visual indication that scrolling is possible. 
This is something that would require some visual design exploration. At its simplest, perhaps ensuring that the menu cuts off half of the last row item, to encourage people to scroll. Maybe a more pronounced 'fade' at the bottom of the menu too? Perhaps there are more elaborate solutions too though, like build animations that scroll the menu contents into view, to visually reinforce the idea that you can scroll. 

--

I would probably start by looking into #1 since that feels like a mistake, and then dive into #2 which is more of an embellishment
tracking-fennec: ? → +
Attached image prev_overflow_mock1.png
I know this bug pertains specifically to the "Share" menu, but here's an example of the "fade" that ibarlow mentioned (above) that I've also been looking at for the visual side of things :)

(not pictured in this example: extending the menu to the full height)
Flags: needinfo?(alam)
Summary: Not obvious that long Shared Intents list is scrollable → Not obvious that browser menu is scrollable on small screen devices
Duplicate of this bug: 1061263
I filed that duplicate; I very much agree with comment 8, point 1.

Gerv
I'd be ok with extending it the entire screen height as well (but still keep same amount of top padding we currently have to leave the browser UI exposed)
Not having it extend the full height and yet it being scrollable (with, thank you Android, although I can see why you did it) no visible scrollbar is just wrong :-). We shouldn't do that.

Gerv
Attached patch PatchSplinter Review
Heres a patch to not restrict the menu height anymore. Seems like there is good buy in there from UX.
Attachment #8483552 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8483552 [details] [diff] [review]
Patch

Review of attachment 8483552 [details] [diff] [review]:
-----------------------------------------------------------------

Does this look/behave ok if the natural menu height is bigger than the screen height? I expect PopupWindow to just do the right thing for us here, just asking :-)
Attachment #8483552 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/integration/fx-team/rev/a8f37943e690

Lets see if this helps. File a new bug if we want to do #2 from comment 8.
(In reply to Wesley Johnston (:wesj) from comment #14)
> Created attachment 8483552 [details] [diff] [review]
> Patch
> 
> Heres a patch to not restrict the menu height anymore. Seems like there is
> good buy in there from UX.

Is there a build I could check out? I'm wondering what the experience is like on larger phones.
https://hg.mozilla.org/mozilla-central/rev/a8f37943e690
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Duplicate of this bug: 764974
You need to log in before you can comment on or make changes to this bug.