Closed Bug 1061263 Opened 6 years ago Closed 6 years ago

Browser stuck in guest mode

Categories

(Firefox for Android :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1048300

People

(Reporter: gerv, Unassigned)

Details

Attachments

(1 file)

I appear to be stuck in Guest Mode - I entered it, but I don't have an "Exit Guest Mode" option on the menu, and yet I don't see my history or sync data or anything, even after restarting. This is with current Aurora. Let me know what more info you need.

Gerv
I have an 'Exit Guest Session' menu item for me (http://cl.ly/image/2C1z0S3H0e2b/o) on Aurora (09/01) on my Nexus 5 (4.4.4). Which device are you using?
Aha! So the issue is, the menu does not reach the bottom of the page, which makes one think that it's complete as seen, and yet it needs scrolling to reveal the missing menu item. (Another thing which makes it hard to detect is that it's below Help, which is traditionally the last item on the menu.) This is weird, because there is enough room to display the menu item if Firefox so chose. Also, it's not where the "Start Guest Session" menu item was, which was on the Tools menu.

The scrollability is not discoverable because there are no scrollbars until you actually start dragging it. I don't know if that's a thing about my Theme (stock CyanogenMod) or whether it's true on all Firefoxes.

The upshot of all this is that it makes it really seem like one is stuck in a Guest Session with no way to exit. Even a reboot doesn't fix it :-|

Gerv
Phew. Yes, it's come up before. Bug 1048300.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048300
aaronmt: I agree part of it is a duplicate, but I also think the Exit Guest Mode menu item should be where the Enter Guest Mode menu item is, either instead or perhaps additionally. So can we make this bug cover that? Or do you want a new one?

Gerv
Oh yes, new bug. The exit/enter item level should be the same.
Technically, we consciously choose to put the "Exit" on the top-level menu to make it easier to get out of Guest Browsing. LOL!

That said, I think our best hope for "fixing" this is bug 897711. I'd be OK with moving the "Exit Guest Browsing" menu to "Tools" once bug 897711 lands.
Bug 1061612 filed on moving the menu item after bug 897711 lands.

Gerv
You need to log in before you can comment on or make changes to this bug.