Closed Bug 1048362 Opened 6 years ago Closed 6 years ago

[Messages] Compose Panel refresh (highlight actionable part)

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

VERIFIED FIXED
2.1 S2 (15aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: julienw, Assigned: azasypkin)

References

Details

(Keywords: feature, Whiteboard: [tako][p=1])

Attachments

(1 file)

See attachment 8461328 [details] for the UX spec.
See attachment 8465323 [details] for the design spec.
User Story: (updated)
Hey Fang, Jenny, it's not very clear to me what the max height is, for the composer.

Especially:
* when there is no subject, should the composer's max height take all the available space
* when there is a subject, should the subject scroll _with_ the message input, or should it stay on top and only the message input is scrolling?
Flags: needinfo?(jelee)
Flags: needinfo?(fshih)
Hello Julien,

When there is no subject, as the composer expands, it can go as high as the lower edge of recipient field.

When there is a subject, as the composer expands, subject line would stick to top (see Messaging Compose.001.png right most screen), composer can go as high as the lower edge of subject line. 

Let me know if you need further clarification, thanks!
Flags: needinfo?(jelee)
Flags: needinfo?(fshih)
My second question about the scroll behavior still apply :) unless we keep the same behavior we have now?
Flags: needinfo?(jelee)
Subject should scroll with composer, once it reaches the lower edge of recipient field, subject line stays on top and message input can keep on scrolling. (This is actually our current behavior :p)
Flags: needinfo?(jelee)
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
QA Whiteboard: [COM=Gaia::SMS]
Summary: [Messages] Compose Panel refresh → [Messages] Compose Panel refresh (highlight actionable part)
Whiteboard: [tako] → [tako][p=1]
As discussed in our sprint planning, in this bug we won't change how the subject is behaving, because this is not needed for Tako. Filed bug 1048845 for this additional part.
See Also: → 1048845
Target Milestone: --- → 2.1 S2 (15aug)
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Comment on attachment 8470662 [details] [review]
GitHub pull request URL

Hey Steve, this patch does the following:

* Changes background for the composer container only;
* Removes "tap-on-container-to-focus-message-input" behaviour;
* Correctly aligns overlay notification messages depending on recipients panel mode (leftover from bug 1015841).

Thanks!
Attachment #8470662 - Flags: review?(schung)
Comment on attachment 8470662 [details] [review]
GitHub pull request URL

It works well overall, just some questions on github, thanks!
(In reply to Steve Chung [:steveck] from comment #8)
> Comment on attachment 8470662 [details] [review]
> GitHub pull request URL
> 
> It works well overall, just some questions on github, thanks!

Thanks! Replied on github.
Comment on attachment 8470662 [details] [review]
GitHub pull request URL

Except for one nice to have styling issue, I think the patch works fine, so r=me. Thanks!
Attachment #8470662 - Flags: review?(schung) → review+
(In reply to Steve Chung [:steveck] from comment #10)
> Comment on attachment 8470662 [details] [review]
> GitHub pull request URL
> 
> Except for one nice to have styling issue, I think the patch works fine, so
> r=me. Thanks!

Thanks for review! Try is green now!

Master: https://github.com/mozilla-b2g/gaia/commit/d4387c377f8652b3b68d5949723e758556d07fe2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
QA Contact: echang
Verified User story is fixed. UI modified according to spec.

Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1084166
Duplicate of this bug: 1084164
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.