Closed Bug 1030925 (sms-refresh-v2.1) Opened 6 years ago Closed 6 years ago

Support for Visual Refresh in Messaging

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: wmathanaraj, Assigned: steveck)

References

Details

(Keywords: feature, meta, Whiteboard: [2.1-feature-qa+])

User Story

As Mozilla I want to improve the visual design of the messaging application.

Messaging:
https://www.dropbox.com/sh/6tzfb2h4kqyfil0/AAA4eBYQVLqo4auRLbO86Zyda

PDF version:
https://www.dropbox.com/s/u8u9fstt6yad08g/FFOS_VisualRefresh_2.1_SMS_designscope.pdf

Attachments

(1 file)

No description provided.
blocking-b2g: --- → 2.1+
User Story: (updated)
Keywords: feature
NI Wilfred to add the link to the PDF export.
Flags: needinfo?(wmathanaraj)
for those who dont use keynote a PDF version posted up in the user story section
User Story: (updated)
Flags: needinfo?(wmathanaraj)
Should this bug use feature-b2g:2.1 instead of blocking-b2g:2.1+ ?
Flags: needinfo?(wmathanaraj)
blocking-b2g: 2.1+ → backlog
feature-b2g: --- → 2.1
Flags: needinfo?(wmathanaraj)
QA Whiteboard: [COM=Gaia::SMS]
Depends on: 1041760
Depends on: 1041765
Alias: sms-refresh-v2.1
Depends on: 990518
Keywords: meta
Attached Message visual refresh Specs

* Messaging Compose Overview
* Messaging Thread 

Thanks!
Depends on: 1048362
QA Whiteboard: [COM=Gaia::SMS] → [COM=Gaia::SMS][2.1-feature-qa+]
Depends on: 1048845
Flags: in-moztrap?(ashiue)
QA Contact: ashiue
QA Whiteboard: [COM=Gaia::SMS][2.1-feature-qa+] → [COM=Gaia::SMS]
Whiteboard: [2.1-feature-qa+]
Flags: in-moztrap?(ashiue) → in-moztrap?
QA Contact: ashiue
QA Contact: echang
Flags: in-moztrap? → in-moztrap?(echang)
Flags: in-moztrap?(echang) → in-moztrap-
Depends on: 1054989
Are we still targeting to land this in 2.1?
Flags: needinfo?(wilfredmanahan)
Assignee: nobody → schung
setting target to sprint3 for the meta bug. 
Dependent bugs are not all feature-b2g=2.1. 
If those are not being landed in 2.1, we should create another meta like "[improvement] VR on SMS" and still close this one after FL.
Target Milestone: --- → 2.1 S3 (29aug)
Flags: needinfo?(wilfredmanahan)
Confirmed with EM/EPM, and this can be landed before FL.
No longer depends on: 1048717
No longer depends on: 1041765
No longer depends on: 1003843
No longer blocks: 1041765
Depends on: 1041765
No longer depends on: 1048845
No longer depends on: 1054989
Close as fixed since main visual refresh patches were landed in master
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified User story is fixed. UI modified according to spec.

Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.