Closed Bug 1048458 Opened 5 years ago Closed 5 years ago

[B2G][2.1][Dialer] Calling a second number while another call is in progress cover's touchpad in Dialer app

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S3 (29aug)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rkunkel, Assigned: vingtetun)

References

Details

(Keywords: regression)

Attachments

(5 files)

Attached file logcat
Description:
When the user is currently in a phone call, pressing the phone+ icon bring the user to a screen that is obscured.
Once the user has their screen obscured, opening other apps; homescreen, lockscreen, camera, ect, will display their screen obscured as well.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140804040204
2) Open Dialer app, call a phone number
3) While phone call is in progress, press the 'phone+' icon to dial a second number
4) Observe the screen is obscured
  
Actual:
Touchpad screen is obscured
  
Expected: 
Touchpad is displayed fully and the user can dial out to other numbers

Environmental Variables:
Device: Flame 2.1
BuildID: 20140804040204
Gaia: 5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko: e6614d8d85f9
Version: 34.0a1
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
Notes:
Current workaround is to lock/unlock the phone while in the call to get rid of the obscured screen displaying.

Repro frequency: 100%
See attached: screenshot, logcat
Attached image Dialer
Attached image Lockscreen
Adding qawanted for branch checks
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
it seems like this might be yet another regression from bug 1042744 -  
if this issue goes to regression-window-wanted we should first check the window here: https://bugzilla.mozilla.org/show_bug.cgi?id=1048181#c4
QA Contact: ckreinbring
The bug repros on Buri 2.1
Actual result: After tapping the Add to Call button while in the middle of a call, most of the screen is obscured, preventing most functions from working properly.

Build ID: 20140804041427
Gaia: af9a0a24fb9f4c5ced3602bc14053bd49b136344
Gecko: 71497ed2e0db
Platform Version: 34.0a1
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0
Actual result: After tapping the Add to Call button while in the middle of a call, the touchpad, contact list and call log display properly.

Build ID: 20140804060132
Gaia: 4ab7384db7aee130be165a699472cc19405a4456
Gecko: 5e94ab16ec71
Platform Version: 32.0
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Summary: [B2G][2.1][Dialer] Calling a second number while another call is in progress cover's touchpad in Dailer app → [B2G][2.1][Dialer] Calling a second number while another call is in progress cover's touchpad in Dialer app
[Blocking Requested - why for this release]: regression and a difficult escape path - user must lock and unlock phone
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
Josh - Can you add the regressionwindow-wanted keyword here?
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+]
Regression window
Last working
Build ID: 20140730141509
Gaia: b67ddd7d40b52e65199478b8d6631c2c28fdf41d
Gecko: 005424a764da
Platform Version: 34.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
Build ID: 20140731150609
Gaia: 04ea7e1a4034a50d4a7a4f5b95a04a2ed8313908
Gecko: 104254bd1fc8
Platform Version: 34.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Note: This window is larger than normal due to the builds in between bring broken.
Working Gaia / Broken Gecko = No repro
Gaia: b67ddd7d40b52e65199478b8d6631c2c28fdf41d
Gecko: 104254bd1fc8
Broken Gaia / Working Gecko = Repro
Gaia: 04ea7e1a4034a50d4a7a4f5b95a04a2ed8313908
Gecko: 005424a764da
Gaia push log: https://github.com/mozilla-b2g/gaia/compare/b67ddd7d40b52e65199478b8d6631c2c28fdf41d...04ea7e1a4034a50d4a7a4f5b95a04a2ed8313908

B2G-inbound
Last working
Build ID: 20140730112305
Gaia: b67ddd7d40b52e65199478b8d6631c2c28fdf41d
Gecko: b3cbce8a2b87
Platform Version: 34.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
Build ID: 20140730122704
Gaia: 7198320c257340009a6d6d0e12e609058881d230
Gecko: 2e4c92e81490
Platform Version: 34.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: b67ddd7d40b52e65199478b8d6631c2c28fdf41d
Gecko: 2e4c92e81490
Broken Gaia / Working Gecko = Repro
Gaia: 7198320c257340009a6d6d0e12e609058881d230
Gecko: b3cbce8a2b87
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/b67ddd7d40b52e65199478b8d6631c2c28fdf41d...7198320c257340009a6d6d0e12e609058881d230
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
possibly broken by bug 1035279 ?  Aleh, can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(aleh.zasypkin)
(In reply to Joshua Mitchell [:Joshua_M] from comment #9)
> possibly broken by bug 1035279 ?  Aleh, can you take a look?

Mmm, I highly doubt that SMS-only change could do that :) I see several system-related commits in gaia push log that are more likely to be the culprit.
Flags: needinfo?(aleh.zasypkin)
Thanks, I'll try again

Aus - could this be caused by bug  1039631 ?
Flags: needinfo?(aus)
Joshua - It's highly unlikely that this would be caused by bug 1039631. We would be seeing things bleeding through from beneath if it was somehow related to it, we would not see it being obscured.
Flags: needinfo?(aus)
Vivien - Could this be caused by bug 1039519?
Flags: needinfo?(21)
Attached patch bug1048458.patchSplinter Review
Jason, this is likely related to the patch you mentioned.

CSS I love/hate you! One liner patch.
Attachment #8470022 - Flags: review?(kgrandon)
Flags: needinfo?(21)
Comment on attachment 8470022 [details] [diff] [review]
bug1048458.patch

Review of attachment 8470022 [details] [diff] [review]:
-----------------------------------------------------------------

I did not test this, but looking at the code makes sense. We need a test for this, but that seems difficult =/
Attachment #8470022 - Flags: review?(kgrandon) → review+
blocking, as it's identifiable regression
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S3 (29aug)
Duplicate of this bug: 1047255
Seems like we just need to land this.
Attached file Github pull request
Here is a pull request to see what the tree does and to get this landed.
Landed patch (with Vivien as author), https://github.com/mozilla-b2g/gaia/commit/96600e87c1805fd99a58880bd76bb937740f5e19
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → 21
This issue still reproduces on Flame 2.1kk(319mb), 2.2kk

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Ignore my last comment. Sorry
QA Whiteboard: [QAnalyst-Triage+] → [failed-verification]
This issue still reproduces on Flame 2.x. File a new Bug 1081530.
Verified issue is fixed on Flame 2.1 and Flame 2.2.

While in an active call, the user is able to add another call by tapping on the 'phone+' icon, and the dialer is not obscured.

Device: Flame 2.1
BuildID: 20141011094725
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: 65c0a4f2b0e9
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master
BuildID: 20141011031924
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.