Closed Bug 1048593 Opened 7 years ago Closed 7 years ago

[B2G][Marketplace][Home Button] Software Home Button overlays on the Install App page in Marketplace

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S3 (29aug)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jschmitt, Assigned: Eli)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached file log.txt
Description:
Software Home Button overlaps and covers buttons on the Install app popup in the Marketplace

Repro Steps:
1) Update a Flame to 20140804040204
2) Open Settings -> Device Information -> More Information and turn on Developer Menu
3) Open Developer Menu and turn on Software Home Button
4) Open Marketplace app
5) Select 'free' on an app

Actual:
Software Home Button overlays on the Install App page in Marketplace.

Expected:
Software Home Button does not overlay pages.

Environmental Variables:
Device: Flame Master 319MB
Build ID: 20140804040204
Gaia: 5fd14b8bc428f87f9b5cf9cc49f9a4f362a970fb
Gecko: e6614d8d85f9
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Issue occurs on 319MB

Notes:
Repro frequency: 100%
See attached: Screenshot, ogcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Component: Gaia → Gaia::System
[Blocking Requested - why for this release]:

The buttons can be tapped and they are functional but the user can't really tell what each button does and this just looks bad so nominating 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.1? → 2.1+
Assigning to Eli based on: https://bugzilla.mozilla.org/show_bug.cgi?id=1048620#c5
Assignee: nobody → eperelman
Status: NEW → ASSIGNED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Whiteboard: [systemsfe]
This patch modifies the system confirmation dialogs to account for the reduced screen height from enabling the software home button.
Attachment #8475400 - Flags: review?(timdream)
Attachment #8475400 - Flags: review?(fabien)
Attachment #8475400 - Flags: feedback?(mhenretty)
The root cause of this issue is that the System app is responsible for both the display of the software home button and the confirmation dialogs used by the Marketplace and did not account for the height of the software home button when calculating the dimensions and placement of these older confirmation dialogs.
Comment on attachment 8475400 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23047

Working for me. Fabien is not the right guy for a system change like this. You most likely want Alive or Etienne.
Attachment #8475400 - Flags: review?(timdream)
Attachment #8475400 - Flags: review?(fabien)
Attachment #8475400 - Flags: review?(etienne)
Attachment #8475400 - Flags: review?(alive)
Attachment #8475400 - Flags: feedback?(mhenretty)
Attachment #8475400 - Flags: feedback+
Comment on attachment 8475400 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23047

r=me with the comment on github addressed
Attachment #8475400 - Flags: review?(etienne)
Attachment #8475400 - Flags: review?(alive)
Attachment #8475400 - Flags: review+
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/c85f417d1fbb3feb8ecb845d5b5dbecb782deb43
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
This bug is verified fixed on the Flame 2.1 (319mb) and the Flame 2.2 (319mb)


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Result: Software Home Button does not overlay pages
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
Integration test added in bug 1077579.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.