Can't load page that redirects when e10s is enabled

RESOLVED WORKSFORME

Status

()

Core
Networking: Cookies
P1
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: blassey, Assigned: jduell)

Tracking

({dogfood, steps-wanted})

unspecified
dogfood, steps-wanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox34 affected)

Details

(Whiteboard: [necko-active], URL)

(don't judge me for my weakness with click bait)

When I try to load this page in an e10s window I get:

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept cookies.


and it loads fine in a non-e10s window
(Reporter)

Updated

4 years ago
Blocks: 997462
tracking-e10s: ? → +
status-firefox34: --- → affected
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
(Assignee)

Comment 1

4 years ago
Clicking on the link in regular (non-e10s) desktop gives me

  Sorry, there was a problem with this link: http://po.st/BU6L39
  You can now continue to this website, or go back to the page you were on before.
  Remember, only follow links from sources you trust.

If I click "follow link" I go to the "most unhealthy meals in America" page :)

I'm actually seeing the /exact same thing/ in an e10s window in nightly (OSX: 8/19 build), i.e. I can't reproduce.  Brad are you still seeing this?  What build/platform are you on?
Flags: needinfo?(blassey.bugs)
(Assignee)

Comment 2

4 years ago
Chris: Brad's on PTO--would you mind trying to repro?
Flags: needinfo?(cpeterson)
Good news and bad news:

I can't reproduce the problem in a clean profile, but I can reproduce the problem in my dirty default profile.. with and without e10s or any add-ons enabled! I see the following warnings in the Browser Console:

chrome://browser/content/browser.xul : Unable to run script because scripts are blocked internally.
chrome://browser/content/browser.xul : Unable to run script because scripts are blocked internally.

When I click this bug report's facebook.com URL in my default profile, the URL opens in a new tab, with or without e10s or any add-ons. In my clean profile, the URL opens in the same tab, replacing the Bugzilla page. about:support doesn't report any suspicious changed prefs that might be related.
Flags: needinfo?(cpeterson)

Comment 4

4 years ago
(In reply to Chris Peterson (:cpeterson) from comment #3)
> Good news and bad news:
> 
> I can't reproduce the problem in a clean profile, but I can reproduce the
> problem in my dirty default profile.. with and without e10s or any add-ons
> enabled! I see the following warnings in the Browser Console:
> 
> chrome://browser/content/browser.xul : Unable to run script because scripts
> are blocked internally.
> chrome://browser/content/browser.xul : Unable to run script because scripts
> are blocked internally.

I get these errors on every page load, even for data:text/html,hello.

> When I click this bug report's facebook.com URL in my default profile, the
> URL opens in a new tab, with or without e10s or any add-ons. In my clean
> profile, the URL opens in the same tab, replacing the Bugzilla page.
> about:support doesn't report any suspicious changed prefs that might be
> related.

That's just target=_blank not working right?  mconley knows whether tab bug has been fixed...
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #4)
> (In reply to Chris Peterson (:cpeterson) from comment #3)
> > Good news and bad news:
> > 
> > I can't reproduce the problem in a clean profile, but I can reproduce the
> > problem in my dirty default profile.. with and without e10s or any add-ons
> > enabled! I see the following warnings in the Browser Console:
> > 
> > chrome://browser/content/browser.xul : Unable to run script because scripts
> > are blocked internally.
> > chrome://browser/content/browser.xul : Unable to run script because scripts
> > are blocked internally.
> 
> I get these errors on every page load, even for data:text/html,hello.
> 
> > When I click this bug report's facebook.com URL in my default profile, the
> > URL opens in a new tab, with or without e10s or any add-ons. In my clean
> > profile, the URL opens in the same tab, replacing the Bugzilla page.
> > about:support doesn't report any suspicious changed prefs that might be
> > related.
> 
> That's just target=_blank not working right?  mconley knows whether tab bug
> has been fixed...

I think the difference that cpeterson is experiencing is related to the targeting of anchors when logged in and not logged into Bugzilla.

When you're logged in, links will open in a new tab. Logged out, and they open in the same browser.

Opening remote browsers via target="_blank" anchors should work from remote browsers. That was fixed in bug 989501. It is, however, busted if you're attempting to open a target="_blank" anchor in a non-remote browser in an e10s-window. That's bug 1047603.
(Assignee)

Comment 6

4 years ago
Chris,

OK, time for an HTTP log:

  https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

If you see this in single-process mode *and* e10s, you might as well just do a single-process log.

If you've got any passwords, important cookies, etc that might show up in the HTTP log from your "dirty" default profile :) then feel free to email me rather than posting in this bug. You can also probably nuke all of the log up until the URI in question: it's unlikely® that this bug depends on previous loads (though you never know)
Flags: needinfo?(blassey.bugs) → needinfo?(cpeterson)

Comment 7

4 years ago
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #4)
> (In reply to Chris Peterson (:cpeterson) from comment #3)
> > Good news and bad news:
> > 
> > I can't reproduce the problem in a clean profile, but I can reproduce the
> > problem in my dirty default profile.. with and without e10s or any add-ons
> > enabled! I see the following warnings in the Browser Console:
> > 
> > chrome://browser/content/browser.xul : Unable to run script because scripts
> > are blocked internally.
> > chrome://browser/content/browser.xul : Unable to run script because scripts
> > are blocked internally.
> 
> I get these errors on every page load, even for data:text/html,hello.

This part is now bug 1055802.
I emailed an HTTP log to Jason.
Flags: needinfo?(cpeterson)
(Assignee)

Comment 9

4 years ago
I don't see any redirects in the log Chris sent me (try grepping for "redir").  Also all the HTTP channels complete successfully, except one which is canceled (error status 0x804B0002 == NS_BINDING_ABORTED).  And I do see a load for the initial URI in this bug: it calls OnStart/OnStop (with nsresult=NS_OK), but it never calls OnDataAvailable, which is weird (it's odd to succeed but have no data).

Chris, just to confirm: you saw the error when you made this log?
(Assignee)

Updated

4 years ago
Flags: needinfo?(cpeterson)
Yes, I saw the error when I made that log, but your description of the log actually sounds like the problem I saw. When I clicked the facebook.com link, a new tab opens with the facebook.com URL but the page is blank/white. So the browser appears to not be loading the facebook.com page, so it never even attempts to redirect.

Unfortunately, I am no longer able to reproduce this redirect problem with my default profile today.
Flags: needinfo?(cpeterson)
Blocks: 879538
No longer blocks: 997462
Summary: Can't load page that redirects → Can't load page that redirects when e10s is enabled
Whiteboard: [e10s-m3]
Moving to M3 milestone. These bugs affect e10s dogfooding but Brad and Gavin did not think they were M2 blockers.
tracking-e10s: + → m3+
Adding "dogfood" keyword so this bug shows up on the e10s wiki's list of known issues:

https://wiki.mozilla.org/Electrolysis#Known_Issues
Keywords: dogfood

Comment 13

4 years ago
I can reproduce this issue with the following url
https://groups.google.com/forum/#!topic/provider-for-google-calendar/IyrLsL_EocI

Steps to reproduce
clean profile
enable e10s
load url https://groups.google.com/forum/#!topic/provider-for-google-calendar/IyrLsL_EocI
Click on the link in the topmost message

What happens:
A new blank tab opens and the link gets opened in the current tab.

What should happen:
Link opens in new tab, original tab reloads to original page. 
(this can be reproduced in a non e10s window)

mail me if you need more info or logs

Comment 14

4 years ago
Sorry folks the above is not completely correct.
I can reproduce this bug only if I set dom.ipc.processCount to something else than 1 
I used 5 in my testing.

Updated

4 years ago
tracking-e10s: m3+ → ?
Keywords: steps-wanted
(Reporter)

Updated

4 years ago
tracking-e10s: ? → +

Comment 15

4 years ago
I see this problem with HTTPS Everywhere enabled, and don't see it when HTTPS Everywhere is disabled (or e10s is disabled). Reproduced this morning with 4.0.2 and the 17 October Nightly, but I saw it previously with earlier version of both (4.0.0 or earlier for HTTPS Everywhere).

I saw the problem with many links (before I disabled ee10s). The link I was using to test this morning was a link from a Mozillazine Topic reply notification email message. I don't know whether the link is specific to my account.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2879993&p=13824191&e=13824191

HTTPS Everywhere doesn't have a rule for Mozillazine.
Duplicate of this bug: 1095769
Indeed, I also see erratic behavior with HTTPS Everywhere enabled but not when it's disabled.

STR:
1. Disable HTTPS Everywhere
2. From Wikipedia, search "key exchange", enter
3. Witness page load
4. Enable HTTPS Everywhere
5. Search "key exchange", enter

Expected:
Page to load

Actual:
Blank white page
The HTTPS Everywhere redirect problem is bug 997808.
tracking, but not m3+
Whiteboard: [e10s-m3]

Comment 20

3 years ago
Issue when click on activity feed item in activity feed plugin - Something Went Wrong - Firefox, IE

We were trying to implement activity feed plugin in our website(HTML5 version / Iframe version). But unfortunately we end up with an issue in Firefox (33.0.2 / 35.0.1 / etc ) and IE8, IE11, etc)

Issue: In firefox and IE, we get Something went wrong error message instead of going to concerned website URL. This happening When cookie, cache, etc are completely cleaned and browing the activity feed FB URL and click on any feed item, which will throws the Something went wrong erros in the Leaving facebook page. But if I browse the Activity feed plugin URL again and then click on any feed item, it opens the proper destination page. This we were able simulate 100% every time.

we can also simulate the same using below URL:
https://www.facebook.com/plugins/activity.php?site=timesofindia.indiatimes.com&height=700&max_age=2

1. Open Firefox, close other firefox instances if anything opened already.
2. Disable any plugins or extensions installed and active.
3. open a new tab with about:blank
4. close all tabs other than the blank tab, newif anything is open
5. clear cache (everthing, all details)
6. close firefox
7. open firefox
8. brow the URL: https://www.facebook.com/plugins/activity.php?site=timesofindia.indiatimes.com&height=700&max_age=2
9. Now we can see activity feed plugin with some feed items.
10. click on any feed item, now the firefox open a new tab with page "Leaving Facebook" and throws error "Something went wrong"
11. Now, in a new tab browse the same activity feed plugin URL https://www.facebook.com/plugins/activity.php?site=timesofindia.indiatimes.com&height=700&max_age=2
12. click on any item in this tab's activity feed item, the concerned timesofindia URL will be shown in new tab.

Kindly advise us.
(Reporter)

Updated

2 years ago
Blocks: 905436
there have been a number of other bugs listed as possible dups in this trail of tears.

jason, can you retest the test case and update the bug as to whether there is something here to do? (or reassign..)
Assignee: mrbkap → jduell.mcbugs
Whiteboard: [necko-active]
(Assignee)

Comment 22

2 years ago
Brad: looks like the page has changed, but there doesn't seem to be any difference now between e10s and non-e10s.  Reopen if there's still something to do here.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(blassey.bugs)
Resolution: --- → WORKSFORME
Yup, this redirect changed
Flags: needinfo?(blassey.bugs)
Blocks: 1245225
You need to log in before you can comment on or make changes to this bug.