Changes in locationbar aren't always executed with UnifiedComplete

RESOLVED DUPLICATE of bug 1050683

Status

()

Toolkit
Places
RESOLVED DUPLICATE of bug 1050683
3 years ago
3 years ago

People

(Reporter: Elbart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8470277 [details]
screencap.mp4

STR:
Have two URLs, one of them previously visited.
In my case:
http://en.wikipedia.org/wiki/Lens_flare
http://en.wikipedia.org/wiki/Google

In the locationbar, start to type en.wikipedia... and then select one of them with the arrow-buttons. Click somewhere in the empty tabbar to close the results-pane.

Replace the last part of the URL with the previously copied string. In my case: "Google" replaces "Lens_flare".

Hit enter.

ER:
The URL with the replaced string is visited.
In my case, the wikipedia-page for Google should be visited.

AR:
The initially selected URL is visited.
In my case that the page for lens flare.


Setting browser.urlbar.unifiedcomplete to false reverts this problem.
(Reporter)

Updated

3 years ago
Blocks: 995091

Comment 1

3 years ago
This is a bit hard to reproduce (probably because I'm too slow), but I've been able to reproduce it once.
Status: UNCONFIRMED → NEW
Ever confirmed: true
the behavior changed recently with bug 1050683 and bug 1051830, would be good to know if this can still be reproduced in currently Nightly builds.
(Reporter)

Comment 3

3 years ago
Last bad revision: 70be728521e3 (2014-08-10)
First good revision: a9b43778f0c2 (2014-08-11)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=70be728521e3&tochange=a9b43778f0c2

Last bad revision: e4f87d728f9d
First good revision: bb954a9a154f
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e4f87d728f9d&tochange=bb954a9a154f

So probably bug 1050683 fixed it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050683
You need to log in before you can comment on or make changes to this bug.