UnifiedComplete is missing nsIAutoCompleteSearchDescriptor

RESOLVED FIXED in mozilla34

Status

()

Toolkit
Places
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
mozilla34
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Looks like I forgot to add it, it's a very trivial oneline patch.

Marco, could you please add this to the current iteration? It will take just a few minutes. (yes, I know about the cap, no worries)
(Assignee)

Updated

3 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Blocks: 1049506

Updated

3 years ago
Iteration: --- → 34.2
QA Whiteboard: [qa?]

Updated

3 years ago
Flags: firefox-backlog+
(Assignee)

Comment 1

3 years ago
Created attachment 8470043 [details] [diff] [review]
patch v1
Attachment #8470043 - Flags: review?(ttaubert)
Attachment #8470043 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 2

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/c61532028ee4
QA Whiteboard: [qa?] → [qa-]
Target Milestone: --- → mozilla34

Comment 3

3 years ago
Backed out for failures like:
https://tbpl.mozilla.org/php/getParsedLog.php?id=45541626&tree=Fx-Team

remote:   https://hg.mozilla.org/integration/fx-team/rev/17408fd769e2
(Assignee)

Comment 4

3 years ago
bah, clearly something is funky with the test
(Assignee)

Comment 5

3 years ago
Created attachment 8470343 [details] [diff] [review]
patch v2

This has not been as trivial as I was expecting, but a good companion for a Friday night.

The test hit a race condition that cause a search to cancel itself, good to fix it. On the positive side this means the patch is doing what I was expecting, thus remove the urlbar delay.

It's currently running on Try.

https://tbpl.mozilla.org/?tree=Try&rev=8dd1240eeff
Attachment #8470343 - Flags: review?(ttaubert)
Comment on attachment 8470343 [details] [diff] [review]
patch v2

Review of attachment 8470343 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8470343 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 7

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/eae2c3cb8a19

Comment 8

3 years ago
https://hg.mozilla.org/mozilla-central/rev/eae2c3cb8a19
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1049506
(Assignee)

Updated

3 years ago
Attachment #8470043 - Attachment is obsolete: true

Updated

3 years ago
Depends on: 1051777

Updated

3 years ago
Duplicate of this bug: 1051047
You need to log in before you can comment on or make changes to this bug.