Quick search for sender takes minute(s)

RESOLVED DUPLICATE of bug 573325

Status

RESOLVED DUPLICATE of bug 573325
5 years ago
5 years ago

People

(Reporter: krichter722, Unassigned)

Tracking

(Depends on: 1 bug)

31 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

activated the "sender" toggle button and deactivated all others in the quick search widget for an IMAP account. Searched for a mail address.


Actual results:

The search took 1 minute 13 seconds although there not more than 10000 mails in the account. Currently the "Searching..." label is displayed for the time menitoned above.


Expected results:

 This should take an unnoticable instant with a prefix tree/trie (patricia tries for compressed data) with complexity O(length of search input). If IMAP server search is involved which might take longer there should be a feedback inidicating when the local search is finished and that the server search still running.
Thanks krichter for reporting this.

Looking at the "Searching..." label in status bar at the bottom is NOT a safe way of measuring the search time. "Searching..." will stay in status bar until overwritten by next status bar message (known bug), while the actual search might have completed long ago. A better indicator is the yellow background color in the message list - quick search is finished when the yellow goes away.
(Reporter)

Updated

5 years ago
Depends on: 1051901
(Reporter)

Comment 2

5 years ago
Thanks for your comment @Thomas D. I guess this changes the issue in its meaning. It's no longer a buggy implementation of the search but an issue regarding the feedback. 

As I wanted to do it for a long time and don't see any reasonable changes to the "single label/single progress bar" system TB has right now (the "Searching..." could be overwritten at any time and is therefore not reliable to monitor the progress of the quick search widget in my opinion), I proposed a message queue widget/management system in 1051901 and added a dependency to it - it's a long shot, but it would solve a lot of feedback problems including the one referred to by this issue.
(In reply to krichter722 from comment #2)
> Thanks for your comment @Thomas D. I guess this changes the issue in its
> meaning. It's no longer a buggy implementation of the search but an issue
> regarding the feedback.

So I think that makes this a duplicate of bug 573325 - feel free to reopen if not.

Thanks for reporting back and filing that other bug, nice idea (I recall some bugs which were around the same idea, but no time to search right now).

> I proposed a message queue widget/management system in 1051901 and added a
> dependency to it - it's a long shot, but it would solve a lot of feedback
> problems including the one referred to by this issue.

Try Tools > Activity Manager - that's pretty close to a message queue system, and might be part of the solution you envisage. Yeah, message queue widget on status bar would be really cool, all the status messages are too volatile as you point out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573325
You need to log in before you can comment on or make changes to this bug.