Closed Bug 1051606 Opened 6 years ago Closed 5 years ago

Create a preference to change pocketsphinx parametrs (decoder options, log and raw file save, and etc)

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: anatal, Assigned: anatal)

References

(Blocks 1 open bug)

Details

(Whiteboard: [webspeechapi])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715215003
Blocks: 1051148
OS: Linux → All
Hardware: x86_64 → All
Blocks: 1067689
No longer blocks: 1051148
Whiteboard: [webspeechapi]
Assignee: nobody → anatal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1180668
Blocks: Meta-Vaani
No longer blocks: 1180668
Kelly, maybe this won't work. 

I remember long time ago, when I was still on GSoC and had just started pocketsphinx integration, that Steven Lee from Taipei media team said that everything on content/ (that today is dom/) wasn't allowed to access filesystem directly using FILE object (that's the way pocketsphinx writes the utterances to the disk), because b2g process couldn't do it. 

I found one email from 7/23/14 and quote him : 
----
"Does the file need big space to save? If not, could you write the data in memory? Or writing to a file is done by pocketsphinx? If it is, then you need to discuss with the reviewer how to save the file, ex ask b2g process to save the the data to file. The current implementation, by promoting content process as root, is not feasible. You have to solve it first."
----

While I evolved in the project, I ended moving to complete in-memory approach (the audio is stored as bytes in vector, and I patched pocketsphinx to accept grammar as bytes too, and these are the one of the reasons that recognizes so fast), and I didn't had to deal with this limitation anymore. 

I don't know if this changed, but as SLee left, I gonna ask SC that probably knows more about it.
Flags: needinfo?(schien)
The access restriction is applied on which process of that code runs, not on the folder where the code is in. As long as the code accessing preference runs on parent process, you're good to go.
Flags: needinfo?(schien)
We addressed this request in a different way than saving locally. We'll stream the audio to the server attaching the same DomeMediaStream from SpeechRecognition object to a MediaRecorder.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.