Closed Bug 1172875 (Meta-Vaani) Opened 6 years ago Closed 4 years ago

Creation of a Voice Based Personal Assistant "Vaani"

Categories

(Firefox OS Graveyard :: Gaia::VoiceControl, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kdavis, Unassigned)

References

Details

(Whiteboard: [webspeechapi][vaani][systemsfe])

User Story

(Note: Vaani team has committed to a set of commands for v2.5. We are also reviewing additional items for feasibility in 2.5 timeframes as "stretch" goals.)

As a user / developer, I would like to use following commands with voice control. 

2.5 committed Goals:  
-- Call <contact>
-- Call <number>
-- Set an alarm
-- Set a timer
-- Open <App>
-- Languages: English (baseline). Post-loaded from mktplace: Spanish, French
-- Settings in the app for enabling Community contributions (record samples with language/accent for Mozilla’s Amazon cloud)

2.5 Stretch Goals: 
-- Play music + basic controls
-- Check messages (count of vmails, unread emails)
-- Check schedule 
-- Check Weather 

Visual Spec:
https://mozilla.box.com/s/s5fbx6pcsqu6usgr15k3k81mtcaoxqa6

User Flows:
http://bit.ly/1GgtnG8

Attachments

(2 files)

This is a meta bug for the creation of "Vaani", a voice based personal assistant.

All work related to the creation of Vaani will exist as bugs in the dependency
tree of this bug.
Depends on: 1172878
Depends on: 1172879
Depends on: 1172881
Depends on: 1172883
Is Vanni part of the Ignite initiative?
Whiteboard: [webspeechapi][vaani]
(In reply to Kan-Ru Chen [:kanru] from comment #3)
> Is Vanni part of the Ignite initiative?

Yes. It's part of the "voice recognition services" portion of Ignite.
Component: General → Gaia::VoiceControl
Duplicate of this bug: 1049931
Thanks Kelly for attaching the specs to the bug!

I've also added the links to the visual specs and user flows in a user story.  The latest versions will always be updated to these links.
User Story: (updated)
Alias: [Meta]Vaani
Summary: Creation of a Voice Based Personal Assistant "Vaani" → [Meta] Creation of a Voice Based Personal Assistant "Vaani"
Alias: [Meta]Vaani → [Meta-Vaani]
Summary: [Meta] Creation of a Voice Based Personal Assistant "Vaani" → Creation of a Voice Based Personal Assistant "Vaani"
Alias: [Meta-Vaani] → Meta-Vaani
No longer depends on: 1172878
Depends on: 1178264
Depends on: 1178273
Depends on: 1178275
Depends on: 1178276
Depends on: 1178279
Depends on: 1178280
Depends on: 1178281
Whiteboard: [webspeechapi][vaani] → [webspeechapi][vaani][systemsfe]
Depends on: 1171043
Depends on: 1178287
Depends on: 1178288
Depends on: 1178318
Depends on: 1178322
Depends on: 1178326
Depends on: 1178332
Depends on: 1180113
Depends on: 1162507
Depends on: 1172878
User Story: (updated)
See Also: → 1180668
User Story: (updated)
User Story: (updated)
User Story: (updated)
No longer depends on: 1178326
User Story: (updated)
Depends on: 1184886
As a result of Bug 1180710 Comment 14 language packs, in particular language packs'
support of different speech recognition languages, will no longer be in Fx OS 2.5.

So, either we will have to find a different way of supporting other languages or we
will have to support a single language.

Right now I am not sure what our path forward on this should be.
Blocks: 1180668
Depends on: 1051604
No longer depends on: 1172881
No longer depends on: 1184886
Depends on: 1051606
Depends on: 1198272
Depends on: 1184886
Depends on: 1202989
Depends on: 1206323
Depends on: 1214092
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.